summaryrefslogtreecommitdiff
path: root/user/scummvm
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 09:00:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 09:00:59 +0000
commit3a5eb59dc72572666a8d51a489cb396f23526541 (patch)
tree26caeb985595194b928a3312fecb9b16a31523eb /user/scummvm
parent24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c (diff)
downloadpackages-3a5eb59dc72572666a8d51a489cb396f23526541.tar.gz
packages-3a5eb59dc72572666a8d51a489cb396f23526541.tar.bz2
packages-3a5eb59dc72572666a8d51a489cb396f23526541.tar.xz
packages-3a5eb59dc72572666a8d51a489cb396f23526541.zip
user/*: Modernise / fix syntax / deps / code
Diffstat (limited to 'user/scummvm')
-rw-r--r--user/scummvm/APKBUILD9
-rw-r--r--user/scummvm/fluidsynth.patch37
2 files changed, 42 insertions, 4 deletions
diff --git a/user/scummvm/APKBUILD b/user/scummvm/APKBUILD
index 129c202b5..e9b6b2074 100644
--- a/user/scummvm/APKBUILD
+++ b/user/scummvm/APKBUILD
@@ -13,10 +13,11 @@ makedepends="alsa-lib-dev curl-dev flac-dev fluidsynth-dev freetype-dev
libjpeg-turbo-dev libmpeg2-dev libogg-dev libpng-dev libvorbis-dev
sdl-dev zlib-dev"
subpackages="$pkgname-doc"
-source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2"
+source="https://www.scummvm.org/frs/scummvm/$pkgver/scummvm-$pkgver.tar.bz2
+ fluidsynth.patch
+ "
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--disable-readline
@@ -24,8 +25,8 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="5f91a65cdde62e6f996ae8a983d212f3d04edcf1ce3ab0e5273f1dfce155724912f386025959f5b2cc6ba566432845d929503f80f0cee513c774d5e04dafde1f scummvm-2.1.0.tar.bz2"
+sha512sums="5f91a65cdde62e6f996ae8a983d212f3d04edcf1ce3ab0e5273f1dfce155724912f386025959f5b2cc6ba566432845d929503f80f0cee513c774d5e04dafde1f scummvm-2.1.0.tar.bz2
+20b20a68263c691efb7db83aa8132ec980f2732af728300a641d30c4035d4aa8fcf6efdcebb8c5b924e68fafb50e39ed1825cd64d1f81145259493e858bd50f4 fluidsynth.patch"
diff --git a/user/scummvm/fluidsynth.patch b/user/scummvm/fluidsynth.patch
new file mode 100644
index 000000000..a815cc705
--- /dev/null
+++ b/user/scummvm/fluidsynth.patch
@@ -0,0 +1,37 @@
+Backport of upstream commits:
+
+* 8593a9e
+* 68758a8
+* 8014f12
+
+--- scummvm-2.1.0/audio/softsynth/fluidsynth.cpp.old 2019-10-04 21:41:29.000000000 +0000
++++ scummvm-2.1.0/audio/softsynth/fluidsynth.cpp 2020-01-13 08:21:46.705102910 +0000
+@@ -20,10 +20,18 @@
+ *
+ */
+
+-#include "common/scummsys.h"
++#if defined(HAVE_CONFIG_H)
++#include "config.h"
++#endif
+
+ #ifdef USE_FLUIDSYNTH
+
++// Fluidsynth v2.1+ uses printf in one of it's headers,
++// include/fluidsynth/log.h around line 82 so need to include this
++// prior scummsys.h inclusion and thus forbidden.h
++#include <fluidsynth.h>
++
++#include "common/scummsys.h"
+ #include "common/config-manager.h"
+ #include "common/error.h"
+ #include "common/system.h"
+@@ -35,8 +43,6 @@
+ #include "backends/platform/ios7/ios7_common.h"
+ #endif
+
+-#include <fluidsynth.h>
+-
+ class MidiDriver_FluidSynth : public MidiDriver_Emulated {
+ private:
+ MidiChannel_MPU401 _midiChannels[16];