summaryrefslogtreecommitdiff
path: root/user/sox
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 23:38:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-21 23:38:00 -0500
commitf652af7585e2a9a9f4b1245cb4d097debe781bd8 (patch)
tree5a8a7ab81d48936b0ce5130c263a8ead9be22954 /user/sox
parente4e01460aecb95a67e06c9ff698c52b1d3e3107c (diff)
downloadpackages-f652af7585e2a9a9f4b1245cb4d097debe781bd8.tar.gz
packages-f652af7585e2a9a9f4b1245cb4d097debe781bd8.tar.bz2
packages-f652af7585e2a9a9f4b1245cb4d097debe781bd8.tar.xz
packages-f652af7585e2a9a9f4b1245cb4d097debe781bd8.zip
user/sox: pull in, modernise, fix license
Diffstat (limited to 'user/sox')
-rw-r--r--user/sox/APKBUILD50
-rw-r--r--user/sox/disable-pipe-file-detection.patch11
-rw-r--r--user/sox/sox-dynamic.patch12
3 files changed, 73 insertions, 0 deletions
diff --git a/user/sox/APKBUILD b/user/sox/APKBUILD
new file mode 100644
index 000000000..efcdeba1e
--- /dev/null
+++ b/user/sox/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Maintainer:
+pkgname=sox
+pkgver=14.4.2
+pkgrel=1
+pkgdesc="Convert between various audio formats"
+url="http://sox.sourceforge.net/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0+ AND LGPL-2.1+ AND MIT AND BSD-1-Clause"
+makedepends="alsa-lib-dev ffmpeg-dev file-dev flac-dev gsm-dev lame-dev
+ libao-dev libid3tag-dev libmad-dev libogg-dev libsamplerate-dev
+ libsndfile-dev libvorbis-dev opusfile-dev pulseaudio-dev
+ autoconf automake libtool"
+depends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ disable-pipe-file-detection.patch
+ sox-dynamic.patch
+ "
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-dyn-default \
+ --with-distro="${DISTRO_NAME:-Adélie Linux}"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ ln -sf play "$pkgdir"/usr/bin/rec
+ ln -sf ../man1/sox.1.gz "$pkgdir"/usr/share/man/man7/soxeffect.7
+ rm "$pkgdir"/usr/lib/sox/*.a
+}
+
+sha512sums="b5c6203f4f5577503a034fe5b3d6a033ee97fe4d171c533933e2b036118a43a14f97c9668433229708609ccf9ee16abdeca3fc7501aa0aafe06baacbba537eca sox-14.4.2.tar.gz
+eb90574a7c174a32ac77aa09a2bb4ebbea407463517e55943e16efd8b7c52393c6b7a6b2778d696f708627271f4d2212221a85fc50d2500b32143139a37a957a disable-pipe-file-detection.patch
+3950834db26faa0523006c6fd8e0769d080518f127d345c8ec9bf53e9db8a6bd67cd724f0f86492aaf9ce6ede2dfbde167049768f35c14ef3c2b96e7e00302b6 sox-dynamic.patch"
diff --git a/user/sox/disable-pipe-file-detection.patch b/user/sox/disable-pipe-file-detection.patch
new file mode 100644
index 000000000..3d2a854f7
--- /dev/null
+++ b/user/sox/disable-pipe-file-detection.patch
@@ -0,0 +1,11 @@
+--- sox-14.4.2/src/formats.c.old 2014-10-27 02:55:50.000000000 +0000
++++ sox-14.4.2/src/formats.c 2018-07-22 04:36:34.380000000 +0000
+@@ -422,7 +422,7 @@
+ /* To fix this #error, either simply remove the #error line and live without
+ * file-type detection with pipes, or add support for your compiler in the
+ * lines above. Test with cat monkey.wav | ./sox --info - */
+- #error FIX NEEDED HERE
++ /* #error FIX NEEDED HERE */
+ #define NO_REWIND_PIPE
+ (void)fp;
+ #endif
diff --git a/user/sox/sox-dynamic.patch b/user/sox/sox-dynamic.patch
new file mode 100644
index 000000000..94ac6a282
--- /dev/null
+++ b/user/sox/sox-dynamic.patch
@@ -0,0 +1,12 @@
+diff -Naur sox-14.4.2-orig/src/Makefile.am sox-14.4.2/src/Makefile.am
+--- sox-14.4.2-orig/src/Makefile.am 2015-04-08 17:11:09.555343005 -0400
++++ sox-14.4.2/src/Makefile.am 2015-04-08 17:11:25.115317153 -0400
+@@ -95,7 +95,7 @@
+
+ libsox_la_CFLAGS = @WARN_CFLAGS@
+ libsox_la_LDFLAGS = @APP_LDFLAGS@ -version-info @SHLIB_VERSION@ \
+- -export-symbols-regex '^(sox_.*|lsx_(check_read_params|(close|open)_dllibrary|(debug(_more|_most)?|fail|report|warn)_impl|eof|fail_errno|filelength|find_(enum_(text|value)|file_extension)|getopt(_init)?|lpc10_(create_(de|en)coder_state|(de|en)code)|raw(read|write)|read(_b_buf|buf|chars)|realloc|rewind|seeki|sigfigs3p?|strcasecmp|tell|unreadb|write(b|_b_buf|buf|s)))$$'
++ -export-symbols-regex '^(sox_.*|lsx_(error|flush|check_read_params|(close|open)_dllibrary|(debug(_more|_most)?|fail|report|warn)_impl|eof|fail_errno|filelength|find_(enum_(text|value)|file_extension)|getopt(_init)?|lpc10_(create_(de|en)coder_state|(de|en)code)|raw(read|write)|read(_b_buf|buf|chars)|realloc|rewind|seeki|sigfigs3p?|strcasecmp|tell|unreadb|write(b|_b_buf|buf|s)))$$'
+
+ if HAVE_WIN32_LTDL
+ libsox_la_SOURCES += win32-ltdl.c win32-ltdl.h