summaryrefslogtreecommitdiff
path: root/user/spack/clingo-explicit-libatomic.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-11-02 10:37:45 -0500
committerZach van Rijn <me@zv.io>2023-11-02 10:50:54 -0500
commit843d1bfd0f5f0fbb008728fe68e62c017d89d84a (patch)
tree1e6f413067a4543f22c5d25a7a2bc8e66a5c4538 /user/spack/clingo-explicit-libatomic.patch
parent6ee3e1a9af10e598569f8497d9389fc2c380a68c (diff)
downloadpackages-843d1bfd0f5f0fbb008728fe68e62c017d89d84a.tar.gz
packages-843d1bfd0f5f0fbb008728fe68e62c017d89d84a.tar.bz2
packages-843d1bfd0f5f0fbb008728fe68e62c017d89d84a.tar.xz
packages-843d1bfd0f5f0fbb008728fe68e62c017d89d84a.zip
user/spack: support all targets.
* ppc requires explicit -latomic; this patch fixes adelie/spack#6 for both the initial clingo bootstrap and 'spack install clingo' * fix regression where all targets not supported by golang/rust could not be bootstrapped; this patch fixes adelie/spack#7 * pmmx still requires the archspec patch; fixes #794 * enable debug output during bootstrap build * disable buildcache by default (do not attempt to pull binaries) * fix package paths
Diffstat (limited to 'user/spack/clingo-explicit-libatomic.patch')
-rw-r--r--user/spack/clingo-explicit-libatomic.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/user/spack/clingo-explicit-libatomic.patch b/user/spack/clingo-explicit-libatomic.patch
new file mode 100644
index 000000000..6a1d1a0aa
--- /dev/null
+++ b/user/spack/clingo-explicit-libatomic.patch
@@ -0,0 +1,12 @@
+diff --git a/var/spack/repos/builtin/packages/clingo/package.py b/var/spack/repos/builtin/packages/clingo/package.py
+index ab5fe9a043..8a31208850 100644
+--- a/var/spack/repos/builtin/packages/clingo/package.py
++++ b/var/spack/repos/builtin/packages/clingo/package.py
+@@ -120,6 +120,7 @@ def cmake_args(self):
+ "-DCLINGO_BUILD_WITH_PYTHON=ON",
+ "-DPYCLINGO_USER_INSTALL=OFF",
+ "-DPYCLINGO_USE_INSTALL_PREFIX=ON",
++ "-DCMAKE_CXX_STANDARD_LIBRARIES=-latomic",
+ self.cmake_py_shared,
+ ]
+ if self.spec["cmake"].satisfies("@3.16.0:"):