summaryrefslogtreecommitdiff
path: root/user/spectacle/qt5.9.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-19 07:33:49 +0000
commite4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e (patch)
tree765c43e23668dd79b2dab94029fb96813c7f824e /user/spectacle/qt5.9.patch
parent6162950549630e75dd1f2d3037cabd23559b2822 (diff)
downloadpackages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.gz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.bz2
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.tar.xz
packages-e4f5e187a9eaa4b7a2d2c33c18ea5c020aece30e.zip
user/*: KDE Applications 19.04.0
Diffstat (limited to 'user/spectacle/qt5.9.patch')
-rw-r--r--user/spectacle/qt5.9.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/user/spectacle/qt5.9.patch b/user/spectacle/qt5.9.patch
new file mode 100644
index 000000000..aa830f86b
--- /dev/null
+++ b/user/spectacle/qt5.9.patch
@@ -0,0 +1,23 @@
+--- spectacle-19.04.0/CMakeLists.txt.old 2019-04-12 00:06:23.000000000 +0000
++++ spectacle-19.04.0/CMakeLists.txt 2019-04-18 22:57:10.598054362 +0000
+@@ -11,7 +11,7 @@
+ # Spectacle project
+ project(Spectacle VERSION ${SPECTACLE_VERSION})
+
+-set(QT_MIN_VERSION "5.10.0")
++set(QT_MIN_VERSION "5.9.0")
+ set(KF5_MIN_VERSION "5.53.0")
+ set(PLASMA_MIN_VERSION "5.12.0")
+
+--- spectacle-19.04.0/src/SpectacleCore.cpp.old 2019-04-11 07:37:14.000000000 +0000
++++ spectacle-19.04.0/src/SpectacleCore.cpp 2019-04-18 22:57:46.694193923 +0000
+@@ -165,8 +165,7 @@
+ break;
+ case Actions::StartNewInstance:
+ QProcess newInstance;
+- newInstance.setProgram(QStringLiteral("spectacle"));
+- newInstance.startDetached();
++ newInstance.startDetached(QStringLiteral("spectacle"));
+ break;
+ }
+ }