summaryrefslogtreecommitdiff
path: root/user/spectacle
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-15 20:28:29 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-06-15 20:28:29 +0000
commit5e30a49b7a4cd903d446302f3a7f4ac685b53f2d (patch)
tree983ff9bdd3a27a48de6b94d0e70223ea6cb4bc5a /user/spectacle
parent18c6e5665fe1dadc47fad19f3f9629a5f9040b2b (diff)
downloadpackages-5e30a49b7a4cd903d446302f3a7f4ac685b53f2d.tar.gz
packages-5e30a49b7a4cd903d446302f3a7f4ac685b53f2d.tar.bz2
packages-5e30a49b7a4cd903d446302f3a7f4ac685b53f2d.tar.xz
packages-5e30a49b7a4cd903d446302f3a7f4ac685b53f2d.zip
user/[KDE Applications]: Bump to 20.04.2
Diffstat (limited to 'user/spectacle')
-rw-r--r--user/spectacle/APKBUILD6
-rw-r--r--user/spectacle/no-wayland.patch29
2 files changed, 16 insertions, 19 deletions
diff --git a/user/spectacle/APKBUILD b/user/spectacle/APKBUILD
index 00793ced6..54e0cfe5a 100644
--- a/user/spectacle/APKBUILD
+++ b/user/spectacle/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=spectacle
-pkgver=19.12.3
+pkgver=20.04.2
pkgrel=0
pkgdesc="Application for capturing desktop screenshots"
url="https://www.kde.org/applications/graphics/spectacle/"
@@ -42,5 +42,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="6bc10c376a63d6558c478e5844c5bc1c099d58c04593d5dc9bf2d0b17543fce62c202d8c3b9c2ade144566e205d9621546b777c134d1159529e7a3bc7b9d6766 spectacle-19.12.3.tar.xz
-36665d1b7d8b7c8004e457179f03fff1eed3865ee3e558f44f19022b80e39bbb2659de3e7b9affe654d5dbc5077890b38b6b4351f3a43324733749fbd36880ac no-wayland.patch"
+sha512sums="acbc058c85d9d8cc38e71ac01353f2a39a75b8ff29bff8c60982b6e3ffa5952d5eaccada8ae0cf15adecaa225c9064dea7238dd7a5435c1736a2f94f36b71e99 spectacle-20.04.2.tar.xz
+4bade3af7f06a1b2eb9568eee2905db04d8aa8647fa9414ba1da32cc2ea5e7029b9db2ad121381a04754b1abea36508b82e68a326db726759943aac5206fb455 no-wayland.patch"
diff --git a/user/spectacle/no-wayland.patch b/user/spectacle/no-wayland.patch
index 554e64d34..50c7cc8b7 100644
--- a/user/spectacle/no-wayland.patch
+++ b/user/spectacle/no-wayland.patch
@@ -19,7 +19,7 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3395c1b..06009f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -68,7 +68,6 @@ find_package(
+@@ -67,7 +67,6 @@ find_package(
NewStuff
GlobalAccel
XmlGui
@@ -31,7 +31,7 @@ diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6ff1b30..80e50dd 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
-@@ -84,7 +84,6 @@ target_link_libraries(
+@@ -87,7 +87,6 @@ target_link_libraries(
KF5::NewStuff
KF5::GlobalAccel
KF5::XmlGui
@@ -52,7 +52,7 @@ index 41e5858..92ced06 100644
#include <QGuiApplication>
#include <QScreen>
#include <QtCore/qmath.h>
-@@ -52,7 +50,7 @@ const int QuickEditor::magZoom = 5;
+@@ -53,7 +51,7 @@ const int QuickEditor::magZoom = 5;
const int QuickEditor::magPixels = 16;
const int QuickEditor::magOffset = 32;
@@ -61,7 +61,7 @@ index 41e5858..92ced06 100644
QWidget(parent),
mMaskColor(QColor::fromRgbF(0, 0, 0, 0.15)),
mStrokeColor(palette().highlight().color()),
-@@ -91,19 +89,7 @@ QuickEditor::QuickEditor(const QPixmap &thePixmap, KWayland::Client::PlasmaShell
+@@ -91,18 +89,6 @@
dprI = 1.0 / devicePixelRatioF();
setGeometry(0, 0, static_cast<int>(mPixmap.width() * dprI), static_cast<int>(mPixmap.height() * dprI));
@@ -70,18 +70,16 @@ index 41e5858..92ced06 100644
- using namespace KWayland::Client;
- winId();
- auto surface = Surface::fromWindow(windowHandle());
-- if (!surface) {
-- return;
+- if (surface) {
+- PlasmaShellSurface *plasmashellSurface = plasmashell->createSurface(surface, this);
+- plasmashellSurface->setRole(PlasmaShellSurface::Role::Panel);
+- plasmashellSurface->setPanelTakesFocus(true);
+- plasmashellSurface->setPosition(geometry().topLeft());
- }
-- PlasmaShellSurface *plasmashellSurface = plasmashell->createSurface(surface, this);
-- plasmashellSurface->setRole(PlasmaShellSurface::Role::Panel);
-- plasmashellSurface->setPanelTakesFocus(true);
-- plasmashellSurface->setPosition(geometry().topLeft());
- }
-+
- if (config->rememberLastRectangularRegion()) {
- QRect cropRegion = config->cropRegion();
- if (!cropRegion.isEmpty()) {
+ if (Settings::rememberLastRectangularRegion() || Settings::alwaysRememberRegion()) {
+ auto savedRect = Settings::cropRegion();
+ QRect cropRegion = QRect(savedRect[0], savedRect[1], savedRect[2], savedRect[3]);
diff --git a/src/QuickEditor/QuickEditor.h b/src/QuickEditor/QuickEditor.h
index 8dd6586..8187995 100644
--- a/src/QuickEditor/QuickEditor.h
@@ -182,11 +180,10 @@ index 3e90a99..8994995 100644
using MainWindowPtr = std::unique_ptr<KSMainWindow>;
using EditorPtr = std::unique_ptr<QuickEditor>;
-@@ -98,4 +92,3 @@ class SpectacleCore: public QObject
+@@ -93,4 +87,3 @@ class SpectacleCore: public QObject
bool mIsGuiInited;
bool mCopyToClipboard;
- KWayland::Client::PlasmaShell *mWaylandPlasmashell;
};
--
2.22.1
-