summaryrefslogtreecommitdiff
path: root/user/spectacle
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-19 00:05:46 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-09-19 00:05:46 +0000
commitcc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4 (patch)
tree5615e599278a678ac233adcd437c8eed67070914 /user/spectacle
parenta7f03fc523db2f305ffd73220b12fb5a6bd2b3b6 (diff)
downloadpackages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.gz
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.bz2
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.tar.xz
packages-cc24acfe4ce7c33801aeb362c8ac13ccf2dac2b4.zip
user/[KDE Applications]: Update to 20.08.1
Diffstat (limited to 'user/spectacle')
-rw-r--r--user/spectacle/APKBUILD6
-rw-r--r--user/spectacle/no-wayland.patch22
2 files changed, 13 insertions, 15 deletions
diff --git a/user/spectacle/APKBUILD b/user/spectacle/APKBUILD
index 95170e3cc..4b47b78e3 100644
--- a/user/spectacle/APKBUILD
+++ b/user/spectacle/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=spectacle
-pkgver=20.04.3
+pkgver=20.08.1
pkgrel=0
pkgdesc="Application for capturing desktop screenshots"
url="https://www.kde.org/applications/graphics/spectacle/"
@@ -42,5 +42,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ba2fdcf4c57efe213e79638a0b81c3061e2df432a4702b2d4830dfb3ed9c2f10cd6573b678b153a95414fee4807320345001f416db348a2b6633afbc5b93c546 spectacle-20.04.3.tar.xz
-4bade3af7f06a1b2eb9568eee2905db04d8aa8647fa9414ba1da32cc2ea5e7029b9db2ad121381a04754b1abea36508b82e68a326db726759943aac5206fb455 no-wayland.patch"
+sha512sums="83adc382c66173c3733dc603a7e7b957856b735af7764c66624158f39ba8bc8ce08e12d46d12781d5a21c2e09ba17ebb651f62dcf06ad032c409aae68f1b42a0 spectacle-20.08.1.tar.xz
+a138cc146e998648d2d99b21c935ab648751c6d66d7be6030e25829a3c001384811066099e3da3f0d4c546c62fbcac243a6a2c54aac8367bcc07bd89c683f7df no-wayland.patch"
diff --git a/user/spectacle/no-wayland.patch b/user/spectacle/no-wayland.patch
index 50c7cc8b7..300c50b8d 100644
--- a/user/spectacle/no-wayland.patch
+++ b/user/spectacle/no-wayland.patch
@@ -119,17 +119,16 @@ index 7024750..40417bb 100644
#include <KWindowSystem>
#include <QApplication>
-@@ -54,8 +51,7 @@ SpectacleCore::SpectacleCore(StartMode theStartMode,
- mPlatform(loadPlatform()),
+@@ -46,7 +46,6 @@
+ QObject(parent),
mMainWindow(nullptr),
- mIsGuiInited(false),
-- mCopyToClipboard(theCopyToClipboard),
+- mIsGuiInited(false),
- mWaylandPlasmashell(nullptr)
-+ mCopyToClipboard(theCopyToClipboard)
++ mIsGuiInited(false)
{
- auto lConfig = KSharedConfig::openConfig(QStringLiteral("spectaclerc"));
- KConfigGroup lGuiConfig(lConfig, "GuiConfig");
-@@ -92,24 +88,6 @@ SpectacleCore::SpectacleCore(StartMode theStartMode,
+ }
+
+@@ -66,23 +65,6 @@
connect(lExportManager, &ExportManager::forceNotify, this, &SpectacleCore::doNotify);
connect(mPlatform.get(), &Platform::windowTitleChanged, lExportManager, &ExportManager::setWindowTitle);
@@ -150,10 +149,9 @@ index 7024750..40417bb 100644
- registry->setup();
- connection->roundtrip();
- }
--
- switch (theStartMode) {
- case StartMode::DBus:
- break;
+ setUpShortcuts();
+ }
+
@@ -245,7 +223,7 @@ void SpectacleCore::screenshotUpdated(const QPixmap &thePixmap)
if (lExportManager->captureMode() == Spectacle::CaptureMode::RectangularRegion) {