summaryrefslogtreecommitdiff
path: root/user/spectacle
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-06-12 04:23:28 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit229100ecde79f6f3d031eb618acccb5aa6195b22 (patch)
treef97440428c3a2112044ff8814cf03cb7002a117a /user/spectacle
parentb05ce5add8948fa72697935d192aa78b5205cce4 (diff)
downloadpackages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.gz
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.bz2
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.xz
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.zip
user/[KDE Apps]: Update to 22.04.2
Diffstat (limited to 'user/spectacle')
-rw-r--r--user/spectacle/APKBUILD12
-rw-r--r--user/spectacle/no-wayland.patch187
2 files changed, 5 insertions, 194 deletions
diff --git a/user/spectacle/APKBUILD b/user/spectacle/APKBUILD
index 4b47b78e3..3ee051c24 100644
--- a/user/spectacle/APKBUILD
+++ b/user/spectacle/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=spectacle
-pkgver=20.08.1
+pkgver=22.04.2
pkgrel=0
pkgdesc="Application for capturing desktop screenshots"
url="https://www.kde.org/applications/graphics/spectacle/"
@@ -12,11 +12,10 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev
kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev
kconfig-dev ki18n-dev kio-dev kxmlgui-dev kwindowsystem-dev python3
kdoctools-dev kdeclarative-dev xcb-util-image-dev xcb-util-cursor-dev
- libxcb-dev xcb-util-renderutil-dev knewstuff-dev libkipi-dev"
+ libxcb-dev xcb-util-renderutil-dev knewstuff-dev libkipi-dev
+ kwayland-dev purpose-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/release-service/$pkgver/src/spectacle-$pkgver.tar.xz
- no-wayland.patch
- "
+source="https://download.kde.org/stable/release-service/$pkgver/src/spectacle-$pkgver.tar.xz"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -42,5 +41,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="83adc382c66173c3733dc603a7e7b957856b735af7764c66624158f39ba8bc8ce08e12d46d12781d5a21c2e09ba17ebb651f62dcf06ad032c409aae68f1b42a0 spectacle-20.08.1.tar.xz
-a138cc146e998648d2d99b21c935ab648751c6d66d7be6030e25829a3c001384811066099e3da3f0d4c546c62fbcac243a6a2c54aac8367bcc07bd89c683f7df no-wayland.patch"
+sha512sums="9fc2dd1792988c74ee7c7f5b6a32373dc9129e6a3beafaad82c58f3a512d9c61f8669fef53e3c682b0b4316d8eebf85833382da52ea39c3afe7df7e5efbb6ce3 spectacle-22.04.2.tar.xz"
diff --git a/user/spectacle/no-wayland.patch b/user/spectacle/no-wayland.patch
deleted file mode 100644
index 300c50b8d..000000000
--- a/user/spectacle/no-wayland.patch
+++ /dev/null
@@ -1,187 +0,0 @@
-From bd10239697d436caaa8aac3f4eca8aa2a5c14cac Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Fri, 18 Oct 2019 19:48:50 -0500
-Subject: [PATCH] Revert "Make QuickEditor fullscreen on Wayland"
-
-Allow building without Wayland libraries.
-
-This reverts commit 5679f7f5c9bc56e59744e9e4045dd01d7142fbfb.
----
- CMakeLists.txt | 1 -
- src/CMakeLists.txt | 1 -
- src/QuickEditor/QuickEditor.cpp | 18 ++----------------
- src/QuickEditor/QuickEditor.h | 8 +-------
- src/SpectacleCore.cpp | 26 ++------------------------
- src/SpectacleCore.h | 7 -------
- 6 files changed, 5 insertions(+), 56 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3395c1b..06009f1 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -67,7 +67,6 @@ find_package(
- NewStuff
- GlobalAccel
- XmlGui
-- Wayland
- )
-
- # optional components
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 6ff1b30..80e50dd 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -87,7 +87,6 @@ target_link_libraries(
- KF5::NewStuff
- KF5::GlobalAccel
- KF5::XmlGui
-- KF5::WaylandClient
- )
-
- if(XCB_FOUND)
-diff --git a/src/QuickEditor/QuickEditor.cpp b/src/QuickEditor/QuickEditor.cpp
-index 41e5858..92ced06 100644
---- a/src/QuickEditor/QuickEditor.cpp
-+++ b/src/QuickEditor/QuickEditor.cpp
-@@ -18,8 +18,6 @@
- */
-
- #include <KLocalizedString>
--#include <KWayland/Client/plasmashell.h>
--#include <KWayland/Client/surface.h>
- #include <QGuiApplication>
- #include <QScreen>
- #include <QtCore/qmath.h>
-@@ -53,7 +51,7 @@ const int QuickEditor::magZoom = 5;
- const int QuickEditor::magPixels = 16;
- const int QuickEditor::magOffset = 32;
-
--QuickEditor::QuickEditor(const QPixmap &thePixmap, KWayland::Client::PlasmaShell *plasmashell, QWidget *parent) :
-+QuickEditor::QuickEditor(const QPixmap& thePixmap, QWidget *parent) :
- QWidget(parent),
- mMaskColor(QColor::fromRgbF(0, 0, 0, 0.15)),
- mStrokeColor(palette().highlight().color()),
-@@ -91,18 +89,6 @@
-
- dprI = 1.0 / devicePixelRatioF();
- setGeometry(0, 0, static_cast<int>(mPixmap.width() * dprI), static_cast<int>(mPixmap.height() * dprI));
-- // TODO This is a hack until a better interface is available
-- if (plasmashell) {
-- using namespace KWayland::Client;
-- winId();
-- auto surface = Surface::fromWindow(windowHandle());
-- if (surface) {
-- PlasmaShellSurface *plasmashellSurface = plasmashell->createSurface(surface, this);
-- plasmashellSurface->setRole(PlasmaShellSurface::Role::Panel);
-- plasmashellSurface->setPanelTakesFocus(true);
-- plasmashellSurface->setPosition(geometry().topLeft());
-- }
-- }
- if (Settings::rememberLastRectangularRegion() || Settings::alwaysRememberRegion()) {
- auto savedRect = Settings::cropRegion();
- QRect cropRegion = QRect(savedRect[0], savedRect[1], savedRect[2], savedRect[3]);
-diff --git a/src/QuickEditor/QuickEditor.h b/src/QuickEditor/QuickEditor.h
-index 8dd6586..8187995 100644
---- a/src/QuickEditor/QuickEditor.h
-+++ b/src/QuickEditor/QuickEditor.h
-@@ -29,19 +29,13 @@
-
- class QMouseEvent;
-
--namespace KWayland {
--namespace Client {
--class PlasmaShell;
--}
--}
--
- class QuickEditor: public QWidget
- {
- Q_OBJECT
-
- public:
-
-- explicit QuickEditor(const QPixmap &thePixmap, KWayland::Client::PlasmaShell *plasmashell, QWidget *parent = nullptr);
-+ explicit QuickEditor(const QPixmap &thePixmap, QWidget *parent = nullptr);
- virtual ~QuickEditor() = default;
-
- private:
-diff --git a/src/SpectacleCore.cpp b/src/SpectacleCore.cpp
-index 7024750..40417bb 100644
---- a/src/SpectacleCore.cpp
-+++ b/src/SpectacleCore.cpp
-@@ -27,9 +27,6 @@
- #include <KMessageBox>
- #include <KNotification>
- #include <KRun>
--#include <KWayland/Client/connection_thread.h>
--#include <KWayland/Client/plasmashell.h>
--#include <KWayland/Client/registry.h>
- #include <KWindowSystem>
-
- #include <QApplication>
-@@ -46,7 +46,6 @@
- QObject(parent),
- mMainWindow(nullptr),
-- mIsGuiInited(false),
-- mWaylandPlasmashell(nullptr)
-+ mIsGuiInited(false)
- {
- }
-
-@@ -66,23 +65,6 @@
- connect(lExportManager, &ExportManager::forceNotify, this, &SpectacleCore::doNotify);
- connect(mPlatform.get(), &Platform::windowTitleChanged, lExportManager, &ExportManager::setWindowTitle);
-
-- // Needed so the QuickEditor can go fullscreen on wayland
-- if (KWindowSystem::isPlatformWayland()) {
-- using namespace KWayland::Client;
-- ConnectionThread *connection = ConnectionThread::fromApplication(this);
-- if (!connection) {
-- return;
-- }
-- Registry *registry = new Registry(this);
-- registry->create(connection);
-- connect(registry, &Registry::plasmaShellAnnounced, this,
-- [this, registry] (quint32 name, quint32 version) {
-- mWaylandPlasmashell = registry->createPlasmaShell(name, version, this);
-- }
-- );
-- registry->setup();
-- connection->roundtrip();
-- }
- setUpShortcuts();
- }
-
-@@ -245,7 +223,7 @@ void SpectacleCore::screenshotUpdated(const QPixmap &thePixmap)
-
- if (lExportManager->captureMode() == Spectacle::CaptureMode::RectangularRegion) {
- if(!mQuickEditor) {
-- mQuickEditor = std::make_unique<QuickEditor>(thePixmap, mWaylandPlasmashell);
-+ mQuickEditor = std::make_unique<QuickEditor>(thePixmap);
- connect(mQuickEditor.get(), &QuickEditor::grabDone, this, &SpectacleCore::screenshotUpdated);
- connect(mQuickEditor.get(), &QuickEditor::grabCancelled, this, &SpectacleCore::screenshotFailed);
- mQuickEditor->show();
-diff --git a/src/SpectacleCore.h b/src/SpectacleCore.h
-index 3e90a99..8994995 100644
---- a/src/SpectacleCore.h
-+++ b/src/SpectacleCore.h
-@@ -30,12 +30,6 @@
-
- #include <memory>
-
--namespace KWayland {
--namespace Client {
--class PlasmaShell;
--}
--}
--
- using MainWindowPtr = std::unique_ptr<KSMainWindow>;
- using EditorPtr = std::unique_ptr<QuickEditor>;
-
-@@ -93,4 +87,3 @@ class SpectacleCore: public QObject
- bool mIsGuiInited;
- bool mCopyToClipboard;
-- KWayland::Client::PlasmaShell *mWaylandPlasmashell;
- };
---
-2.22.1