summaryrefslogtreecommitdiff
path: root/user/syntax-highlighting
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-15 02:05:29 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-15 02:05:29 -0500
commit6d1aa6bdb53da260cfb9c2496247de1dbeaeaa5c (patch)
tree3b91ce6873e302eb3d1ca193ac05e59817739c2b /user/syntax-highlighting
parentea82a0564a0bd45499e1f615df591c2497d085c4 (diff)
downloadpackages-6d1aa6bdb53da260cfb9c2496247de1dbeaeaa5c.tar.gz
packages-6d1aa6bdb53da260cfb9c2496247de1dbeaeaa5c.tar.bz2
packages-6d1aa6bdb53da260cfb9c2496247de1dbeaeaa5c.tar.xz
packages-6d1aa6bdb53da260cfb9c2496247de1dbeaeaa5c.zip
user/syntax-highlighting: bump to 5.39.0, add -doc
Diffstat (limited to 'user/syntax-highlighting')
-rw-r--r--user/syntax-highlighting/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/user/syntax-highlighting/APKBUILD b/user/syntax-highlighting/APKBUILD
index c069664c8..1276e5201 100644
--- a/user/syntax-highlighting/APKBUILD
+++ b/user/syntax-highlighting/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=syntax-highlighting
-pkgver=5.38.0
+pkgver=5.39.0
pkgrel=0
pkgdesc="Framework for rendering programming code with formatting"
url="https://www.kde.org/"
@@ -9,10 +9,11 @@ arch="all"
license="LGPL-2.1"
depends=""
depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev perl"
+makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev perl
+ doxygen graphviz"
checkdepends="qt5-qtxmlpatterns-dev"
install=""
-subpackages="$pkgname-dev $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://download.kde.org/stable/frameworks/${pkgver%.*}/syntax-highlighting-$pkgver.tar.xz"
builddir="$srcdir/syntax-highlighting-$pkgver"
@@ -28,6 +29,7 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_QCH:BOOL=ON \
${CMAKE_CROSSOPTS}
make
}
@@ -42,4 +44,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1ca56399cd78e593644b3d474b4eff979762300d6d27f19a57e1e66954342ec0c6de28b4309f284d7c3c3d1f71d1ea6ca108cee0c5bb8ca1803aed5f0c69076c syntax-highlighting-5.38.0.tar.xz"
+sha512sums="d7b011950541754b840fe87b82139f3c36b2f582db53ff0b7e2b44c31f6111b5063c77e822dbd4f216761e4e9d556257f7d8954d507541475073bad1fdb3e976 syntax-highlighting-5.39.0.tar.xz"