summaryrefslogtreecommitdiff
path: root/user/talloc
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-01-27 23:13:19 -0500
committerMax Rees <maxcrees@me.com>2019-01-27 23:13:19 -0500
commitbc9c8e49b499f4d27d74e2f557d891d41a10b3ae (patch)
tree4aca62af13e25b436f934ef5e15b8f43a222027b /user/talloc
parent1cfde161f34685366e3d94bd6dddaba30af2f4c5 (diff)
downloadpackages-bc9c8e49b499f4d27d74e2f557d891d41a10b3ae.tar.gz
packages-bc9c8e49b499f4d27d74e2f557d891d41a10b3ae.tar.bz2
packages-bc9c8e49b499f4d27d74e2f557d891d41a10b3ae.tar.xz
packages-bc9c8e49b499f4d27d74e2f557d891d41a10b3ae.zip
user/talloc: new package
Diffstat (limited to 'user/talloc')
-rw-r--r--user/talloc/APKBUILD53
-rw-r--r--user/talloc/waf-location.patch10
2 files changed, 63 insertions, 0 deletions
diff --git a/user/talloc/APKBUILD b/user/talloc/APKBUILD
new file mode 100644
index 000000000..82ba9d682
--- /dev/null
+++ b/user/talloc/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=talloc
+pkgver=2.1.15
+pkgrel=0
+pkgdesc="Memory pool management library"
+url="https://talloc.samba.org"
+arch="all"
+license="LGPL-3.0+ AND GPL-3.0+ AND ISC AND LGPL-2.1+ AND BSD-3-Clause AND PostgreSQL"
+replaces="samba-common"
+depends=""
+makedepends="docbook-xsl libxslt python3-dev"
+subpackages="$pkgname-dev py3-$pkgname:py3 $pkgname-doc"
+source="https://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz
+ waf-location.patch"
+
+build() {
+ cd "$builddir"
+ PYTHON=python3 ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --bundled-libraries=NONE \
+ --builtin-libraries=replace \
+ --disable-rpath \
+ --disable-rpath-install
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+py3() {
+ pkgdesc="Python 3 binding for libtalloc"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libpytalloc-util.cpython* \
+ "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="41896f8877e9a52e70b9881c41667dc52d7c1b03c3b248020fd909b794a4c5a4addee3eb944aa80ecfa3b03e6e5e1f67a62b5f3a5dcdc412b3e975352057ff40 talloc-2.1.15.tar.gz
+d19553fae679b5db10ab77a86f9fa0525ccba37a3ef30e530cd96245ee5fc94d4570079bbfe0271c32fbc84a3556c4bf86cc1cab6ffb61863cbce3f5a911efec waf-location.patch"
diff --git a/user/talloc/waf-location.patch b/user/talloc/waf-location.patch
new file mode 100644
index 000000000..a5ca47f44
--- /dev/null
+++ b/user/talloc/waf-location.patch
@@ -0,0 +1,10 @@
+--- talloc-2.1.15/Makefile 2019-01-14 17:24:45.000000000 -0500
++++ talloc-2.1.15/Makefile 2019-01-27 22:57:15.919981283 -0500
+@@ -1,6 +1,6 @@
+ # simple makefile wrapper to run waf
+
+-WAF_BINARY=$(PYTHON) ../../buildtools/bin/waf
++WAF_BINARY=$(PYTHON) buildtools/bin/waf
+ WAF=PYTHONHASHSEED=1 WAF_MAKE=1 $(WAF_BINARY)
+
+ all: