summaryrefslogtreecommitdiff
path: root/user/tcpdump
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-27 23:55:43 -0700
committerDan Theisen <djt@hxx.in>2018-09-27 23:55:43 -0700
commit33b7c264cc2f69e3e19f32ceb4094e4e266a8c66 (patch)
treed56b7c2950a7aa182efd2a7f7e97a3e9b9091095 /user/tcpdump
parent1d2675b9ac0370a9bfee031a1193027b986e6833 (diff)
downloadpackages-33b7c264cc2f69e3e19f32ceb4094e4e266a8c66.tar.gz
packages-33b7c264cc2f69e3e19f32ceb4094e4e266a8c66.tar.bz2
packages-33b7c264cc2f69e3e19f32ceb4094e4e266a8c66.tar.xz
packages-33b7c264cc2f69e3e19f32ceb4094e4e266a8c66.zip
user/tcpdump: new package
Diffstat (limited to 'user/tcpdump')
-rw-r--r--user/tcpdump/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/tcpdump/APKBUILD b/user/tcpdump/APKBUILD
new file mode 100644
index 000000000..c5f4203e7
--- /dev/null
+++ b/user/tcpdump/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Dan Theisen <djt@hxx.in>
+pkgname=tcpdump
+pkgver=4.9.2
+pkgrel=0
+pkgdesc="A tool for network monitoring and data acquisition"
+url="http://www.tcpdump.org"
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends="libpcap-dev openssl-dev perl"
+subpackages="$pkgname-doc"
+source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz"
+
+build () {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/sbin/tcpdump.4*
+}
+
+sha512sums="e1bc19a5867d6e3628f3941bdf3ec831bf13784f1233ca1bccc46aac1702f47ee9357d7ff0ca62cddf211b3c8884488c21144cabddd92c861e32398cd8f7c44b tcpdump-4.9.2.tar.gz"