summaryrefslogtreecommitdiff
path: root/user/thunderbird/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-12 12:13:31 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-12 12:13:31 +0000
commit011b3b71d73a63ccbb6b1e281057103c240c83cc (patch)
tree7dd5c1a1fb0a2fc254acb9d9711ed94435281915 /user/thunderbird/APKBUILD
parentb485f27d0f2aa9eb17c13ccd5ade2e04b0d28d9e (diff)
downloadpackages-011b3b71d73a63ccbb6b1e281057103c240c83cc.tar.gz
packages-011b3b71d73a63ccbb6b1e281057103c240c83cc.tar.bz2
packages-011b3b71d73a63ccbb6b1e281057103c240c83cc.tar.xz
packages-011b3b71d73a63ccbb6b1e281057103c240c83cc.zip
user/thunderbird: bump to 68.0
Diffstat (limited to 'user/thunderbird/APKBUILD')
-rw-r--r--user/thunderbird/APKBUILD162
1 files changed, 105 insertions, 57 deletions
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
index 5b23efe27..4c314d8d3 100644
--- a/user/thunderbird/APKBUILD
+++ b/user/thunderbird/APKBUILD
@@ -1,123 +1,171 @@
-# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=thunderbird
-pkgver=52.9.1
-pkgrel=1
+pkgver=68.0
+pkgrel=0
pkgdesc="Email client from Mozilla"
-url="https://www.mozilla.org/thunderbird/"
+url="https://www.thunderbird.net/"
arch="all"
-options="!check" # X11 required
-license="MPL"
+options="!check" # Tests disabled
+license="MPL-2.0"
depends=""
# moz build system stuff
# python deps
# system-libs
# actual deps
makedepends="
- autoconf2.13 ncurses-dev perl cmd:which
+ autoconf2.13 cargo cbindgen clang llvm8-dev node ncurses-dev
+ perl rust rust-stdlib cmd:which
ncurses-dev openssl-dev
alsa-lib-dev bzip2-dev icu-dev libevent-dev libffi-dev libpng-dev
libjpeg-turbo-dev nspr-dev nss-dev pulseaudio-dev zlib-dev
- dbus-glib-dev gconf-dev gtk+2.0-dev gtk+3.0-dev hunspell-dev libsm-dev
- libnotify-dev libxcomposite-dev libxdamage-dev libxrender-dev libxt-dev
- nss-static sqlite-dev startup-notification-dev unzip yasm zip
+ dbus-glib-dev fts-dev gconf-dev gtk+3.0-dev hunspell-dev
+ libnotify-dev libsm-dev libxcomposite-dev libxdamage-dev
+ libxrender-dev libxt-dev nasm nss-static sqlite-dev
+ startup-notification-dev unzip yasm zip gtk+2.0-dev
"
-install=""
-subpackages="$pkgname-dev"
-source="https://archive.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
+_py2ver="2.7.16"
+source="https://archive.mozilla.org/pub/thunderbird/candidates/$pkgver-candidates/build2/source/thunderbird-$pkgver.source.tar.xz
+ https://www.python.org/ftp/python/$_py2ver/Python-$_py2ver.tar.xz
mozconfig
+
bad-google-code.patch
+ disable-gecko-profiler.patch
+ fix-mutex-build.patch
fix-seccomp-bpf.patch
- mach-linux-musl.patch
- profiler.patch
- proper-system-hunspell.patch
- stab.h
+ mozilla-build-arm.patch
+ rust-config.patch
+ shut-up-warning.patch
stackwalk-x86-ppc.patch
+ webrtc-broken.patch
+ yuv-be.patch
+
thunderbird.desktop
"
somask="liblgpllibs.so
libmozgtk.so
libmozsandbox.so
- libxul.so"
-_tbirddir=/usr/lib/${pkgname}-${pkgver}
+ libmozsqlite3.so
+ libxul.so
+ "
+_mozappdir=/usr/lib/thunderbird
+ldpath="$_mozappdir"
unpack() {
default_unpack
- # just ripped from Firefox's APKBUILD...
[ -z $SKIP_PYTHON ] || return 0
+
msg "Killing all remaining hope for humanity and building Python 2..."
- cd "$srcdir"
- [ -d python ] && rm -r python
- mkdir python
- cd python
+ cd "$srcdir/Python-$_py2ver"
+ [ -d ../python ] && rm -r ../python
+
# 19:39 <+solar> just make the firefox build process build its own py2 copy
- curl -O https://www.python.org/ftp/python/2.7.15/Python-2.7.15.tar.xz
- tar xJf Python-2.7.15.tar.xz
- cd Python-2.7.15
# 20:03 <calvin> TheWilfox: there's always violence
- ./configure --prefix="$srcdir/python"
+
+ sed -e 's/é/e/g' /etc/os-release > "$srcdir"/os-release
+ export UNIXCONFDIR="$srcdir"
+
+ ./configure --prefix="$srcdir/python" --with-ensurepip=install
make -j $JOBS
# 6 tests failed:
# test__locale test_os test_posix test_re test_strptime test_time
# make test
make -j $JOBS install
+
+ # firefox's bundled pipenv and pip aren't new enough to support
+ # configurable UNIXCONFDIR
+ export PATH="$srcdir/python/bin:$PATH"
+ pip2 install virtualenv pipenv
}
prepare() {
+ cd "$builddir"
default_prepare
- cp "$srcdir"/stab.h "$builddir"/mozilla/toolkit/crashreporter/google-breakpad/src/
cp "$srcdir"/mozconfig "$builddir"/mozconfig
echo "ac_add_options --enable-optimize=\"$CFLAGS\"" >> "$builddir"/mozconfig
echo "ac_add_options --host=\"$CHOST\"" >> "$builddir"/mozconfig
echo "ac_add_options --target=\"$CTARGET\"" >> "$builddir"/mozconfig
# too much memory
- if [ -z "$JOBS" ] || [ $JOBS -gt 16 ]; then
- echo "mk_add_options MOZ_MAKE_FLAGS=\"-j16\"" >> "$builddir"/mozconfig
+ if [ -z "$JOBS" ] || [ $JOBS -ge 16 ]; then
+ JOBS=16
fi
+ echo "mk_add_options MOZ_MAKE_FLAGS=\"-j$JOBS\"" >> "$builddir"/mozconfig
+
+ case "$CARCH" in
+ pmmx|x86*)
+ echo "ac_add_options --disable-elf-hack" >> "$builddir"/mozconfig
+ ;;
+ esac
+
+ rm "$builddir"/third_party/python/virtualenv/virtualenv_support/pip*.whl
+ rm "$builddir"/third_party/python/virtualenv/virtualenv_support/setuptools*.whl
+ cp "$srcdir/Python-$_py2ver"/Lib/ensurepip/_bundled/*.whl \
+ "$builddir/third_party/python/virtualenv/virtualenv_support"
}
build() {
cd "$builddir"
- # reportedly needed for gcc6; confirm this?
- export CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks -fno-schedule-insns2"
-
- export LDFLAGS="$LDFLAGS -Wl,-rpath,${_tbirddir}"
+ export SHELL=/bin/sh
+ export BUILD_OFFICIAL=1
+ export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
+ # gcc 6
+ export CXXFLAGS="-fno-delete-null-pointer-checks -fno-schedule-insns2"
+
+ # set rpath so linker finds the libs
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,${_mozappdir}"
+
+ export UNIXCONFDIR="$srcdir"
+
+ local extra_flags=""
+ [ "$CARCH" = "s390x" ] && extra_flags="--disable-startupcache"
export PATH="$srcdir/python/bin:$PATH"
- ./mozilla/mach build
+ ./mach build
+}
+
+run() {
+ cd "$builddir"/obj-$CHOST/dist/bin
+ export LD_LIBRARY_PATH=.
+ ./firefox -no-remote -profile "$builddir"/obj-$CHOST/tmp/profile-default
}
package() {
cd "$builddir"
export PATH="$srcdir/python/bin:$PATH"
- DESTDIR="$pkgdir" ./mozilla/mach install
- install -D -m644 "$srcdir"/thunderbird.desktop \
- "$pkgdir"/usr/share/applications/thunderbird.desktop
-}
+ DESTDIR="$pkgdir" ./mach install
+
+ install -m755 -d ${pkgdir}/usr/share/applications
+ install -m755 -d ${pkgdir}/usr/share/pixmaps
-dev() {
- pkgdesc="$pkgdesc (development files)"
+ local png
+ for png in comm/mail/branding/thunderbird/default*.png; do
+ local i="${_png%.png}"
+ i=${i##*/default}
+ install -D -m644 "$png" \
+ "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/thunderbird.png
+ done
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/include "$subpkgdir"/usr/include
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/thunderbird-devel* "$subpkgdir"/usr/lib
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/idl "$subpkgdir"/usr/share
+ install -m644 "$builddir"/comm/mail/branding/thunderbird/default256.png \
+ ${pkgdir}/usr/share/pixmaps/thunderbird.png
+ install -m644 ${startdir}/thunderbird.desktop \
+ ${pkgdir}/usr/share/applications/thunderbird.desktop
}
-sha512sums="0de80a5036b1e8a5a8549c546b4693cb285ee4d10f546f4b4aceed9e1d6c64b9dbafce7bacaaf057112130036f7b41fb2e0fa3343412140e6ac926dd94c27d23 thunderbird-52.9.1.source.tar.xz
-70fe8deb669eb0fb060f90f7af4ef98d6b6a80bde258a898397dd7e8c075b11ff3e418aa5eaf72262f40e561ea82da4b645cfc0b92d02af53f45536dc9963cbb mozconfig
-9b11ba43f1f3fe9cda69b6b92e2073ea5165a47e30084537f396ceb8fb63573c4eb057251644837504aa4546183dc8f77fbb24f1450b6a15a1386f29180deefc bad-google-code.patch
-2f52fcd7c42f8e12c955e05aa12449aa486c5347d2a7406ff0dada66f64079152b18c3f65c43410df372e871488f17889bc337ced37d0b76305afdbcb55cb580 fix-seccomp-bpf.patch
-475bdf81c41775634b131635197fa449b5068f2624a6b120d1878e2191a8e7badf01ac79a15ccf39242c64a29357f2ed7bae96352ceb70a234b17468a999e0c4 mach-linux-musl.patch
-7e72b96196f51cc02478f1802a10b1c1754db09d7d35aef697c5dcaace107e7a45a1b97256cc98b4aa728845694be093b148b61868e8ebfc8317fea19d6c71fa profiler.patch
-63b09028262a109e3a02f928c12323793df65dbd6d5605ddc315978b50ff4b50f6d1af410dc7c00538c80009a8721900c6320b166c8aa9bc6dce170ebcd6fc91 proper-system-hunspell.patch
-0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
-d620a1efa4b079ce082a27cfacbae275aceb3d268fd44bfd3f4b742b8098c8e1b1733edd360404c5109137c508b8426ed9e1ca1036b11752de8d1f429bf14844 stackwalk-x86-ppc.patch
+sha512sums="5177c11e841f6aa704634ce66fa9f1af02703d8c04dfeabf19829551f997cd80b60e8fa32af71ea64cf27af2be3956971bb6b75645dfc68417bb257a41872e3e thunderbird-68.0.source.tar.xz
+16e814e8dcffc707b595ca2919bd2fa3db0d15794c63d977364652c4a5b92e90e72b8c9e1cc83b5020398bd90a1b397dbdd7cb931c49f1aa4af6ef95414b43e0 Python-2.7.16.tar.xz
+d706c413a2fd3c3192f4dcc1ee3e16fb4572ad25cdaf4ddb291c34a58e684da574211bcb25e9a699b5b30de3026263cfec95e6f1c4b4d13a054e28199ec8e2f4 mozconfig
+ace7492f4fb0523c7340fdc09c831906f74fddad93822aff367135538dacd3f56288b907f5a04f53f94c76e722ba0bab73e28d83ec12d3e672554712e6b08613 bad-google-code.patch
+9c14041f0295682b8dbeb6d5b58a2f9dc0a2dc8bef995a0f7e30fa0b17c51aa0f6748f80fb8584169db7687e2eeb404dff68a09158ae56a5f24eef30685dd2b3 disable-gecko-profiler.patch
+c0b2bf43206c2a5154e560ef30189a1062ae856861b39f52ce69002390ff9972d43e387bfd2bf8d2ab3cac621987bc042c8c0a8b4cf90ae05717ca7705271880 fix-mutex-build.patch
+70863b985427b9653ce5e28d6064f078fb6d4ccf43dd1b68e72f97f44868fc0ce063161c39a4e77a0a1a207b7365d5dc7a7ca5e68c726825eba814f2b93e2f5d fix-seccomp-bpf.patch
+e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb18b9e3138273ea8ddcfdcb1084fdcaa922a1e5b30146a3b18 mozilla-build-arm.patch
+45613d476e85fe333ef8091acce4806803953c1a99de4f03ff577cf20c5a1a3d635d0589e1490da104ef80721f4f1b1d35045af3c6892c1a468fa84095f27ad8 rust-config.patch
+39ddb15d1453a8412275c36fc8db3befc69dffd4a362e932d280fb7fd1190db595a2af9b468ee49e0714f5e9df6e48eb5794122a64fa9f30d689de8693acbb15 shut-up-warning.patch
+452b47b825294779f98ed46bc1065dad76b79ff453521ef049934a120f349c84a1c863b16af1828fe053059823da9690ec917c055ae02dcc5c80c54cad732448 stackwalk-x86-ppc.patch
+be68f1387aa6677875a67106e2d6a9db470c934c943056d3b53391a63034235108e41945c53957db427d9cdc59f0aa2f9e6f2f8cd862e090e512a3ab9cbcc9a8 webrtc-broken.patch
+2dfb986089c9afcd6a895302c8a5a1d299cffa4cc3c73fce784c29d348f362c1e7570109c4f09d328275d8549a96531736dd976411c15956b385d7fb211b8af2 yuv-be.patch
95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"