summaryrefslogtreecommitdiff
path: root/user/thunderbird/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-13 01:17:58 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-13 01:17:58 -0500
commit95a8766521ed143dbf82ec447b7b79743e274797 (patch)
tree813208c7a3f22309e48d9d8a220862886be5b658 /user/thunderbird/APKBUILD
parenta987aed29a4003ef075b86cd50c1a0875004f30d (diff)
downloadpackages-95a8766521ed143dbf82ec447b7b79743e274797.tar.gz
packages-95a8766521ed143dbf82ec447b7b79743e274797.tar.bz2
packages-95a8766521ed143dbf82ec447b7b79743e274797.tar.xz
packages-95a8766521ed143dbf82ec447b7b79743e274797.zip
user/thunderbird: new package
Diffstat (limited to 'user/thunderbird/APKBUILD')
-rw-r--r--user/thunderbird/APKBUILD90
1 files changed, 90 insertions, 0 deletions
diff --git a/user/thunderbird/APKBUILD b/user/thunderbird/APKBUILD
new file mode 100644
index 000000000..782061ea3
--- /dev/null
+++ b/user/thunderbird/APKBUILD
@@ -0,0 +1,90 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=thunderbird
+pkgver=52.6.0
+pkgrel=0
+pkgdesc="Email client from Mozilla"
+url="https://www.mozilla.org/thunderbird/"
+arch="all"
+options="!check" # X11 required
+license="MPL"
+depends=""
+# moz build system stuff
+# system-libs
+# actual deps
+makedepends="
+ autoconf2.13 debianutils-which perl python2
+
+ alsa-lib-dev bzip2-dev icu-dev libevent-dev libffi-dev libpng-dev
+ libjpeg-turbo-dev libvpx-dev nspr-dev nss-dev pulseaudio-dev zlib-dev
+
+ dbus-glib-dev gconf-dev gtk+2.0-dev gtk+3.0-dev hunspell-dev libsm-dev
+ libnotify-dev libxcomposite-dev libxdamage-dev libxrender-dev libxt-dev
+ nss-static sqlite-dev startup-notification-dev unzip yasm zip
+ "
+install=""
+subpackages="$pkgname-dev"
+source="https://archive.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
+ mozconfig
+ bad-google-code.patch
+ fix-seccomp-bpf.patch
+ mach-linux-musl.patch
+ profiler.patch
+ proper-system-hunspell.patch
+ stab.h
+ thunderbird.desktop
+ "
+somask="liblgpllibs.so
+ libmozgtk.so
+ libmozsandbox.so
+ libxul.so"
+_tbirddir=/usr/lib/${pkgname}-${pkgver}
+
+prepare() {
+ default_prepare
+ cp "$srcdir"/stab.h "$builddir"/mozilla/toolkit/crashreporter/google-breakpad/src/
+ cp "$srcdir"/mozconfig "$builddir"/mozconfig
+ echo "ac_add_options --enable-optimize=\"$CFLAGS\"" >> "$builddir"/mozconfig
+ echo "ac_add_options --host=\"$CHOST\"" >> "$builddir"/mozconfig
+ echo "ac_add_options --target=\"$CTARGET\"" >> "$builddir"/mozconfig
+}
+
+build() {
+ cd "$builddir"
+
+ # reportedly needed for gcc6; confirm this?
+ export CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks -fno-schedule-insns2"
+
+ export LDFLAGS="$LDFLAGS -Wl,-rpath,${_tbirddir}"
+ export USE_SHORT_LIBNAME=1
+
+ ./mozilla/mach build
+}
+
+package() {
+ cd "$builddir"
+ DESTDIR="$pkgdir" ./mozilla/mach install
+ install -D -m644 "$srcdir"/thunderbird.desktop \
+ "$pkgdir"/usr/share/applications/thunderbird.desktop
+}
+
+dev() {
+ pkgdesc="$pkgdesc (development files)"
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/include "$subpkgdir"/usr/include
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/thunderbird-devel* "$subpkgdir"/usr/lib
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/idl "$subpkgdir"/usr/share
+}
+
+sha512sums="80742c95ed61d1cb2e72b71bb23bdd211a40240ab4393e9f028a38f902547372084a8f56445e2394484be088a7b9801405f3d6618fb2742601cc968bf34427f0 thunderbird-52.6.0.source.tar.xz
+000b4403bfac4a6192ebe36a734ef3e464f3bdd3bc797e87bc487b4d9d93cd4b41137d82726617205e39f7aedf8bf2dfb11645db24a8b0b0137a141c9133f151 mozconfig
+9b11ba43f1f3fe9cda69b6b92e2073ea5165a47e30084537f396ceb8fb63573c4eb057251644837504aa4546183dc8f77fbb24f1450b6a15a1386f29180deefc bad-google-code.patch
+2f52fcd7c42f8e12c955e05aa12449aa486c5347d2a7406ff0dada66f64079152b18c3f65c43410df372e871488f17889bc337ced37d0b76305afdbcb55cb580 fix-seccomp-bpf.patch
+475bdf81c41775634b131635197fa449b5068f2624a6b120d1878e2191a8e7badf01ac79a15ccf39242c64a29357f2ed7bae96352ceb70a234b17468a999e0c4 mach-linux-musl.patch
+7e72b96196f51cc02478f1802a10b1c1754db09d7d35aef697c5dcaace107e7a45a1b97256cc98b4aa728845694be093b148b61868e8ebfc8317fea19d6c71fa profiler.patch
+63b09028262a109e3a02f928c12323793df65dbd6d5605ddc315978b50ff4b50f6d1af410dc7c00538c80009a8721900c6320b166c8aa9bc6dce170ebcd6fc91 proper-system-hunspell.patch
+0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+95a2b1deb4f6c90750fdd2bfe8ca0a7879a5b267965091705a6beb0a0a4b1ccad75d11df7b9885543ca4232ff704e975c6946f4c11804cb71c471e06f9576001 thunderbird.desktop"