summaryrefslogtreecommitdiff
path: root/user/tlp
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-03 19:21:05 -0600
committerMax Rees <maxcrees@me.com>2020-03-17 00:32:05 -0500
commitd2b9d4e2ab2fca5ef26632b00a855b8e72757b80 (patch)
tree369021ea613f92b65f5e83b6183f13134fe3b407 /user/tlp
parent02084aa19f020997dd27337b36d63e24c74ec7cd (diff)
downloadpackages-d2b9d4e2ab2fca5ef26632b00a855b8e72757b80.tar.gz
packages-d2b9d4e2ab2fca5ef26632b00a855b8e72757b80.tar.bz2
packages-d2b9d4e2ab2fca5ef26632b00a855b8e72757b80.tar.xz
packages-d2b9d4e2ab2fca5ef26632b00a855b8e72757b80.zip
user/tlp: bump to 1.3.1
Diffstat (limited to 'user/tlp')
-rw-r--r--user/tlp/APKBUILD5
-rw-r--r--user/tlp/tlp.post-upgrade14
2 files changed, 17 insertions, 2 deletions
diff --git a/user/tlp/APKBUILD b/user/tlp/APKBUILD
index 40613efd9..ca7208b5e 100644
--- a/user/tlp/APKBUILD
+++ b/user/tlp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=tlp
_pkgname=TLP
-pkgver=1.2.2
+pkgver=1.3.1
pkgrel=0
pkgdesc="Linux Advanced Power Management"
url="https://linrunner.de/en/tlp/tlp.html"
@@ -13,6 +13,7 @@ depends="/bin/sh perl"
makedepends=""
subpackages="$pkgname-doc $pkgname-rdw $pkgname-bash-completion:bashcomp
$pkgname-openrc"
+install="$pkgname.post-upgrade"
source="$pkgname-$pkgver.tar.gz::https://github.com/linrunner/$_pkgname/archive/$pkgver.tar.gz
$pkgname.initd"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -48,5 +49,5 @@ bashcomp() {
"$subpkgdir"/usr/share/bash-completion/completions
}
-sha512sums="b01fc2063bf8a87f2b93749c08a5cab53a0a4030b74c7fe62964009fb9d54ca5dc10800971f27cfe6dcdf024ba6d3e21a06caed07e8dc12b09d9d359585a480e tlp-1.2.2.tar.gz
+sha512sums="7ebb14ea797ad8aae613c537de51107a3c7430b5c6ee1407e722e2069ed5376f88ab3dac613651fafabd92d219b980452f236bef33e8a655b1abbfed5eded1b1 tlp-1.3.1.tar.gz
e6de216b2540413812711b3304cdc29c8729d527080cfd747ba382db50166dd21c6c27ff467f9f2a967e92007c7a311b00e88262952c34a22f417578c66cf4e7 tlp.initd"
diff --git a/user/tlp/tlp.post-upgrade b/user/tlp/tlp.post-upgrade
new file mode 100644
index 000000000..6adf68850
--- /dev/null
+++ b/user/tlp/tlp.post-upgrade
@@ -0,0 +1,14 @@
+#!/bin/sh
+ver_new="$1"
+ver_old="$2"
+
+if [ "$(apk version -t "$ver_old" "1.3.1")" = "<" ]; then
+ cat >&2 <<-EOF
+ *
+ * tlp has moved its configuration from '/etc/default/tlp'
+ * to '/etc/tlp.conf' and '/etc/tlp.d'. Additionally,
+ * these configuration files are now parsed instead of
+ * executed via the shell, so expansions will no longer work.
+ *
+ EOF
+fi