summaryrefslogtreecommitdiff
path: root/user/ttf-freefont
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 17:44:46 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-23 17:44:46 -0500
commit8724bd068cdde6fc4f2091caa60e7d63cc3a139d (patch)
tree07a50b7cb879ff90058d7e12d686a6998ed776d3 /user/ttf-freefont
parent17ee116c0d745030d456d99a3bab764790f6ef66 (diff)
downloadpackages-8724bd068cdde6fc4f2091caa60e7d63cc3a139d.tar.gz
packages-8724bd068cdde6fc4f2091caa60e7d63cc3a139d.tar.bz2
packages-8724bd068cdde6fc4f2091caa60e7d63cc3a139d.tar.xz
packages-8724bd068cdde6fc4f2091caa60e7d63cc3a139d.zip
user/ttf-freefont: pull in, fix up, modernise
Diffstat (limited to 'user/ttf-freefont')
-rw-r--r--user/ttf-freefont/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/user/ttf-freefont/APKBUILD b/user/ttf-freefont/APKBUILD
new file mode 100644
index 000000000..532f064a7
--- /dev/null
+++ b/user/ttf-freefont/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer:
+pkgname=ttf-freefont
+pkgver=20120503
+pkgrel=0
+pkgdesc="High-quality TrueType fonts covering the UCS character set"
+url="http://www.nongnu.org/freefont/"
+arch="noarch"
+options="!check" # No test suite.
+license="GPL-3.0+ with exception"
+depends="encodings fontconfig mkfontdir mkfontscale"
+makedepends="font-util-dev"
+source="https://ftp.gnu.org/gnu/freefont/freefont-ttf-$pkgver.zip"
+builddir="$srcdir/freefont-$pkgver"
+
+package() {
+ cd "$builddir"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF/"
+ # Licensing exception is discussed in README in pkgver==20120503
+ install -Dm644 README "$pkgdir/usr/share/licenses/$pkgname/README"
+}
+
+sha512sums="dcd6f525e8f97631c6f84ab4cc2a31af4614dcdb9a4d434bd890baf18e0c2934032f2915384fc27fbecf60d259d792e48f52d357b07e3ed2616d3c8c3544268e freefont-ttf-20120503.zip"