summaryrefslogtreecommitdiff
path: root/user/ttf-hack
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-06 21:30:08 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-10-06 21:30:08 -0500
commit5edebe21c05ec53d22c514d85081c47ab0d57751 (patch)
treee500d3240a1237ad702dbe40d0adac0427661067 /user/ttf-hack
parent5b2ed288029e9f68e269b89fc7220b95174410e9 (diff)
downloadpackages-5edebe21c05ec53d22c514d85081c47ab0d57751.tar.gz
packages-5edebe21c05ec53d22c514d85081c47ab0d57751.tar.bz2
packages-5edebe21c05ec53d22c514d85081c47ab0d57751.tar.xz
packages-5edebe21c05ec53d22c514d85081c47ab0d57751.zip
user/ttf-hack: new package
Diffstat (limited to 'user/ttf-hack')
-rw-r--r--user/ttf-hack/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/user/ttf-hack/APKBUILD b/user/ttf-hack/APKBUILD
new file mode 100644
index 000000000..cdfa600c6
--- /dev/null
+++ b/user/ttf-hack/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=ttf-hack
+pkgver=2.020
+pkgrel=0
+pkgdesc="Libre typeface designed for source code"
+url="http://sourcefoundry.org/hack/"
+arch="noarch"
+license="OFL-2.0"
+options="!check" # No test suite.
+depends=""
+makedepends=""
+install=""
+subpackages=""
+source="https://github.com/source-foundry/Hack/releases/download/v$pkgver/Hack-v2_020-ttf.zip"
+builddir="$srcdir/"
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ for variant in Regular Bold BoldItalic Italic; do
+ install -m644 -D "$srcdir"/Hack-$variant.ttf \
+ "$pkgdir"/usr/share/truetype/Hack-$variant.ttf
+ done
+}
+
+sha512sums="de3c8e13ace5ee49bb2b5dd331cc3109ad12b762f967c88cdf8f0d1080e5c3cb99d2dffe1c986c9fcc6e46e31c3bc7141cf1c9e1b8430d1ef76a90ab461d1a09 Hack-v2_020-ttf.zip"