summaryrefslogtreecommitdiff
path: root/user/umbrello
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-01 05:34:55 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-01 05:34:55 +0000
commiteb2ac2b0ce4c14f582cb40755b774cb39c963b17 (patch)
tree645e05cd33e86e9543ab599c216f043ba7d02e4a /user/umbrello
parent2692b4530ddccdcc1fd5b17eaa4812b98b4e34b3 (diff)
downloadpackages-eb2ac2b0ce4c14f582cb40755b774cb39c963b17.tar.gz
packages-eb2ac2b0ce4c14f582cb40755b774cb39c963b17.tar.bz2
packages-eb2ac2b0ce4c14f582cb40755b774cb39c963b17.tar.xz
packages-eb2ac2b0ce4c14f582cb40755b774cb39c963b17.zip
user/umbrello: disable icons to fix crash (upstream #400501)
Diffstat (limited to 'user/umbrello')
-rw-r--r--user/umbrello/APKBUILD9
-rw-r--r--user/umbrello/hax.patch11
2 files changed, 17 insertions, 3 deletions
diff --git a/user/umbrello/APKBUILD b/user/umbrello/APKBUILD
index 432d310d4..f64b28489 100644
--- a/user/umbrello/APKBUILD
+++ b/user/umbrello/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=umbrello
pkgver=18.08.2
-pkgrel=0
+pkgrel=1
pkgdesc="Software modelling tool and code generator"
url="https://umbrello.kde.org/"
arch="all"
@@ -14,7 +14,9 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
kcrash-dev kdoctools-dev kiconthemes-dev kdelibs4support-dev kio-dev
ktexteditor-dev kwindowsystem-dev kwidgetsaddons-dev kxmlgui-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.kde.org/stable/applications/$pkgver/src/umbrello-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/umbrello-$pkgver.tar.xz
+ hax.patch
+ "
build() {
cd "$builddir"
@@ -42,4 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="55941afe05b72085aefac3604ac9a9023f46149e5aad0784fa14942907c21009fb20919750a969abb8c398bcb2f99f3e23e3b91eed06f0cb5a8897563aaa52b8 umbrello-18.08.2.tar.xz"
+sha512sums="55941afe05b72085aefac3604ac9a9023f46149e5aad0784fa14942907c21009fb20919750a969abb8c398bcb2f99f3e23e3b91eed06f0cb5a8897563aaa52b8 umbrello-18.08.2.tar.xz
+fcbe03a49d5420bf17383e5e6d4bac4377c1abfcafacea20ac37409457471537067efe3236647fb3570abfa410a4a3870b1638bb1ef880a24e6f60e2b189a562 hax.patch"
diff --git a/user/umbrello/hax.patch b/user/umbrello/hax.patch
new file mode 100644
index 000000000..d48c6052b
--- /dev/null
+++ b/user/umbrello/hax.patch
@@ -0,0 +1,11 @@
+--- umbrello-18.08.2/umbrello/umllistviewitem.cpp.old 2018-10-08 12:48:19.000000000 +0000
++++ umbrello-18.08.2/umbrello/umllistviewitem.cpp 2018-10-31 06:24:26.330000000 +0000
+@@ -469,7 +469,7 @@
+ {
+ QPixmap p = Icon_Utils::SmallIcon(iconType);
+ if (!p.isNull()) {
+- QTreeWidgetItem::setIcon(0, QIcon(p));
++ //QTreeWidgetItem::setIcon(0, QIcon(p));
+ }
+ }
+