summaryrefslogtreecommitdiff
path: root/user/umbrello
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-13 01:48:37 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-13 01:48:37 +0000
commit939576404a1853bf009789059c34288420bfd6ec (patch)
tree6a9626325bda0c2288f49928bc5e64cb9bb2af10 /user/umbrello
parenteb7b790aab31076e25c88f0fd10cf54c3cd2699c (diff)
downloadpackages-939576404a1853bf009789059c34288420bfd6ec.tar.gz
packages-939576404a1853bf009789059c34288420bfd6ec.tar.bz2
packages-939576404a1853bf009789059c34288420bfd6ec.tar.xz
packages-939576404a1853bf009789059c34288420bfd6ec.zip
user/KDE Apps: bump to 18.08.3
Diffstat (limited to 'user/umbrello')
-rw-r--r--user/umbrello/APKBUILD4
-rw-r--r--user/umbrello/assertion-fix.patch41
2 files changed, 43 insertions, 2 deletions
diff --git a/user/umbrello/APKBUILD b/user/umbrello/APKBUILD
index f64b28489..d200097fa 100644
--- a/user/umbrello/APKBUILD
+++ b/user/umbrello/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=umbrello
-pkgver=18.08.2
+pkgver=18.08.3
pkgrel=1
pkgdesc="Software modelling tool and code generator"
url="https://umbrello.kde.org/"
@@ -44,5 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="55941afe05b72085aefac3604ac9a9023f46149e5aad0784fa14942907c21009fb20919750a969abb8c398bcb2f99f3e23e3b91eed06f0cb5a8897563aaa52b8 umbrello-18.08.2.tar.xz
+sha512sums="2aaceb8e351e4a0a13834ce6ad1c8dd5575ea591e4c69ac080ad53798338200fa9768460ee63f7462941e372ddb9458afba8b602843c63c9cad2cee6f763d6b1 umbrello-18.08.3.tar.xz
fcbe03a49d5420bf17383e5e6d4bac4377c1abfcafacea20ac37409457471537067efe3236647fb3570abfa410a4a3870b1638bb1ef880a24e6f60e2b189a562 hax.patch"
diff --git a/user/umbrello/assertion-fix.patch b/user/umbrello/assertion-fix.patch
new file mode 100644
index 000000000..ef86e6546
--- /dev/null
+++ b/user/umbrello/assertion-fix.patch
@@ -0,0 +1,41 @@
+From af72e059f728d70e43ac3ea03653865585818e66 Mon Sep 17 00:00:00 2001
+From: Ralf Habacker <ralf.habacker@freenet.de>
+Date: Fri, 2 Nov 2018 11:38:37 +0100
+Subject: Fix 'Umbrello fails to start due to ASSERT failure in QVector<T>::at
+ "index out of range"'
+
+The backtrace shows that Qt wants to access tree view items that
+have already been deleted. To avoid this, graphical updates are
+disabled when creating the new document.
+
+BUG:400501
+FIXED-IN:2.26.3 (KDE Applications 18.08.3)
+---
+ umbrello/umldoc.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/umbrello/umldoc.cpp b/umbrello/umldoc.cpp
+index d4099bb..af5c889 100644
+--- a/umbrello/umldoc.cpp
++++ b/umbrello/umldoc.cpp
+@@ -442,6 +442,9 @@ void UMLDoc::closeDocument()
+ */
+ bool UMLDoc::newDocument()
+ {
++ bool state = UMLApp::app()->document()->loading();
++ UMLApp::app()->document()->setLoading(false);
++
+ closeDocument();
+ UMLApp::app()->setCurrentView(0);
+ setUrlUntitled();
+@@ -465,6 +468,7 @@ bool UMLDoc::newDocument()
+ UMLApp::app()->enableUndoAction(false);
+ UMLApp::app()->clearUndoStack();
+
++ UMLApp::app()->document()->setLoading(state);
+ return true;
+ }
+
+--
+cgit v0.11.2
+