summaryrefslogtreecommitdiff
path: root/user/util-macros
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 00:41:43 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 00:41:43 -0500
commit1fc2e08291003639f3c325df5fe4240cc286b06c (patch)
treec3ff34591f1bfc05270530fb7e84f457604b69f1 /user/util-macros
parentf282f15ae747cab342559be7ec65c9bee4c9ba55 (diff)
downloadpackages-1fc2e08291003639f3c325df5fe4240cc286b06c.tar.gz
packages-1fc2e08291003639f3c325df5fe4240cc286b06c.tar.bz2
packages-1fc2e08291003639f3c325df5fe4240cc286b06c.tar.xz
packages-1fc2e08291003639f3c325df5fe4240cc286b06c.zip
user/util-macros: bump, take
Diffstat (limited to 'user/util-macros')
-rw-r--r--user/util-macros/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/util-macros/APKBUILD b/user/util-macros/APKBUILD
new file mode 100644
index 000000000..f5b24e8b2
--- /dev/null
+++ b/user/util-macros/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=util-macros
+pkgver=1.19.2
+pkgrel=0
+pkgdesc="X.Org Autotools macros"
+url="https://www.X.Org/"
+arch="noarch"
+license="MIT"
+depends=""
+makedepends=""
+source="https://www.X.Org/releases/individual/util/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="3f51504b27f0478c136126f15110cf3cdbba218c4d74a8e974cca1381c6e8364609bd0c444f2fb19aa86a7f4e848dfce4f4da940463b224036f75a60b3d88619 util-macros-1.19.2.tar.bz2"