summaryrefslogtreecommitdiff
path: root/user/valgrind
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-08-23 14:56:23 -0500
committerZach van Rijn <me@zv.io>2023-08-23 14:56:23 -0500
commitd9cb2749153211fca6557c7ee3fff65ec2009921 (patch)
tree980c40da41bb7f7ba3fc155a030aa0318f6efa20 /user/valgrind
parentdab0c53b3336818bc933dbace50d90fe425f43d7 (diff)
downloadpackages-d9cb2749153211fca6557c7ee3fff65ec2009921.tar.gz
packages-d9cb2749153211fca6557c7ee3fff65ec2009921.tar.bz2
packages-d9cb2749153211fca6557c7ee3fff65ec2009921.tar.xz
packages-d9cb2749153211fca6557c7ee3fff65ec2009921.zip
user/valgrind: bump { 3.19.0 --> 3.21.0 }.
Diffstat (limited to 'user/valgrind')
-rw-r--r--user/valgrind/APKBUILD13
-rw-r--r--user/valgrind/realloc.patch24
2 files changed, 5 insertions, 32 deletions
diff --git a/user/valgrind/APKBUILD b/user/valgrind/APKBUILD
index 77772afc9..7a038a2bd 100644
--- a/user/valgrind/APKBUILD
+++ b/user/valgrind/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=valgrind
-pkgver=3.19.0
+pkgver=3.21.0
pkgrel=0
pkgdesc="A tool to help find memory-management problems in programs"
-url="http://valgrind.org/"
+url="https://valgrind.org/"
arch="all"
# from README_PACKAGERS:
# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
@@ -19,7 +19,6 @@ source="ftp://sourceware.org/pub/$pkgname/$pkgname-$pkgver.tar.bz2
0001-Ensure-ELFv2-is-supported-on-PPC64.patch
arm.patch
ppc64-support-tkill.patch
- realloc.patch
"
prepare() {
@@ -56,13 +55,11 @@ package() {
strip "$pkgdir"/usr/bin/valgrind \
"$pkgdir"/usr/bin/valgrind-di-server \
"$pkgdir"/usr/bin/vgdb \
- "$pkgdir"/usr/bin/valgrind-listener \
- "$pkgdir"/usr/bin/cg_merge
+ "$pkgdir"/usr/bin/valgrind-listener
fi
}
-sha512sums="f720a89dc4c4989cc5714bff9efe97529f71990bcfad7a92b889ce099c4326d6da07fa4d5fbab2e9125e20f352354f6178471e49e419b613a3c82c2a1c667ab2 valgrind-3.19.0.tar.bz2
+sha512sums="3e86cda2f2d6cd30807fac7933ba2c46a97a2b4a868db989e6b0cceeadf029af7ee34ba900466a346948289aacb30f4399799bb83b97cc49a4d2d810441e5cfd valgrind-3.21.0.tar.bz2
f90aa3cef5d3561d4602ff63b8f355b8427cbe6bb2ecd6bfc2e2bb063915fa40a70d923dbc60a643ee3fb7bcfbbddac049c6f6133c541189dd82b891f7ad9dbc 0001-Ensure-ELFv2-is-supported-on-PPC64.patch
9ee297d1b2b86891584443ad0caadc4977e1447979611ccf1cc55dbee61911b0b063bc4ad936d86c451cedae410cb3219b5a088b2ad0aa17df182d564fe36cfe arm.patch
-daf819d0f9bbbaf4243c7bf931fed840f1f55304df1b45d4a72ceaf8403b8e0e1fc8079343b86106f0741aa812560a466389d7d3878c5547f3ff7a9e46e63df7 ppc64-support-tkill.patch
-57086a768f3876b26b0e507bc159a73f0955f03d5af8cc30e21103e348ca67f2e58b5555a5a97f299751c6602692ad43d8346bb68a80917d740fb4d65bba9665 realloc.patch"
+daf819d0f9bbbaf4243c7bf931fed840f1f55304df1b45d4a72ceaf8403b8e0e1fc8079343b86106f0741aa812560a466389d7d3878c5547f3ff7a9e46e63df7 ppc64-support-tkill.patch"
diff --git a/user/valgrind/realloc.patch b/user/valgrind/realloc.patch
deleted file mode 100644
index d0eb795b8..000000000
--- a/user/valgrind/realloc.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- valgrind-3.13.0/coregrind/m_replacemalloc/vg_replace_malloc.c
-+++ valgrind-3.13.0/coregrind/m_replacemalloc/vg_replace_malloc.c
-@@ -765,13 +765,15 @@ static void init(void);
- DO_INIT; \
- MALLOC_TRACE("realloc(%p,%llu)", ptrV, (ULong)new_size ); \
- \
-- if (ptrV == NULL) \
-- /* We need to call a malloc-like function; so let's use \
-- one which we know exists. */ \
-- return VG_REPLACE_FUNCTION_EZU(10010,VG_Z_LIBC_SONAME,malloc) \
-- (new_size); \
-+ if (ptrV == NULL) { \
-+ TRIGGER_MEMCHECK_ERROR_IF_UNDEFINED(new_size); \
-+ v = (void*)VALGRIND_NON_SIMD_CALL1( info.tl_malloc, new_size ); \
-+ MALLOC_TRACE(" = %p\n", v ); \
-+ return v; \
-+ } \
- if (new_size <= 0) { \
-- VG_REPLACE_FUNCTION_EZU(10050,VG_Z_LIBC_SONAME,free)(ptrV); \
-+ if (ptrV != NULL) \
-+ VALGRIND_NON_SIMD_CALL1( info.tl_free, ptrV ); \
- MALLOC_TRACE(" = 0\n"); \
- return NULL; \
- } \