summaryrefslogtreecommitdiff
path: root/user/volume_key/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-27 15:18:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-07 09:57:58 -0500
commit426181ae3bc26b8fb15fb712ec8cf14e0832a3c0 (patch)
tree537f0b45356df69e90cdf478508f1b26bfd8ba71 /user/volume_key/APKBUILD
parentc34c173a5a0c7f3cdce39c5bce2126d4e8f3cda5 (diff)
downloadpackages-426181ae3bc26b8fb15fb712ec8cf14e0832a3c0.tar.gz
packages-426181ae3bc26b8fb15fb712ec8cf14e0832a3c0.tar.bz2
packages-426181ae3bc26b8fb15fb712ec8cf14e0832a3c0.tar.xz
packages-426181ae3bc26b8fb15fb712ec8cf14e0832a3c0.zip
user/volume_key: Fix build against Python 3
If the build environment has a /usr/bin/python, the build system believes it is Python 2. Ensure that does not happen.
Diffstat (limited to 'user/volume_key/APKBUILD')
-rw-r--r--user/volume_key/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/user/volume_key/APKBUILD b/user/volume_key/APKBUILD
index d6d22c271..69da50792 100644
--- a/user/volume_key/APKBUILD
+++ b/user/volume_key/APKBUILD
@@ -21,13 +21,15 @@ prepare() {
}
build() {
- ./configure \
+ PYTHON3=python3.11 ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --with-python=no \
+ --with-python3
make
}