summaryrefslogtreecommitdiff
path: root/user/wayland-protocols/test.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-07-02 20:13:25 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit70f899055f40b6d3ae191c88c842267a95199e46 (patch)
treecb2221b5e1a7b147d97ef90d541dad7be51d67e6 /user/wayland-protocols/test.patch
parent4693ca07c6a9ea6d954697224af118ee0fa0d028 (diff)
downloadpackages-70f899055f40b6d3ae191c88c842267a95199e46.tar.gz
packages-70f899055f40b6d3ae191c88c842267a95199e46.tar.bz2
packages-70f899055f40b6d3ae191c88c842267a95199e46.tar.xz
packages-70f899055f40b6d3ae191c88c842267a95199e46.zip
user/wayland-protocols: Update to 1.25, fix tests
Diffstat (limited to 'user/wayland-protocols/test.patch')
-rw-r--r--user/wayland-protocols/test.patch66
1 files changed, 66 insertions, 0 deletions
diff --git a/user/wayland-protocols/test.patch b/user/wayland-protocols/test.patch
new file mode 100644
index 000000000..b7a5e26ea
--- /dev/null
+++ b/user/wayland-protocols/test.patch
@@ -0,0 +1,66 @@
+xdg-decoration-unstable-v1 needs xdg-toplevel but does not define it.
+This leads to a linker failure on at least ppc64.
+
+--- wayland-protocols-1.25/tests/meson.build.old 2022-01-28 10:00:40.731421000 -0600
++++ wayland-protocols-1.25/tests/meson.build 2022-07-02 20:09:54.653454716 -0500
+@@ -88,32 +88,34 @@
+ ]
+
+ # Check that header can be included by a pedantic C99 compiler
+- test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
+- test_name_source = '@0@.c'.format(test_name)
+- test_source = custom_target(
+- test_name_source,
+- input: 'build-pedantic.c.in',
+- output: test_name_source,
+- command: replace_command,
+- )
+- pedantic_test_executable = executable(
+- test_name,
+- [
+- test_source,
+- client_header,
+- server_header,
+- code
+- ],
+- link_args: extra_linker_flags,
+- dependencies: libwayland,
+- c_args: [
+- '-std=c99',
+- '-pedantic',
+- '-Wall',
+- '-Werror' ],
+- install: false,
+- )
+- test(test_name, pedantic_test_executable)
++ if not protocol_file.contains('xdg-decoration-unstable-v1')
++ test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
++ test_name_source = '@0@.c'.format(test_name)
++ test_source = custom_target(
++ test_name_source,
++ input: 'build-pedantic.c.in',
++ output: test_name_source,
++ command: replace_command,
++ )
++ pedantic_test_executable = executable(
++ test_name,
++ [
++ test_source,
++ client_header,
++ server_header,
++ code
++ ],
++ link_args: extra_linker_flags,
++ dependencies: libwayland,
++ c_args: [
++ '-std=c99',
++ '-pedantic',
++ '-Wall',
++ '-Werror' ],
++ install: false,
++ )
++ test(test_name, pedantic_test_executable)
++ endif
+
+ # Check that the header
+ if not protocol_file.contains('xdg-foreign-unstable-v1')