summaryrefslogtreecommitdiff
path: root/user/weechat
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-25 19:08:44 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-25 19:09:34 -0500
commitb234299e70c50f6cab203a11ab62be733726770b (patch)
treeb49230bdf3e9106394a4fe2a439efd6cc76df636 /user/weechat
parent45b2f80485481b7e062de2ed92bbe11ee942a17b (diff)
downloadpackages-b234299e70c50f6cab203a11ab62be733726770b.tar.gz
packages-b234299e70c50f6cab203a11ab62be733726770b.tar.bz2
packages-b234299e70c50f6cab203a11ab62be733726770b.tar.xz
packages-b234299e70c50f6cab203a11ab62be733726770b.zip
user/weechat: bump to 2.2, modernise, Guile support removed upstream
Diffstat (limited to 'user/weechat')
-rw-r--r--user/weechat/APKBUILD22
-rw-r--r--user/weechat/fix-python-linking.patch4
2 files changed, 12 insertions, 14 deletions
diff --git a/user/weechat/APKBUILD b/user/weechat/APKBUILD
index 660a85468..2a1a5d558 100644
--- a/user/weechat/APKBUILD
+++ b/user/weechat/APKBUILD
@@ -1,25 +1,23 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=weechat
-pkgver=2.1
+pkgver=2.2
pkgrel=0
-pkgdesc="A fast, light, extensible ncurses-based chat client"
-url="http://www.weechat.org"
+pkgdesc="Fast, light, extensible ncurses-based chat client"
+url="https://www.weechat.org"
arch="all"
-license="GPL-3.0+"
options="!check" # requires all plugins be built.
-depends_dev="cmake gettext-dev ncurses-dev gnutls-dev libgcrypt-dev curl-dev
- aspell-dev guile-dev lua5.3-dev perl-dev python3-dev zlib-dev"
+license="GPL-3.0+"
+depends_dev="cmake aspell-dev curl-dev gnutls-dev libgcrypt-dev lua5.3-dev
+ ncurses-dev perl-dev python3-dev zlib-dev"
makedepends="$depends_dev"
checkdepends="cpputest"
subpackages="$pkgname-dev $pkgname-aspell:_plugin $pkgname-lua:_plugin
- $pkgname-perl:_plugin $pkgname-python:_plugin
- $pkgname-guile:_plugin $pkgname-lang"
-source="http://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
+ $pkgname-perl:_plugin $pkgname-python:_plugin $pkgname-lang"
+source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
fix-python-linking.patch
libintl-fix.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
# 1.7.1-r0:
@@ -63,6 +61,6 @@ check() {
ctest -V
}
-sha512sums="36b18d194bfc1dc3a9e0c5d009d66154d222d3c357935efe98b8bb5bb9bb8aa37de426f6863eabdbf8cedbaf78af7d5d5ca4882120ed2dfbe4c60a6bf20077c2 weechat-2.1.tar.gz
-23b1e3fa9fcade74738d9013b533a0be01dbadabe8a7d82c97d338cdf3e4efe0943b9671f6ec47ac4838d3ad29ab4fd2ce0e6b3c74b4c7280abfd7b040407678 fix-python-linking.patch
+sha512sums="aa729ce8cd0e398d7f5f3155db3bff473885d64ad444ca7f10b2f9874e90e31205783119ec4c31fca65de0a7c636cd5fe605d40bbbd31cb09893f20cc4332375 weechat-2.2.tar.gz
+95f6d1405141421fae70288ec560a6d61f0bde1ce0bfa6e522e24a9673e699099594e83511b39e413aff28010ea1f7f1672af051ac370b152c732d6ca36a9056 fix-python-linking.patch
59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca libintl-fix.patch"
diff --git a/user/weechat/fix-python-linking.patch b/user/weechat/fix-python-linking.patch
index c94be8026..c45d3af3a 100644
--- a/user/weechat/fix-python-linking.patch
+++ b/user/weechat/fix-python-linking.patch
@@ -4,8 +4,8 @@
)
if(ENABLE_PYTHON3)
find_library(PYTHON_LIBRARY
-- NAMES python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
-+ NAMES python3.6m python3.6 python3.5m python3.5 python3.4m python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
+- NAMES python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python3 python2.7 python2.6 python2.5 python
++ NAMES python3.7m python3.7 python3.6m python3.6 python3.5m python3.5 python3.4m python3.4 python3.3 python3.2 python3.1 python3.0 python3
HINTS ${PYTHON_POSSIBLE_LIB_PATH}
)
else()