summaryrefslogtreecommitdiff
path: root/user/weechat
diff options
context:
space:
mode:
authorzlg <zlg@zlg.space>2018-11-21 01:50:16 -0800
committerzlg <zlg@zlg.space>2018-11-21 02:53:31 -0800
commite4969194f5031b1c56a9cc7aee5f0a13d8243584 (patch)
tree8148ca43ecf3cffed269037fd03edc528c20d61b /user/weechat
parente48520ec1e55df33a5303920467f286f3b1566f7 (diff)
downloadpackages-e4969194f5031b1c56a9cc7aee5f0a13d8243584.tar.gz
packages-e4969194f5031b1c56a9cc7aee5f0a13d8243584.tar.bz2
packages-e4969194f5031b1c56a9cc7aee5f0a13d8243584.tar.xz
packages-e4969194f5031b1c56a9cc7aee5f0a13d8243584.zip
user/weechat: fix overzealous highlighting bug
Diffstat (limited to 'user/weechat')
-rw-r--r--user/weechat/APKBUILD5
-rw-r--r--user/weechat/fix-unsigned-char.patch37
2 files changed, 41 insertions, 1 deletions
diff --git a/user/weechat/APKBUILD b/user/weechat/APKBUILD
index 3cca9f41a..6f8bb3701 100644
--- a/user/weechat/APKBUILD
+++ b/user/weechat/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=weechat
pkgver=2.3
-pkgrel=0
+pkgrel=1
pkgdesc="Fast, light, extensible ncurses-based chat client"
url="https://www.weechat.org"
arch="all"
@@ -16,6 +17,7 @@ subpackages="$pkgname-dev $pkgname-aspell:_plugin $pkgname-lua:_plugin
$pkgname-perl:_plugin $pkgname-python:_plugin $pkgname-lang"
source="https://www.weechat.org/files/src/$pkgname-$pkgver.tar.gz
fix-python-linking.patch
+ fix-unsigned-char.patch
libintl-fix.patch
"
@@ -63,4 +65,5 @@ check() {
sha512sums="3315eb672d099dec041a6ece268e3efac9f766fe8273b13810c9ed6bc9129ed0db9730a027db6cdf157338472caf99d60aaf3de9b096a3c395fdf889b106aaea weechat-2.3.tar.gz
95f6d1405141421fae70288ec560a6d61f0bde1ce0bfa6e522e24a9673e699099594e83511b39e413aff28010ea1f7f1672af051ac370b152c732d6ca36a9056 fix-python-linking.patch
+e9dddc914f08660c49fd3331ebdca73a3df7e165b284d8b19e0487974ec2d8d75d03cd6d07da6ba9783015ddb19d6c118b697a830dcbea13f078ca7826223370 fix-unsigned-char.patch
59841bc343b1d10a542631eb01380789f96cac896380dbb3b159444c4806bd6367952e457b9ffd42fb87c1e19fc77eba78c38fd2178ef202ab9f7f1a543417ca libintl-fix.patch"
diff --git a/user/weechat/fix-unsigned-char.patch b/user/weechat/fix-unsigned-char.patch
new file mode 100644
index 000000000..d4acd1986
--- /dev/null
+++ b/user/weechat/fix-unsigned-char.patch
@@ -0,0 +1,37 @@
+This patch is backported from the upcoming 2.4 release. It corrects
+highlighting behavior for plugins such as urlserver.py.
+
+See-Also: https://github.com/weechat/weechat/issues/1277
+Patch-Author: Sébastien Helleu <flashcode@flashtux.org>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0ae69ea0f..1d7738af5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -27,8 +27,8 @@ project(weechat C)
+ set(CMAKE_VERBOSE_MAKEFILE OFF)
+ set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake ${CMAKE_MODULE_PATH})
+ set(CMAKE_SKIP_RPATH ON)
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
+-set(CMAKE_CXX_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror-implicit-function-declaration")
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fsigned-char -Wall -Wextra -Werror-implicit-function-declaration")
+
+ # version
+ execute_process(COMMAND ${CMAKE_SOURCE_DIR}/version.sh devel-major OUTPUT_VARIABLE VERSION_MAJOR)
+diff --git a/configure.ac b/configure.ac
+index d267ca10f..a0bf00078 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1330,7 +1330,7 @@ AC_DEFINE_UNQUOTED(WEECHAT_SHAREDIR, "$WEECHAT_SHAREDIR")
+ weechat_libdir=${libdir}/weechat
+ AC_SUBST(weechat_libdir)
+
+-COMMON_CFLAGS="-Wall -Wextra -Werror-implicit-function-declaration"
++COMMON_CFLAGS="-fsigned-char -Wall -Wextra -Werror-implicit-function-declaration"
+ AC_MSG_CHECKING([whether we have GNU assembler])
+ GAS=`as --version < /dev/null 2>/dev/null | grep GNU`
+ if test "$GAS"; then
+--
+2.19.1
+