summaryrefslogtreecommitdiff
path: root/user/wimlib
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-06-12 23:46:44 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-06-12 23:46:44 +0000
commitc0f1a6973237aec01c7942a0541715e7ea1720d6 (patch)
tree3c21c29aafcfdb10ea065439835572a855322bba /user/wimlib
parentbe87f4ccc042f1b8a9db033ff5f52692b3138bc2 (diff)
downloadpackages-c0f1a6973237aec01c7942a0541715e7ea1720d6.tar.gz
packages-c0f1a6973237aec01c7942a0541715e7ea1720d6.tar.bz2
packages-c0f1a6973237aec01c7942a0541715e7ea1720d6.tar.xz
packages-c0f1a6973237aec01c7942a0541715e7ea1720d6.zip
user/wimlib: new port
Diffstat (limited to 'user/wimlib')
-rw-r--r--user/wimlib/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/wimlib/APKBUILD b/user/wimlib/APKBUILD
new file mode 100644
index 000000000..a8268910a
--- /dev/null
+++ b/user/wimlib/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: CyberLeo <cyberleo@cyberleo.net>
+# Maintainer: CyberLeo <cyberleo@cyberleo.net>
+pkgname=wimlib
+pkgver=1.13.1
+pkgrel=0
+pkgdesc="Windows Imaging (WIM) archive manipulation library and tools"
+url="https://wimlib.net/"
+arch="all"
+license="(GPL-2.0 OR LGPL-2.1) AND CC0"
+depends=""
+makedepends="libxml2-dev fuse-dev ntfs-3g ntfs-3g-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
+source="https://wimlib.net/downloads/wimlib-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ PATH="/usr/sbin:${PATH}" make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="a874eafa979e715adf06398371380f06ae42370392473b2eb8aca969b2019664b187f3f2bfa74819bc1d85db4977a08e915c69efc67e77e933c82e6bbcda0243 wimlib-1.13.1.tar.gz"