summaryrefslogtreecommitdiff
path: root/user/wine/no-pie.patch
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-06-01 23:04:18 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-06-01 23:04:18 +0000
commit3b329c19497c9e83bf5173c5621147c1b8eab1da (patch)
tree5dbc157846d74ae588007d7656b6f169a4706cde /user/wine/no-pie.patch
parent8cbcedad8e10818a217c55770a378215fd1567ae (diff)
parent5befc512a356c813a292168c535e5c365cb69e2d (diff)
downloadpackages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.gz
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.bz2
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.xz
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.zip
Merge branch 'wine-4' into 'master'
user/wine: bump to 4.0.1, add mpg123 support I can backport the `mpg123` support if you'd like. I think I need to investigate Wine 3 a little more since there appears to be serious problems with it - like not even being able to move Notepad windows around without freezing. This problem is not present in Wine 4, so either something changed upstream or our package is corrupted. I will try a rebuild and see what happens. See merge request !230
Diffstat (limited to 'user/wine/no-pie.patch')
-rw-r--r--user/wine/no-pie.patch21
1 files changed, 9 insertions, 12 deletions
diff --git a/user/wine/no-pie.patch b/user/wine/no-pie.patch
index 5fb5d87b6..2874e0af8 100644
--- a/user/wine/no-pie.patch
+++ b/user/wine/no-pie.patch
@@ -1,14 +1,11 @@
-diff --git a/loader/Makefile.in b/loader/Makefile.in
-index 8190037..437d4d9 100644
---- a/loader/Makefile.in
-+++ b/loader/Makefile.in
-@@ -26,7 +26,7 @@ wine64_DEPS = $(WINELOADER_DEPENDS)
- wine64_LDFLAGS = $(LDEXECFLAGS) -lwine $(PTHREAD_LIBS)
+--- wine-4.0.1/configure.ac
++++ wine-4.0.1/configure.ac
+@@ -955,7 +955,7 @@
- wine_preloader_OBJS = preloader.o
--wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
+ [WINELOADER_LDFLAGS="-Wl,--export-dynamic"])
+- WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000"
++ WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie"
- wine64_preloader_OBJS = preloader.o
--wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--rpath,\$ORIGIN/../lib],
+ [LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"