summaryrefslogtreecommitdiff
path: root/user/wine/no-pie.patch
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-05-22 07:12:49 -0400
committerMax Rees <maxcrees@me.com>2019-05-22 07:12:49 -0400
commit5befc512a356c813a292168c535e5c365cb69e2d (patch)
tree5fdbaea3a63ed8c34063c43036151407a12a7a39 /user/wine/no-pie.patch
parent0ee2191bdaf224bcc5c9bd4cfd3e42e0fe5fed16 (diff)
downloadpackages-5befc512a356c813a292168c535e5c365cb69e2d.tar.gz
packages-5befc512a356c813a292168c535e5c365cb69e2d.tar.bz2
packages-5befc512a356c813a292168c535e5c365cb69e2d.tar.xz
packages-5befc512a356c813a292168c535e5c365cb69e2d.zip
user/wine: bump to 4.0.1, add mpg123 support
Diffstat (limited to 'user/wine/no-pie.patch')
-rw-r--r--user/wine/no-pie.patch21
1 files changed, 9 insertions, 12 deletions
diff --git a/user/wine/no-pie.patch b/user/wine/no-pie.patch
index 5fb5d87b6..2874e0af8 100644
--- a/user/wine/no-pie.patch
+++ b/user/wine/no-pie.patch
@@ -1,14 +1,11 @@
-diff --git a/loader/Makefile.in b/loader/Makefile.in
-index 8190037..437d4d9 100644
---- a/loader/Makefile.in
-+++ b/loader/Makefile.in
-@@ -26,7 +26,7 @@ wine64_DEPS = $(WINELOADER_DEPENDS)
- wine64_LDFLAGS = $(LDEXECFLAGS) -lwine $(PTHREAD_LIBS)
+--- wine-4.0.1/configure.ac
++++ wine-4.0.1/configure.ac
+@@ -955,7 +955,7 @@
- wine_preloader_OBJS = preloader.o
--wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
+ [WINELOADER_LDFLAGS="-Wl,--export-dynamic"])
+- WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000"
++ WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie"
- wine64_preloader_OBJS = preloader.o
--wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--rpath,\$ORIGIN/../lib],
+ [LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"