summaryrefslogtreecommitdiff
path: root/user/wireguard-module/APKBUILD
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2019-12-28 10:33:20 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2019-12-28 10:40:45 +0100
commitd3ea30be5b638892f5476c240b46880ca5379a99 (patch)
tree88f95bc8b6023a799f08355774d7efaef93fd907 /user/wireguard-module/APKBUILD
parentc7c0916fad338d4743257d0f05e357e9c0f1f670 (diff)
downloadpackages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.gz
packages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.bz2
packages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.xz
packages-d3ea30be5b638892f5476c240b46880ca5379a99.zip
user/wireguard-*: bump to 20191226 and account for repo changes
Upstream split the monolithic WireGuard repo into wireguard-linux-compat and wireguard-tools. This mostly just requires changing the URL, but in one case, we move the patch creation subpackage from wireguard-tools to wireguard-module, since that's where those scripts actually exist.
Diffstat (limited to 'user/wireguard-module/APKBUILD')
-rw-r--r--user/wireguard-module/APKBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/user/wireguard-module/APKBUILD b/user/wireguard-module/APKBUILD
index 2e4a7e74f..0471f0a01 100644
--- a/user/wireguard-module/APKBUILD
+++ b/user/wireguard-module/APKBUILD
@@ -3,11 +3,11 @@
# KEEP THIS IN SYNC with the other wireguard-module packages.
_kflavour=""
_kver="4.14.138-mc15"
-pkgver=0.0.20191012
+pkgver=0.0.20191226
pkgrel=0
_pkgname="wireguard-module$_kflavour"
pkgname="$_pkgname-$_kver"
-_pkgreal="WireGuard"
+_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="all"
@@ -16,7 +16,8 @@ license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
depends="easy-kernel$_kflavour-modules-$_kver"
makedepends="easy-kernel$_kflavour-src-$_kver"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
+subpackages="wireguard-patch:_patch:noarch"
+source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -29,4 +30,13 @@ package() {
make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
}
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+_patch() {
+ depends=""
+ pkgdesc="Kernel patch for the WireGuard VPN"
+
+ cd "$builddir"
+ mkdir -p "$subpkgdir/usr/share/wireguard"
+ kernel-tree-scripts/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
+}
+
+sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"