summaryrefslogtreecommitdiff
path: root/user/wireguard-module
diff options
context:
space:
mode:
authorLuis Ressel <aranea@aixah.de>2020-01-10 12:04:51 +0100
committerLuis Ressel <aranea@aixah.de>2020-01-10 12:05:22 +0100
commit526bd9f0171eaf47e620714600c0c684eaa764ca (patch)
treec8669c67fcc98b6a8454fccb4195d2c21f016a7d /user/wireguard-module
parentc667559d5c2595f81bb181df7a8790b907ba9d28 (diff)
downloadpackages-526bd9f0171eaf47e620714600c0c684eaa764ca.tar.gz
packages-526bd9f0171eaf47e620714600c0c684eaa764ca.tar.bz2
packages-526bd9f0171eaf47e620714600c0c684eaa764ca.tar.xz
packages-526bd9f0171eaf47e620714600c0c684eaa764ca.zip
user/wireguard-module: Bump to 0.0.20200105
Diffstat (limited to 'user/wireguard-module')
-rw-r--r--user/wireguard-module/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/user/wireguard-module/APKBUILD b/user/wireguard-module/APKBUILD
index 614beff16..e77179680 100644
--- a/user/wireguard-module/APKBUILD
+++ b/user/wireguard-module/APKBUILD
@@ -1,11 +1,9 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
-# KEEP THIS IN SYNC with the other wireguard-module packages.
-_kflavour=""
_kver="5.4.5-mc0"
-pkgver=0.0.20191226
+pkgver=0.0.20200105
pkgrel=0
-_pkgname="wireguard-module$_kflavour"
+_pkgname="wireguard-module"
pkgname="$_pkgname-$_kver"
_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
@@ -14,23 +12,23 @@ arch="all"
options="!check !dbg !strip" # no test suite
license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
-depends="easy-kernel$_kflavour-modules-$_kver"
-makedepends="easy-kernel$_kflavour-src-$_kver"
+depends="easy-kernel-modules-$_kver"
+makedepends="easy-kernel-src-$_kver"
subpackages="wireguard-patch:_patch:noarch"
source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver$_kflavour" module
+ make -C src LDFLAGS="" KERNELDIR="/usr/src/linux-$_kver" module
}
package() {
if [ -f $HOME/kernel_key.pem ]; then
- /usr/src/linux-$_kver$_kflavour/scripts/sign-file sha512 \
+ /usr/src/linux-$_kver/scripts/sign-file sha512 \
$HOME/kernel_key.pem $HOME/kernel_key.pem \
"$builddir"/src/wireguard.ko
fi
- make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
+ make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver" INSTALL_MOD_PATH="$pkgdir" module-install
}
_patch() {
@@ -41,4 +39,4 @@ _patch() {
"$builddir"/kernel-tree-scripts/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
}
-sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"
+sha512sums="a27d863e7af9ecbdad784d9ebd6b7613cb6a3a8749d2552c0ecc932c606ed08effc9600813d8cc6801748041456d6e59aab28b9ba486986c88f3d2e90a9209bd wireguard-linux-compat-0.0.20200105.tar.xz"