summaryrefslogtreecommitdiff
path: root/user/wireguard-tools
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2019-12-28 10:33:20 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2019-12-28 10:40:45 +0100
commitd3ea30be5b638892f5476c240b46880ca5379a99 (patch)
tree88f95bc8b6023a799f08355774d7efaef93fd907 /user/wireguard-tools
parentc7c0916fad338d4743257d0f05e357e9c0f1f670 (diff)
downloadpackages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.gz
packages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.bz2
packages-d3ea30be5b638892f5476c240b46880ca5379a99.tar.xz
packages-d3ea30be5b638892f5476c240b46880ca5379a99.zip
user/wireguard-*: bump to 20191226 and account for repo changes
Upstream split the monolithic WireGuard repo into wireguard-linux-compat and wireguard-tools. This mostly just requires changing the URL, but in one case, we move the patch creation subpackage from wireguard-tools to wireguard-module, since that's where those scripts actually exist.
Diffstat (limited to 'user/wireguard-tools')
-rw-r--r--user/wireguard-tools/APKBUILD25
1 files changed, 7 insertions, 18 deletions
diff --git a/user/wireguard-tools/APKBUILD b/user/wireguard-tools/APKBUILD
index 1ee00b549..21875f043 100644
--- a/user/wireguard-tools/APKBUILD
+++ b/user/wireguard-tools/APKBUILD
@@ -1,8 +1,7 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=wireguard-tools
-_pkgreal=WireGuard
-pkgver=0.0.20191012
+pkgver=1.0.20191226
pkgrel=0
pkgdesc="Userland tools for the WireGuard VPN"
url="https://www.wireguard.com/"
@@ -11,18 +10,18 @@ options="!check" # no test suite
license="GPL-2.0-only"
depends="bash iproute2"
makedepends="libmnl-dev"
-subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc wireguard-patch:_patch:noarch"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
-builddir="$srcdir/$_pkgreal-$pkgver"
+subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
+source="https://git.zx2c4.com/$pkgname/snapshot/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make RUNSTATEDIR=/run -C src/tools
+ make RUNSTATEDIR=/run -C src
}
package() {
cd "$builddir"
- make WITH_BASHCOMPLETION=yes WITH_WGQUICK=yes DESTDIR="$pkgdir" -C src/tools install
+ make WITH_BASHCOMPLETION=yes WITH_WGQUICK=yes DESTDIR="$pkgdir" -C src install
}
bashcomp() {
@@ -33,14 +32,4 @@ bashcomp() {
mv "$pkgdir/usr/share/bash-completion" "$subpkgdir/usr/share/"
}
-_patch() {
- depends=""
- pkgdesc="Kernel patch for the WireGuard VPN"
-
- cd "$builddir"
- mkdir -p "$subpkgdir/usr/share/wireguard"
- contrib/kernel-tree/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
-
-}
-
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+sha512sums="e6b7fc34f9517efc830b751e054e811acdd7f210e8f68b5ad5a503ee0c081bcb1a65e64e82a0b66ddfea9ef3ea0ca3210d5620c278d1b17442e233be1734ef03 wireguard-tools-1.0.20191226.tar.xz"