summaryrefslogtreecommitdiff
path: root/user/x265
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 19:37:45 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-28 19:37:45 +0000
commit03f56c6f7c063b4cf021c1f3775ae102fedc85f6 (patch)
tree18ab923738bb93d1086da0dcf8ae963b31652ec7 /user/x265
parent902da7a13de82eaaee5bf001802e073ec5267b54 (diff)
downloadpackages-03f56c6f7c063b4cf021c1f3775ae102fedc85f6.tar.gz
packages-03f56c6f7c063b4cf021c1f3775ae102fedc85f6.tar.bz2
packages-03f56c6f7c063b4cf021c1f3775ae102fedc85f6.tar.xz
packages-03f56c6f7c063b4cf021c1f3775ae102fedc85f6.zip
user/x265: Modernise and fix syntax
Diffstat (limited to 'user/x265')
-rw-r--r--user/x265/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/user/x265/APKBUILD b/user/x265/APKBUILD
index 6d84c5499..0ca89487e 100644
--- a/user/x265/APKBUILD
+++ b/user/x265/APKBUILD
@@ -8,6 +8,7 @@ url="http://x265.org"
arch="all"
options="textrels"
license="GPL-2.0-only"
+depends=""
makedepends="cmake yasm" # 2.6+ will use nasm instead of yasm
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/multicoreware/$pkgname/downloads/${pkgname}_${pkgver}.tar.gz
@@ -17,7 +18,7 @@ builddir="$srcdir/${pkgname}_$pkgver"
build() {
cd "$builddir"/build/linux
- local cmake_opts=""
+ cmake_opts=""
case "$CARCH" in
# unfortunately, AltiVec code is very broken (more than 1000 errors)
ppc*) cmake_opts="-DENABLE_ALTIVEC=OFF -DCPU_POWER8=OFF";;