summaryrefslogtreecommitdiff
path: root/user/xabacus
diff options
context:
space:
mode:
authorHorst G. Burkhardt <horst@adelielinux.org>2018-06-26 21:21:27 +0000
committerHorst G. Burkhardt <horst@adelielinux.org>2018-06-26 21:21:27 +0000
commit8d91add99a801cda01281f6ff59e66e64cc4369b (patch)
tree13034ab7272d46a982a402ae14ff96a00a90b6a1 /user/xabacus
parentfa2852991f2326368c0ac6a9729d99b6109fc315 (diff)
downloadpackages-8d91add99a801cda01281f6ff59e66e64cc4369b.tar.gz
packages-8d91add99a801cda01281f6ff59e66e64cc4369b.tar.bz2
packages-8d91add99a801cda01281f6ff59e66e64cc4369b.tar.xz
packages-8d91add99a801cda01281f6ff59e66e64cc4369b.zip
user/xabacus: new package
Diffstat (limited to 'user/xabacus')
-rw-r--r--user/xabacus/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/xabacus/APKBUILD b/user/xabacus/APKBUILD
new file mode 100644
index 000000000..ac3b8b6c1
--- /dev/null
+++ b/user/xabacus/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=xabacus
+pkgver=8.1.7
+pkgrel=1
+pkgdesc="a simple X11 abacus widget"
+url="http://www.sillycycle.com/abacus.html"
+arch="all !s390x"
+options="!check" # xabacus does not ship a test suite
+license="MIT"
+depends=""
+makedepends="libx11-dev libxpm-dev libxt-dev libxml2-dev"
+source="http://www.sillycycle.com/abacus/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install
+ make install-png
+}
+
+sha512sums="6e126d79c606f5d10689bc6f495f3e586351ce9500f83c0a03ac772471c9f788e08efe228356da1c1479acc8b2d5f406b6d82ac78066e18ed8ac6e24502524bb xabacus-8.1.7.tar.xz"