summaryrefslogtreecommitdiff
path: root/user/xapian-core/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 21:58:35 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-15 22:46:32 -0500
commitc15d4cceb9a68f73116a23993fbed98f4f6c7176 (patch)
tree10a976f56e788a5a57af42625776686d6074c1d8 /user/xapian-core/APKBUILD
parent7669a8d5e0a610c67e08a02d872e7411070fc792 (diff)
downloadpackages-c15d4cceb9a68f73116a23993fbed98f4f6c7176.tar.gz
packages-c15d4cceb9a68f73116a23993fbed98f4f6c7176.tar.bz2
packages-c15d4cceb9a68f73116a23993fbed98f4f6c7176.tar.xz
packages-c15d4cceb9a68f73116a23993fbed98f4f6c7176.zip
user/xapian-core: sec bump to 1.4.6, fix, disable check
Diffstat (limited to 'user/xapian-core/APKBUILD')
-rw-r--r--user/xapian-core/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/user/xapian-core/APKBUILD b/user/xapian-core/APKBUILD
new file mode 100644
index 000000000..eac1f412f
--- /dev/null
+++ b/user/xapian-core/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer:
+pkgname=xapian-core
+pkgver=1.4.6
+pkgrel=0
+pkgdesc="Open source search engine library"
+url="https://xapian.org/"
+arch="all"
+options="!check" # https://trac.xapian.org/ticket/764
+license="GPL-2.0+"
+depends=""
+depends_dev="zlib-dev util-linux-dev"
+makedepends="$depends_dev libtool"
+subpackages="$pkgname-dev $pkgname-doc libxapian"
+source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
+ timeval-t.patch"
+
+case "$CARCH" in
+armhf) options="!check" ;; # FIXME
+s390x) options="!check" ;; # FIXME
+esac
+
+# secfixes:
+# 1.4.6-r0:
+# - CVE-2018-0499
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make VALGRIND= check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+libxapian() {
+ pkgdesc="Xapian search engine library"
+
+ cd "$builddir"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/$subpkgname* "$subpkgdir"/usr/lib
+}
+
+sha512sums="f08168eba26a24ea00c2219d2cdfac1d904b51162fdd98d437564786375245e00010986a7d6e9c8c7548ae19aab80434b5cb0051252f902b40db2976b1008fe2 xapian-core-1.4.6.tar.xz
+639c0ecd75be0627d334628b5adf581a7da92c4f86dfb86a92669368ff8a874d4bf4e344b8f3b1276d22d126d2bc44c8ab727e39e1c29c0358fe7bbc8aa8050d timeval-t.patch"