summaryrefslogtreecommitdiff
path: root/user/xf86-video-tdfx
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-02 07:49:12 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-02 07:49:12 +0000
commit08c3574e23731a671ce1d9713c4b73c6039c064b (patch)
tree89c1e27b4fd684b29d9d24296f0896cdc8834306 /user/xf86-video-tdfx
parent660436ccb41f720b5b6e7c059d0352cfc57fbbb7 (diff)
downloadpackages-08c3574e23731a671ce1d9713c4b73c6039c064b.tar.gz
packages-08c3574e23731a671ce1d9713c4b73c6039c064b.tar.bz2
packages-08c3574e23731a671ce1d9713c4b73c6039c064b.tar.xz
packages-08c3574e23731a671ce1d9713c4b73c6039c064b.zip
user/xf86-video-tdfx: new package
Diffstat (limited to 'user/xf86-video-tdfx')
-rw-r--r--user/xf86-video-tdfx/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/xf86-video-tdfx/APKBUILD b/user/xf86-video-tdfx/APKBUILD
new file mode 100644
index 000000000..62b9217cc
--- /dev/null
+++ b/user/xf86-video-tdfx/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xf86-video-tdfx
+pkgver=1.4.7
+pkgrel=0
+pkgdesc="3Dfx video driver for X11"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="util-macros xorgproto-dev xorg-server-dev"
+subpackages="$pkgname-doc"
+source="https://www.x.org/releases/individual/driver/xf86-video-tdfx-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="573eea7a6b05ed33a963f8e2f80ac1cb14632b7fd10d8d90da16c07db432e73641ced885ee979f68e4ead8429b39506b2f231ca4ac296a0780c9f6d223c3b405 xf86-video-tdfx-1.4.7.tar.bz2"