summaryrefslogtreecommitdiff
path: root/user/xfce4-docklike-plugin
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2022-06-13 23:35:54 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commitbe815563c6bfd7e629dbcbe12d98aeb89a6fc84a (patch)
treeafe0e4c20344c6ec3a597b461af8bfd4960b89f3 /user/xfce4-docklike-plugin
parent9db82f49014266b2f6d8a8da7c8c37a034d8a329 (diff)
downloadpackages-be815563c6bfd7e629dbcbe12d98aeb89a6fc84a.tar.gz
packages-be815563c6bfd7e629dbcbe12d98aeb89a6fc84a.tar.bz2
packages-be815563c6bfd7e629dbcbe12d98aeb89a6fc84a.tar.xz
packages-be815563c6bfd7e629dbcbe12d98aeb89a6fc84a.zip
user/xfce4-docklike-plugin: new package
Diffstat (limited to 'user/xfce4-docklike-plugin')
-rw-r--r--user/xfce4-docklike-plugin/APKBUILD36
-rw-r--r--user/xfce4-docklike-plugin/xfce4-docklike-plugin-0.4.0-fix-missing-include.patch12
2 files changed, 48 insertions, 0 deletions
diff --git a/user/xfce4-docklike-plugin/APKBUILD b/user/xfce4-docklike-plugin/APKBUILD
new file mode 100644
index 000000000..cbcdf9ef6
--- /dev/null
+++ b/user/xfce4-docklike-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=xfce4-docklike-plugin
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="A modern, minimalist taskbar for XFCE"
+url="https://www.xfce.org"
+arch="all"
+license="GPL-3.0-only"
+depends=""
+makedepends="gtk+3.0-dev intltool libice-dev libwnck-dev libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+source="https://archive.xfce.org/src/panel-plugins/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ $pkgname-0.4.0-fix-missing-include.patch"
+
+build() {
+ LIBS="-lintl" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4da41fc9ebae96e706ce4def8c34d214bcd92910a19ea89d3a83bb2a24665a2382d5006908048756501c7e21475b5ff4043eedf6463a8b5294eaa2b2720149bc xfce4-docklike-plugin-0.4.0.tar.bz2
+6613eb5214bd88319f0bd9414cc6378647d7dd5b7f8b5624e72d8dc1ea8a7818033a3a4c9583dbe296398eb40ce1f093883fe74e31fffdfccfd2271771540da4 xfce4-docklike-plugin-0.4.0-fix-missing-include.patch"
diff --git a/user/xfce4-docklike-plugin/xfce4-docklike-plugin-0.4.0-fix-missing-include.patch b/user/xfce4-docklike-plugin/xfce4-docklike-plugin-0.4.0-fix-missing-include.patch
new file mode 100644
index 000000000..8437b4947
--- /dev/null
+++ b/user/xfce4-docklike-plugin/xfce4-docklike-plugin-0.4.0-fix-missing-include.patch
@@ -0,0 +1,12 @@
+diff -Nurd xfce4-docklike-plugin-0.4.0/src/Helpers.hpp xfce4-docklike-plugin-0.4.0.new/src/Helpers.hpp
+--- xfce4-docklike-plugin-0.4.0/src/Helpers.hpp 2021-07-27 03:48:58.000000000 +0000
++++ xfce4-docklike-plugin-0.4.0.new/src/Helpers.hpp 2022-06-13 23:22:13.807662271 +0000
+@@ -19,6 +19,8 @@
+ #include <string>
+ #include <vector>
+
++#include <libgen.h>
++
+ namespace Help
+ {
+ namespace String