summaryrefslogtreecommitdiff
path: root/user/xfce4-timer-plugin
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 19:47:36 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-08 22:15:55 -0500
commit9e33de969c033fde889324a3e473c99332a8acb9 (patch)
tree36a1c69bc1fa7822d7a98f43b5c2c0f7bde9eabf /user/xfce4-timer-plugin
parent61886c2c86e168e9ddeef8d4cfd26761117fca85 (diff)
downloadpackages-9e33de969c033fde889324a3e473c99332a8acb9.tar.gz
packages-9e33de969c033fde889324a3e473c99332a8acb9.tar.bz2
packages-9e33de969c033fde889324a3e473c99332a8acb9.tar.xz
packages-9e33de969c033fde889324a3e473c99332a8acb9.zip
user/xfce4-timer-plugin: new package
Diffstat (limited to 'user/xfce4-timer-plugin')
-rw-r--r--user/xfce4-timer-plugin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/xfce4-timer-plugin/APKBUILD b/user/xfce4-timer-plugin/APKBUILD
new file mode 100644
index 000000000..6e76d0772
--- /dev/null
+++ b/user/xfce4-timer-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-timer-plugin
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Timer plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-timer-plugin/1.7/xfce4-timer-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b4d00396f5be37d009cdb50baea8804c4b06a6f0b821d66751fd07ca21e186c01bafeec5170209b5de69559803e0ac54d9b56266f193b65ac056cdd52bf5228e xfce4-timer-plugin-1.7.0.tar.bz2"