summaryrefslogtreecommitdiff
path: root/user/xkbprint
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-01 07:22:53 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-01 07:22:53 +0000
commit8d5509832f6bb9d47c5561e284fbe9ceb59a2e46 (patch)
treeaf276eb6559a0a1a551e75f0cc66e458ef764887 /user/xkbprint
parent7d44ea422bf3c02d11e11edcddacff9db6d57404 (diff)
downloadpackages-8d5509832f6bb9d47c5561e284fbe9ceb59a2e46.tar.gz
packages-8d5509832f6bb9d47c5561e284fbe9ceb59a2e46.tar.bz2
packages-8d5509832f6bb9d47c5561e284fbe9ceb59a2e46.tar.xz
packages-8d5509832f6bb9d47c5561e284fbe9ceb59a2e46.zip
user/xkbprint: new package
Diffstat (limited to 'user/xkbprint')
-rw-r--r--user/xkbprint/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/xkbprint/APKBUILD b/user/xkbprint/APKBUILD
new file mode 100644
index 000000000..3661c7da9
--- /dev/null
+++ b/user/xkbprint/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=xkbprint
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="Tool to generate PostScript descriptions of XKB keyboard layouts"
+url="https://www.X.Org/"
+arch="all"
+license="X11"
+depends=""
+makedepends="libx11-dev libxkbfile-dev util-macros xorgproto-dev"
+subpackages="$pkgname-doc"
+source="https://www.x.org/releases/individual/app/xkbprint-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bb65a93ae737cd4b78787fef51972f4d0072a272166f82103bfaa92cf275db6363fae3530539b7c9a4139f6b87512019ac15ab3478d4ad05967ad18a8e80033a xkbprint-1.0.4.tar.bz2"