summaryrefslogtreecommitdiff
path: root/user/xmlsec
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2017-12-27 20:35:49 +0000
committerMax Rees <maxcrees@me.com>2017-12-28 09:28:08 +0000
commitab64fe5bf75c7fc9f1ef154a397e36380ada01ec (patch)
tree861d62b3d861f2099f60b7bd1109fcb3fd32e89d /user/xmlsec
parent54252e3f3ad2451193df2e01af5d2acfad1db83e (diff)
downloadpackages-ab64fe5bf75c7fc9f1ef154a397e36380ada01ec.tar.gz
packages-ab64fe5bf75c7fc9f1ef154a397e36380ada01ec.tar.bz2
packages-ab64fe5bf75c7fc9f1ef154a397e36380ada01ec.tar.xz
packages-ab64fe5bf75c7fc9f1ef154a397e36380ada01ec.zip
user/xmlsec: new package
Diffstat (limited to 'user/xmlsec')
-rw-r--r--user/xmlsec/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/user/xmlsec/APKBUILD b/user/xmlsec/APKBUILD
new file mode 100644
index 000000000..4a3b752ed
--- /dev/null
+++ b/user/xmlsec/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname="xmlsec"
+pkgver=1.2.25
+pkgrel=0
+pkgdesc="C-based XML signature and encryption syntax and processing library"
+url="https://github.com/lsh123/${pkgname}/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="${depends_dev} libxml2-dev libxslt-dev openssl-dev nss-dev
+ autoconf automake libtool"
+install=""
+options="libtool"
+subpackages="$pkgname-nss $pkgname-dev $pkgname-doc"
+source="${url}/archive/${pkgname}-${pkgver//./_}.tar.gz"
+builddir="${srcdir}/${pkgname}-${pkgname}-${pkgver//./_}"
+
+prepare() {
+ cd "${builddir}"
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ cd "${builddir}"
+ ./configure \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix='/usr' \
+ --disable-static \
+ --enable-pkgconfig \
+ --with-openssl=/usr \
+ --without-gnutls \
+ --without-gcrypt \
+ --with-default-crypto='openssl'
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make -k check
+}
+
+package() {
+ cd "${builddir}"
+ make DESTDIR="${pkgdir}" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 'COPYING' "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+nss() {
+ pkgdesc="xmlsec NSS plugin"
+ install_if="$pkgname=$pkgver-r$pkgrel nss"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/libxmlsec1-nss.so* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="3f05d76c70eecbcb38b466fc191a13ff692a39e36ab04c7d667f726b9e59e8896ce469e147f907fb044b154d0d5f00b89f6c0fc6d84a90b715efe6c80e0e123d xmlsec-1_2_25.tar.gz"