summaryrefslogtreecommitdiff
path: root/user/xscope
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-20 23:25:44 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-24 05:44:57 +0000
commit7523964b3c5d5bbd0dde73c8d5e1fcb361963ddb (patch)
treea70225eee1937d6925bfca86565a957dd1e3e7b1 /user/xscope
parent57c8540d0f6e3252245e12c2a60bc67c73f5bc72 (diff)
downloadpackages-7523964b3c5d5bbd0dde73c8d5e1fcb361963ddb.tar.gz
packages-7523964b3c5d5bbd0dde73c8d5e1fcb361963ddb.tar.bz2
packages-7523964b3c5d5bbd0dde73c8d5e1fcb361963ddb.tar.xz
packages-7523964b3c5d5bbd0dde73c8d5e1fcb361963ddb.zip
user/xscope: Update to 1.4.3
Diffstat (limited to 'user/xscope')
-rw-r--r--user/xscope/APKBUILD9
-rw-r--r--user/xscope/disable-xtrans.patch31
2 files changed, 37 insertions, 3 deletions
diff --git a/user/xscope/APKBUILD b/user/xscope/APKBUILD
index 7a51fc97c..3d0013081 100644
--- a/user/xscope/APKBUILD
+++ b/user/xscope/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=xscope
-pkgver=1.4.1
+pkgver=1.4.3
pkgrel=0
pkgdesc="Monitor communication between an X11 client and server"
url="https://www.X.Org/"
@@ -10,7 +10,9 @@ license="X11"
depends=""
makedepends="util-macros xorgproto-dev"
subpackages="$pkgname-doc"
-source="https://www.x.org/releases/individual/app/xscope-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.xz
+ disable-xtrans.patch
+ "
build() {
./configure \
@@ -31,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0b35bd51ed3118bde72359280a610f6f3f7d5e62f1673e493f13d2118ce07bfe4ae7ccc4231556d1c24f4bd7add88c46a4ea478d825fc9cf3fd723dc662d2874 xscope-1.4.1.tar.bz2"
+sha512sums="588a3668d07cc42fd44dc9cea55cd31bc67bfeddf3d07b0b0a39202304b2502dc322ff3bf5310eb689622485390fa8851ffe68b672c9b13742b9ab89d9495327 xscope-1.4.3.tar.xz
+2816a136d874af7e0b0892e601c8cf556f46d75d6c39e3411bfcbcf8ef5432c8413c14dd1e68b3be7ba27d221c73c473d0fd6d23eaded98bfb2633b665409b96 disable-xtrans.patch"
diff --git a/user/xscope/disable-xtrans.patch b/user/xscope/disable-xtrans.patch
new file mode 100644
index 000000000..ebc44ca66
--- /dev/null
+++ b/user/xscope/disable-xtrans.patch
@@ -0,0 +1,31 @@
+From 4e297db3cf54a629a2c8f38b068cd4f8434afa4c Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Wed, 13 Jul 2022 15:51:58 -0700
+Subject: [PATCH] fd.h: fix build when not building with xtrans
+
+Always include <X11/Xfuncproto.h> for the definition of _X_NORETURN,
+instead of relying on Xtrans.h to include it indirectly for us.
+
+Fixes: #2
+Fixes: commit cc298d1f559240976344588f9f765ee60ca3d6f3
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+ fd.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/fd.h b/fd.h
+index c317aa4..55c5b01 100644
+--- a/fd.h
++++ b/fd.h
+@@ -65,6 +65,7 @@
+ typedef void *XtransConnInfo;
+ #endif
+ #include <sys/select.h>
++#include <X11/Xfuncproto.h>
+
+ typedef int FD;
+
+--
+GitLab
+