summaryrefslogtreecommitdiff
path: root/user/yaml-cpp
diff options
context:
space:
mode:
authorAlyx Wolcott <alyx@malkier.net>2020-02-24 22:47:05 -0600
committerAlyx Wolcott <alyx@malkier.net>2020-02-24 22:47:05 -0600
commitb2afa3d3e2afa81810509893149032c2912f23ee (patch)
tree30d9069e4db4f2ac08d5a56c09c5aec12156b5f5 /user/yaml-cpp
parentd14e248d2b12a7b2299e9103d2d1fd06ad925469 (diff)
downloadpackages-b2afa3d3e2afa81810509893149032c2912f23ee.tar.gz
packages-b2afa3d3e2afa81810509893149032c2912f23ee.tar.bz2
packages-b2afa3d3e2afa81810509893149032c2912f23ee.tar.xz
packages-b2afa3d3e2afa81810509893149032c2912f23ee.zip
user/libmaxminddb, user/lua-yaml, user/yaml-cpp: Do the needful
Diffstat (limited to 'user/yaml-cpp')
-rw-r--r--user/yaml-cpp/APKBUILD10
1 files changed, 1 insertions, 9 deletions
diff --git a/user/yaml-cpp/APKBUILD b/user/yaml-cpp/APKBUILD
index 4f7e7bfa9..53f41b87b 100644
--- a/user/yaml-cpp/APKBUILD
+++ b/user/yaml-cpp/APKBUILD
@@ -13,7 +13,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/jbeder/yaml-cpp/archive/yaml
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -30,17 +29,10 @@ build() {
}
check() {
- cd "$builddir"
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-check() {
- cd "$builddir"
- make test
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}