summaryrefslogtreecommitdiff
path: root/user/yelp-xsl/APKBUILD
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2021-07-27 23:41:01 +0000
committerZach van Rijn <me@zv.io>2021-07-27 23:41:01 +0000
commitdbf2ee8a4c30d9326a182f421fbc2e5b58f9fc6d (patch)
treef0b5cb765c7f5a5ad19dd7db8303e1816ba9ebdf /user/yelp-xsl/APKBUILD
parentcb89ebf6d88ee2ce9c87fbfc27d75fa65b3baa48 (diff)
parenteff1c3c87532b591492fec9e3952425e199547a9 (diff)
downloadpackages-dbf2ee8a4c30d9326a182f421fbc2e5b58f9fc6d.tar.gz
packages-dbf2ee8a4c30d9326a182f421fbc2e5b58f9fc6d.tar.bz2
packages-dbf2ee8a4c30d9326a182f421fbc2e5b58f9fc6d.tar.xz
packages-dbf2ee8a4c30d9326a182f421fbc2e5b58f9fc6d.zip
Merge branch 'aerdan/20210721' into 'master'
Bump packages owned by Síle See merge request adelie/packages!619
Diffstat (limited to 'user/yelp-xsl/APKBUILD')
-rw-r--r--user/yelp-xsl/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/yelp-xsl/APKBUILD b/user/yelp-xsl/APKBUILD
new file mode 100644
index 000000000..65c20e517
--- /dev/null
+++ b/user/yelp-xsl/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Sheila Aman <sheila@vulpine.house>
+# Maintainer: Sheila Aman <sheila@vulpine.house>
+pkgname=yelp-xsl
+pkgver=40.2
+pkgrel=0
+pkgdesc="XSL stylesheets for Yelp documentation"
+url="http://live.gnome.org/Yelp"
+arch="noarch"
+license="GPL-2.0+"
+depends=""
+makedepends="itstool"
+source="https://download-fallback.gnome.org/sources/yelp-xsl/40/yelp-xsl-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d365d6d873878a640244053efa9f2b9f7330a8bbca1c47073f0617c1f9150f58e91b48ac7d28e5b65fd113d612afd65b5f9c3d16a6958a957130f85d2f866483 yelp-xsl-40.2.tar.xz"