summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-04-18 05:09:49 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-04-18 05:09:49 +0000
commitc800e3f92a52af93e323151b4ae454b073058851 (patch)
tree5b4f58e8923818b493f88ca59cdf931209d57fff /user
parentccaca87e437505faefd94112c2e881621fedd19f (diff)
parent8c21b8ee3b41239d365d94ea8d01429f7518f47d (diff)
downloadpackages-c800e3f92a52af93e323151b4ae454b073058851.tar.gz
packages-c800e3f92a52af93e323151b4ae454b073058851.tar.bz2
packages-c800e3f92a52af93e323151b4ae454b073058851.tar.xz
packages-c800e3f92a52af93e323151b4ae454b073058851.zip
Merge branch 'bump.aerdan.20190416' into 'master'
Package bumps for 16 April 2019. See merge request !216
Diffstat (limited to 'user')
-rw-r--r--user/at-spi2-core/APKBUILD9
-rw-r--r--user/at-spi2-core/stupid-meson-fix.patch11
-rw-r--r--user/glib-networking/APKBUILD10
-rw-r--r--user/glib-networking/glib-networking-2.60-new-gnutls-cert-error-fix.patch31
-rw-r--r--user/gobject-introspection/APKBUILD4
-rw-r--r--user/gtk+3.0/APKBUILD4
-rw-r--r--user/gvim/APKBUILD4
-rw-r--r--user/imagemagick/APKBUILD4
-rw-r--r--user/libcroco/APKBUILD10
-rw-r--r--user/libcroco/CVE-2017-7960.patch58
-rw-r--r--user/libsoup/APKBUILD4
-rw-r--r--user/mate-icon-theme/APKBUILD4
-rw-r--r--user/opus/APKBUILD4
-rw-r--r--user/perl-extutils-depends/APKBUILD4
-rw-r--r--user/perl-file-find-object-rule/APKBUILD4
-rw-r--r--user/perl-games-solitaire-verify/APKBUILD6
-rw-r--r--user/perl-http-headers-fast/APKBUILD4
-rw-r--r--user/perl-test-perltidy/APKBUILD7
-rw-r--r--user/perl-yaml-libyaml/APKBUILD4
-rw-r--r--user/py3-pexpect/APKBUILD7
-rw-r--r--user/ristretto/APKBUILD4
-rw-r--r--user/vala/APKBUILD4
-rw-r--r--user/vte/APKBUILD4
23 files changed, 83 insertions, 122 deletions
diff --git a/user/at-spi2-core/APKBUILD b/user/at-spi2-core/APKBUILD
index 38feb8b0a..edd3dd5f3 100644
--- a/user/at-spi2-core/APKBUILD
+++ b/user/at-spi2-core/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=at-spi2-core
-pkgver=2.32.0
+pkgver=2.32.1
pkgrel=0
pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
url="https://wiki.linuxfoundation.org/accessibility/d-bus"
@@ -13,9 +13,7 @@ depends_dev="libxtst-dev"
makedepends="$depends_dev dbus-dev glib-dev intltool gobject-introspection-dev
dbus meson ninja"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/at-spi2-core/${pkgver%.*}/at-spi2-core-$pkgver.tar.xz
- stupid-meson-fix.patch
- "
+source="https://download.gnome.org/sources/at-spi2-core/${pkgver%.*}/at-spi2-core-$pkgver.tar.xz"
build() {
cd "$builddir"
@@ -33,5 +31,4 @@ package() {
DESTDIR="$pkgdir" ninja -C builddir/ install
}
-sha512sums="4c77b4e0d37b559d20e6521107e8f7e03e91392414dc7ffdceb558667f3a7a6137af6895f3a8cd97dc3e85715d7875812d658dcc84277a63a10276992bde2fa6 at-spi2-core-2.32.0.tar.xz
-628b40c26d50d35ac898eab547c7c66d481e9ab239e0de4e98f5a8d90ef189960ac8c20312c88e8036c40ef1a1bb90559d5e621157b46f75d185d6b1be550877 stupid-meson-fix.patch"
+sha512sums="cec6ea1426b25d9738c5c401a1038b39e04b1e989b7ef8e02590d117b35cfb253b260cc6e41b09e10e007801fedcb7702c48ba7f3a0c7b6c1f16edd4e8ad0cca at-spi2-core-2.32.1.tar.xz"
diff --git a/user/at-spi2-core/stupid-meson-fix.patch b/user/at-spi2-core/stupid-meson-fix.patch
deleted file mode 100644
index 461871706..000000000
--- a/user/at-spi2-core/stupid-meson-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- at-spi2-core-2.32.0/atspi/meson.build.old 2019-03-12 02:54:43.000000000 +0000
-+++ at-spi2-core-2.32.0/atspi/meson.build 2019-03-23 22:15:47.910000000 +0000
-@@ -57,7 +57,7 @@
-
- atspi_includedir = join_paths(get_option('prefix'), get_option('includedir'), 'at-spi-2.0', 'atspi')
-
--install_headers(atspi_headers, subdir: atspi_includedir)
-+install_headers(atspi_headers, install_dir: atspi_includedir)
-
- atspi_enums = gnome.mkenums('atspi-enum-types',
- sources: [ 'atspi-constants.h', 'atspi-types.h' ],
diff --git a/user/glib-networking/APKBUILD b/user/glib-networking/APKBUILD
index 40c86ad5c..83ee6af4a 100644
--- a/user/glib-networking/APKBUILD
+++ b/user/glib-networking/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer:
pkgname=glib-networking
-pkgver=2.60.0.1
-_ver=2.60
+pkgver=2.60.1
+_ver=${pkgver%.*}
pkgrel=0
pkgdesc="Networking support for GLib"
url="https://www.gnome.org/"
@@ -12,7 +12,8 @@ depends="ca-certificates"
makedepends="bash glib-dev gnutls-dev gsettings-desktop-schemas-dev intltool
libgcrypt-dev libproxy-dev meson ninja p11-kit-dev"
subpackages="$pkgname-lang"
-source="https://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz
+ glib-networking-2.60-new-gnutls-cert-error-fix.patch"
prepare() {
cd "$builddir"
@@ -37,4 +38,5 @@ package() {
rm -f "$pkgdir"/usr/lib/gio/modules/*.a
}
-sha512sums="98a34a14cdbbcb4a9496bce807e7720dd9e103adbacd5dc44439d5fcaf02eef12c0385df95767d7603587331b84c7ad4a677f47b00583a46f15a022572a3690f glib-networking-2.60.0.1.tar.xz"
+sha512sums="a40a7e9678076db1a469f0d8ffdcb0c6658ef96ff1d9637299fbb07985f4c42bae3f1415f8df15242718420d20eb90de93253a00d1f6a347110b3f8a74bcc717 glib-networking-2.60.1.tar.xz
+b9d3d744aec5337553e228ff1ee0616b1d79d1766ef9d87e644706a154f8e6151b15651b73a7073482e5cbe20b54ac78bd34f7ad77ebf0d34c42d969b4315241 glib-networking-2.60-new-gnutls-cert-error-fix.patch"
diff --git a/user/glib-networking/glib-networking-2.60-new-gnutls-cert-error-fix.patch b/user/glib-networking/glib-networking-2.60-new-gnutls-cert-error-fix.patch
new file mode 100644
index 000000000..ab04dae3e
--- /dev/null
+++ b/user/glib-networking/glib-networking-2.60-new-gnutls-cert-error-fix.patch
@@ -0,0 +1,31 @@
+From 1ce6b40da8ecbf997c5522a592a122e805aa81c4 Mon Sep 17 00:00:00 2001
+From: Michael Catanzaro <mcatanzaro@igalia.com>
+Date: Wed, 3 Apr 2019 18:00:55 -0500
+Subject: [PATCH] gnutls: Handle new GNUTLS_E_CERTIFICATE_REQUIRED
+
+This new error in GnuTLS 3.6.7 should correspond to
+G_TLS_ERROR_CERTIFICATE_REQUIRED. This fixes our client auth tests when
+run with GnuTLS 3.6.7.
+
+Fixes #70
+---
+ tls/gnutls/gtlsconnection-gnutls.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tls/gnutls/gtlsconnection-gnutls.c b/tls/gnutls/gtlsconnection-gnutls.c
+index 27bbbcd..774d668 100644
+--- a/tls/gnutls/gtlsconnection-gnutls.c
++++ b/tls/gnutls/gtlsconnection-gnutls.c
+@@ -1062,7 +1062,11 @@ end_gnutls_io (GTlsConnectionGnutls *gnutls,
+ else
+ return 0;
+ }
+- else if (status == GNUTLS_E_NO_CERTIFICATE_FOUND)
++ else if (status == GNUTLS_E_NO_CERTIFICATE_FOUND
++#ifdef GNUTLS_E_CERTIFICATE_REQUIRED
++ || status == GNUTLS_E_CERTIFICATE_REQUIRED /* Added in GnuTLS 3.6.7 */
++#endif
++ )
+ {
+ g_set_error_literal (error, G_TLS_ERROR, G_TLS_ERROR_CERTIFICATE_REQUIRED,
+ _("TLS connection peer did not send a certificate"));
diff --git a/user/gobject-introspection/APKBUILD b/user/gobject-introspection/APKBUILD
index 1e97e0eb5..841a87d05 100644
--- a/user/gobject-introspection/APKBUILD
+++ b/user/gobject-introspection/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=gobject-introspection
-pkgver=1.60.0
+pkgver=1.60.1
pkgrel=0
pkgdesc="Introspection system for GObject-based libraries"
url="https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
@@ -46,4 +46,4 @@ dev() {
replaces="gobject-introspection"
}
-sha512sums="858cf12b1a606be4ec884444ef0c9f05aaaf75d4f547dde489c4eef35d125a66d3d1b7c3cd879bae0f01bc0fb75dd3473a1e1bc9f66241f32ac27b0a35a06901 gobject-introspection-1.60.0.tar.xz"
+sha512sums="01adbeffee08ff6487f11a303fd7a59a99c36714dce21be9bbae7fd2bf8f080665e830bc3a47566140a6081dc74f6c2f8d8232286759b761f70493545a9d90ea gobject-introspection-1.60.1.tar.xz"
diff --git a/user/gtk+3.0/APKBUILD b/user/gtk+3.0/APKBUILD
index 0504053e6..57cbe384b 100644
--- a/user/gtk+3.0/APKBUILD
+++ b/user/gtk+3.0/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:
pkgname=gtk+3.0
-pkgver=3.24.7
+pkgver=3.24.8
pkgrel=0
pkgdesc="The GTK+ Toolkit (v3)"
url="https://www.gtk.org/"
@@ -53,4 +53,4 @@ package() {
rm -f "$pkgdir"/usr/share/man/man1/gtk-update-icon-cache.1
}
-sha512sums="2605087c3e09c81192769e6c4bcc4374e0fadbc4d05433edeaefd9915e128ff925c64fb3d07799bacccb16d85d31e53936ac09c696a09349efa6e21d886074c5 gtk+-3.24.7.tar.xz"
+sha512sums="a988ca2e25f0f32e55b2931f16c72f9649ed98405579d217e8a5e7f0ac10bcd1969090c622c5d9eb7d75235813ff7ccb90e30e252afd71ba283c6172ee459fe5 gtk+-3.24.8.tar.xz"
diff --git a/user/gvim/APKBUILD b/user/gvim/APKBUILD
index a31e6eee5..fdb3bb987 100644
--- a/user/gvim/APKBUILD
+++ b/user/gvim/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=gvim
_pkgreal=vim
-pkgver=8.1.1073
+pkgver=8.1.1177
pkgrel=0
pkgdesc="advanced text editor"
url="http://www.vim.org"
@@ -74,4 +74,4 @@ package() {
ln -s gvim rgvim
}
-sha512sums="74d13063853677aaff795925414baa293819ccd20e3deb7013c134b42434e8abd14db1645116b20081f80bcb3dfd9a1e0c6b210ed9af62a4cf19c183025c9779 vim-8.1.1073.tar.gz"
+sha512sums="b90d3f6b6727ea97a1e41154855c45f80a2e94a8e3cf1b912ec6812494c2658d66ba4bc796f5a9e7713544ecdd2f813512e4497293d0e362ae9281695dcee52f vim-8.1.1177.tar.gz"
diff --git a/user/imagemagick/APKBUILD b/user/imagemagick/APKBUILD
index 864337eb2..00f6b907d 100644
--- a/user/imagemagick/APKBUILD
+++ b/user/imagemagick/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=imagemagick
-pkgver=7.0.8.39
+pkgver=7.0.8.40
_abiver=7
_pkgver=${pkgver%.*}-${pkgver##*.}
pkgrel=0
@@ -81,4 +81,4 @@ _cxx() {
mv "$pkgdir"/usr/lib/libMagick++*.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="545c0e919f58e5d29b0a92b1db8dc32eb8f4aa828c6e8bc8f9bec5ada3468b79c8fbbb57350772f1a87a46f29bbd94af33272f7f8bb0ab720837844d15d7a43b ImageMagick-7.0.8-39.tar.xz"
+sha512sums="09defd7bedfc18ff5ef8e404e2f1189cbcd97f087b05fc925cfd6e90b416e97aea691542a1eca6841b99c24dbeaf10d2437a74d8d380dfc5f70a1eb54ae61982 ImageMagick-7.0.8-40.tar.xz"
diff --git a/user/libcroco/APKBUILD b/user/libcroco/APKBUILD
index 5365445f7..0ed8d4685 100644
--- a/user/libcroco/APKBUILD
+++ b/user/libcroco/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer:
pkgname=libcroco
-pkgver=0.6.12
-pkgrel=2
+pkgver=0.6.13
+pkgrel=0
pkgdesc="GNOME CSS 2 parsing and manipulation toolkit"
url="https://gitlab.gnome.org/GNOME/libcroco"
arch="all"
@@ -11,8 +11,7 @@ subpackages="$pkgname-dev"
depends=
makedepends="glib-dev libxml2-dev"
checkdepends="cmd:which"
-source="https://download.gnome.org/sources/$pkgname/0.6/$pkgname-$pkgver.tar.xz
- CVE-2017-7960.patch"
+source="https://download.gnome.org/sources/$pkgname/0.6/$pkgname-$pkgver.tar.xz"
# secfixes:
# 0.6.12-r2:
@@ -38,5 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="af9a171d5ccded255b57f170576e67155f12fa0f61ab3e379e907975f77afc37e82e22772c6019b2897cffc15b2425faf3ccfda92b1a45b23eda2519debabeb6 libcroco-0.6.12.tar.xz
-da26b95808d7f06c15afed306fac2a80012413bf96ad2cd249c7420a6f41a02d76abeb80b94705f24414f1986084aa4d864fd82038274f664fa91b31fbcabd30 CVE-2017-7960.patch"
+sha512sums="038a3ac9d160a8cf86a8a88c34367e154ef26ede289c93349332b7bc449a5199b51ea3611cebf3a2416ae23b9e45ecf8f9c6b24ea6d16a5519b796d3c7e272d4 libcroco-0.6.13.tar.xz"
diff --git a/user/libcroco/CVE-2017-7960.patch b/user/libcroco/CVE-2017-7960.patch
deleted file mode 100644
index 4561392c0..000000000
--- a/user/libcroco/CVE-2017-7960.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 898e3a8c8c0314d2e6b106809a8e3e93cf9d4394 Mon Sep 17 00:00:00 2001
-From: Ignacio Casal Quinteiro <qignacio@amazon.com>
-Date: Sun, 16 Apr 2017 13:13:43 +0200
-Subject: [PATCH] input: check end of input before reading a byte
-
-When reading bytes we weren't check that the index wasn't
-out of bound and this could produce an invalid read which
-could deal to a security bug.
----
- src/cr-input.c | 11 +++++++++--
- 1 file changed, 9 insertions(+), 2 deletions(-)
-
-diff --git a/src/cr-input.c b/src/cr-input.c
-index 49000b1..3b63a88 100644
---- a/src/cr-input.c
-+++ b/src/cr-input.c
-@@ -256,7 +256,7 @@ cr_input_new_from_uri (const gchar * a_file_uri, enum CREncoding a_enc)
- *we should free buf here because it's own by CRInput.
- *(see the last parameter of cr_input_new_from_buf().
- */
-- buf = NULL ;
-+ buf = NULL;
- }
-
- cleanup:
-@@ -404,6 +404,8 @@ cr_input_get_nb_bytes_left (CRInput const * a_this)
- enum CRStatus
- cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- {
-+ gulong nb_bytes_left = 0;
-+
- g_return_val_if_fail (a_this && PRIVATE (a_this)
- && a_byte, CR_BAD_PARAM_ERROR);
-
-@@ -413,6 +415,12 @@ cr_input_read_byte (CRInput * a_this, guchar * a_byte)
- if (PRIVATE (a_this)->end_of_input == TRUE)
- return CR_END_OF_INPUT_ERROR;
-
-+ nb_bytes_left = cr_input_get_nb_bytes_left (a_this);
-+
-+ if (nb_bytes_left < 1) {
-+ return CR_END_OF_INPUT_ERROR;
-+ }
-+
- *a_byte = PRIVATE (a_this)->in_buf[PRIVATE (a_this)->next_byte_index];
-
- if (PRIVATE (a_this)->nb_bytes -
-@@ -477,7 +485,6 @@ cr_input_read_char (CRInput * a_this, guint32 * a_char)
- if (*a_char == '\n') {
- PRIVATE (a_this)->end_of_line = TRUE;
- }
--
- }
-
- return status;
---
-2.17.1
-
diff --git a/user/libsoup/APKBUILD b/user/libsoup/APKBUILD
index 27dde65ad..ddcf75515 100644
--- a/user/libsoup/APKBUILD
+++ b/user/libsoup/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libsoup
-pkgver=2.66.0
+pkgver=2.66.1
pkgrel=0
pkgdesc="GObject-based HTTP library"
url="https://wiki.gnome.org/Projects/libsoup"
@@ -29,4 +29,4 @@ package() {
DESTDIR="$pkgdir" ninja install
}
-sha512sums="a79d4dafbf12a3345803b38859a398839e3e9e389552c90bab60b005ffa7e4ce2f43112e322ca10f134ab6e6c53568e058c82c370617e872539e1fafd82a1352 libsoup-2.66.0.tar.xz"
+sha512sums="bb9c15cae965606d5f7c009fab9223445235982269d23ff20e89249b10d3423797427e7cff39c31a3f5db99b0c2d7a01eb911edb61309603cdeb8f2467fe6039 libsoup-2.66.1.tar.xz"
diff --git a/user/mate-icon-theme/APKBUILD b/user/mate-icon-theme/APKBUILD
index aad16388d..f06e39926 100644
--- a/user/mate-icon-theme/APKBUILD
+++ b/user/mate-icon-theme/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=mate-icon-theme
-pkgver=1.22.0
+pkgver=1.22.1
pkgrel=0
pkgdesc="Default icon theme for the MATE desktop environment"
url="https://mate-desktop.org"
@@ -35,4 +35,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b4f0b5040e412bcbe818c14f101556cd643cc9dfce02aa676edc790f17de7da2272754235f8d9ad000551e7d92a5974cec3336712074747fcf669c0a729f8a5e mate-icon-theme-1.22.0.tar.xz"
+sha512sums="640fea3dfd4d9f2edd24353e4a36d57520de356c421b24ee1aec7fca98d3f76a789808a1d005a20ed87ee089d1777376e5b3f229ce0e90b06adf242f6a79b3b9 mate-icon-theme-1.22.1.tar.xz"
diff --git a/user/opus/APKBUILD b/user/opus/APKBUILD
index 7b76e2a0a..2b2a2d887 100644
--- a/user/opus/APKBUILD
+++ b/user/opus/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=opus
-pkgver=1.3
+pkgver=1.3.1
pkgrel=0
pkgdesc="Codec designed for speech and audio transmission"
url="http://www.opus-codec.org/"
@@ -39,4 +39,4 @@ package() {
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha512sums="438635667e72c326d6d06a30e0b3a5564ba6cf5d484066456e1118e1c2fe3a61b959d0afa77a1084b177b72f9230618b6b55c78bc4e24e9127a09fd345b42518 opus-1.3.tar.gz"
+sha512sums="6cd5e4d8a0551ed5fb59488c07a5cc18a241d1fde5f9eb9f16cd4e77abcdb4134dd51ad1d737be1e6039bfa56912510b8648152f2478a1f21c7c1d9ce32933cd opus-1.3.1.tar.gz"
diff --git a/user/perl-extutils-depends/APKBUILD b/user/perl-extutils-depends/APKBUILD
index 2d62635f2..84a2a30be 100644
--- a/user/perl-extutils-depends/APKBUILD
+++ b/user/perl-extutils-depends/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-extutils-depends
-pkgver=0.405
+pkgver=0.8000
pkgrel=0
pkgdesc="Easily build XS extensions that depend on XS extensions"
url="https://metacpan.org/release/ExtUtils-Depends"
@@ -31,4 +31,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="b9983ad763ff0cb81c899bc24f3152f13c69e608304b6e4446bd07b9b13d039650f3f87544c0bdd29c67246ea2973f04a1ce0fccbffb566fe89fdbe0bb03f11b ExtUtils-Depends-0.405.tar.gz"
+sha512sums="c2823e48fc6ae42677da958d8cbeb561a29839cc387224ecd545e1d81979cd963377210f9c5a9bf314e2fc6e0907190f0b867ed59e91f8eab6df91f8d0c91e5d ExtUtils-Depends-0.8000.tar.gz"
diff --git a/user/perl-file-find-object-rule/APKBUILD b/user/perl-file-find-object-rule/APKBUILD
index f8938a59c..498f0358e 100644
--- a/user/perl-file-find-object-rule/APKBUILD
+++ b/user/perl-file-find-object-rule/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-file-find-object-rule
-pkgver=0.0309
+pkgver=0.0310
pkgrel=0
pkgdesc="Alternative Perl interface to File::Find::Object"
url="https://metacpan.org/release/File-Find-Object-Rule"
@@ -31,4 +31,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="d4fe0bc369faa4870bb4f66b4e1212f0597ab0eb723dfb0ab6473428657067c0a72f9b9d6354a549117e553be1ddde222ede822555f94846ba110a2f82cc4b68 File-Find-Object-Rule-0.0309.tar.gz"
+sha512sums="d77f600a43a45fddf84fd9689666fb90d3dc87fb444e575a111bcebec482d570201e591764513f345941983935f1761bf4e2704d1a70babd6b3ba12ba3d8a74d File-Find-Object-Rule-0.0310.tar.gz"
diff --git a/user/perl-games-solitaire-verify/APKBUILD b/user/perl-games-solitaire-verify/APKBUILD
index 8854921a3..627484d38 100644
--- a/user/perl-games-solitaire-verify/APKBUILD
+++ b/user/perl-games-solitaire-verify/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-games-solitaire-verify
-pkgver=0.1900
+pkgver=0.2000
pkgrel=0
pkgdesc="Verify solutions to solitaire games"
url="https://metacpan.org/release/Games-Solitaire-Verify"
@@ -9,7 +9,7 @@ arch="noarch"
license="MIT"
depends="perl-class-xsaccessor perl-exception-class perl-list-moreutils"
makedepends="perl-dev perl-module-build"
-checkdepends="perl-test-differences"
+checkdepends="perl-test-differences perl-path-tiny"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Games-Solitaire-Verify-$pkgver.tar.gz"
builddir="$srcdir/Games-Solitaire-Verify-$pkgver"
@@ -32,4 +32,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="d161bc395f85f2aa404fe7aac893c840b302c7659e529b62bda9ad6c274508c4294c03c9037b9ab6a667e8a90292ef83445c88be26e42dde89625224f85027f0 Games-Solitaire-Verify-0.1900.tar.gz"
+sha512sums="4abc5cd68bc57f96115a2f273aa16076b2f2ff50a597a8e1f4bf5b6f6dcb26771346d7cff3cadfc10eb1f8584c79141b06ecd6b07b6b19610405dc80977d9382 Games-Solitaire-Verify-0.2000.tar.gz"
diff --git a/user/perl-http-headers-fast/APKBUILD b/user/perl-http-headers-fast/APKBUILD
index b7496496b..ec547543e 100644
--- a/user/perl-http-headers-fast/APKBUILD
+++ b/user/perl-http-headers-fast/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-http-headers-fast
_pkgname=HTTP-Headers-Fast
-pkgver=0.21
+pkgver=0.22
pkgrel=0
pkgdesc="Fast HTTP header parsing for Perl"
url="https://metacpan.org/release/HTTP-Headers-Fast"
@@ -32,4 +32,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="ce04b70f0748ee2d5911c772149b71c8c130d172267c11716151c1ca21b26e8c793af22227098d73a9253c9bfae57d618b6d67454c41862e2ba3a9798c067cf6 HTTP-Headers-Fast-0.21.tar.gz"
+sha512sums="60435c11b5846c1a6256227c7edb00fd444c76346797424f186f971c5bebec93b1c84be805e0a4589c92b8c571d0c3e0332436b21ad099677a31544305d819b2 HTTP-Headers-Fast-0.22.tar.gz"
diff --git a/user/perl-test-perltidy/APKBUILD b/user/perl-test-perltidy/APKBUILD
index 392257c83..428c833cf 100644
--- a/user/perl-test-perltidy/APKBUILD
+++ b/user/perl-test-perltidy/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-perltidy
-pkgver=20130104
+pkgver=20190402
pkgrel=0
pkgdesc="Check all your Perl files for tidiness"
url="https://metacpan.org/release/Test-PerlTidy"
arch="noarch"
license="Artistic-1.0-Perl"
depends="perl-file-finder perl-file-slurp perl-perl-tidy perl-text-diff"
+checkdepends="perl-path-tiny"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/L/LA/LARRYL/Test-PerlTidy-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Test-PerlTidy-$pkgver.tar.gz"
builddir="$srcdir/Test-PerlTidy-$pkgver"
build() {
@@ -30,4 +31,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="47d77083ec6f4808ac60bdb19431b3013b996f83506b0af490a6fa52f4f71a8c1812cf21b447568661495c845d524f9c2be6842380bd41c9ccfe22ec6acd802f Test-PerlTidy-20130104.tar.gz"
+sha512sums="0fcdb45fff1f6d29ccd4a88b88e6c81a3e12d32ec618b33cb5751582c5c0580a628f7cddbc7c657e17c6626ac6a4d7c3b259d4d1bede8617a48adadb8985cd1a Test-PerlTidy-20190402.tar.gz"
diff --git a/user/perl-yaml-libyaml/APKBUILD b/user/perl-yaml-libyaml/APKBUILD
index 42578f61e..87a8c5a80 100644
--- a/user/perl-yaml-libyaml/APKBUILD
+++ b/user/perl-yaml-libyaml/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-yaml-libyaml
-pkgver=0.76
+pkgver=0.77
pkgrel=0
pkgdesc="Perl YAML Serialization using XS and libyaml"
url="https://metacpan.org/pod/YAML::LibYAML"
@@ -33,4 +33,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="1a5058cc957bc891aaf1468bd03b7a169372f2711ce027ec701126f8c3d2c15d2029946ca2db77438cf8d43a3a1964238c50fc1a3da20addb3a525733b4499c8 YAML-LibYAML-0.76.tar.gz"
+sha512sums="20d35718ebd318c2e7cfd618274dafb9c4489596e6ee77ca957f58d4971b7c712cbbf71517c9b29f316d0059b1b9f375aab57facc895c61c200cc0e40589de33 YAML-LibYAML-0.77.tar.gz"
diff --git a/user/py3-pexpect/APKBUILD b/user/py3-pexpect/APKBUILD
index 10978ca79..2394872d5 100644
--- a/user/py3-pexpect/APKBUILD
+++ b/user/py3-pexpect/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=py3-pexpect
-pkgver=4.6.0
+_pkgname=${pkgname#*-}
+pkgver=4.7.0
pkgrel=0
pkgdesc="Python library for managing console applications"
url="https://pexpect.readthedocs.io/"
@@ -9,8 +10,7 @@ arch="noarch"
license="ISC"
depends="python3 py3-ptyprocess"
makedepends=""
-source="https://files.pythonhosted.org/packages/89/43/07d07654ee3e25235d8cea4164cdee0ec39d1fda8e9203156ebe403ffda4/pexpect-$pkgver.tar.gz"
-sha512sums="9a2b1ef19d885e69cfd17ba0519581f782574019010043e66d8b68f98ac86b359f4a1ca42f8bb0059a5dfdd43275ad93531c076cc0ac2049e109408961b46bbd pexpect-4.6.0.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/pexpect-$pkgver"
build() {
@@ -28,3 +28,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
+sha512sums="4cea4229332c1f3de26dfcad596877665b3c02e91d51ca3c45c1f9b44462adb7c82abc7b76eb09a73822c2d1ccc9d812574cf79bf6bc8fb0b7d2f1093962cc3f pexpect-4.7.0.tar.gz"
diff --git a/user/ristretto/APKBUILD b/user/ristretto/APKBUILD
index 9fded5c45..1970f15af 100644
--- a/user/ristretto/APKBUILD
+++ b/user/ristretto/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=ristretto
-pkgver=0.8.3
+pkgver=0.8.4
pkgrel=0
pkgdesc="Image viewer for the XFCE desktop environment"
url="https://xfce.org"
@@ -35,4 +35,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c43b48dfdf9e8ed0ea3c5f2bbac1c837881aa6a467c78377b6f53dcce030b5a3b8134a7b8cbad1008ae758295953fde50a916c284e54e8c5490158e776554514 ristretto-0.8.3.tar.bz2"
+sha512sums="c5479cde66e4f0903b9b8d9b1b8f4c7cde35ebfa334e414c8202e783c332bd4bfec650f85d308c7151d31fe84b27a13bb4048290b0a82ce7b8ba4baf3e4088b8 ristretto-0.8.4.tar.bz2"
diff --git a/user/vala/APKBUILD b/user/vala/APKBUILD
index 649aecea1..3e6b0d5b0 100644
--- a/user/vala/APKBUILD
+++ b/user/vala/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vala
-pkgver=0.44.2
+pkgver=0.44.3
pkgrel=0
pkgdesc="Compiler for the Vala programming language"
url="https://wiki.gnome.org/Projects/Vala"
@@ -30,4 +30,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c7151efce9c4da4b31eadd646105ce8fb244ddd285f6d086ab65c044c0725ac7b33752316a8dba6f5709998a48eac77510815cba2609742947b41a2e6268515d vala-0.44.2.tar.xz"
+sha512sums="f074d537db94772565003a097c6a29e0dfcd58680baeb321ad04dec8ea056319eb8b7059117c259523b7570841651c2935feef06c03e3d82a11a94a293349b5a vala-0.44.3.tar.xz"
diff --git a/user/vte/APKBUILD b/user/vte/APKBUILD
index b952f4959..adcc489d5 100644
--- a/user/vte/APKBUILD
+++ b/user/vte/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=vte
-pkgver=0.56.0
+pkgver=0.56.1
pkgrel=0
pkgdesc="Virtual terminal emulator library for Gnome"
url="https://www.gnome.org"
@@ -33,5 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f366ed4a28a896ba919184b50a55ee110eae43127847f34c049684bcb9b81327d1b72e9d871b2a5b7f7fa12f3f4aa721ac3d770770b600dca9c433cb2c674915 vte-0.56.0.tar.xz
+sha512sums="74a6404d4e8f13e8b006c59e8cd63e660407ef217c1f80bfd7d0b72c395411558929760c1d98eea9ecb9010df725506c31c953b23e541c03f4a8a93e78066436 vte-0.56.1.tar.xz
4987254439a136f66a7b7be1300f5efbf85db74bdb64fdd8d0c9a555173a172b4fd519174f932e73d58a2618ef37273e82fe681bb129891f2792a414025f6c61 exitcode.patch"