summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-07-29 14:18:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2017-07-29 14:18:59 +0000
commit05daed829b64f4f9626414af68e0a1c918ec6fa0 (patch)
tree822c3e7f64b9d6680bca231794cf4b025dc7795f /user
parentd96953ed082f9eb0031b089817564c7729504156 (diff)
downloadpackages-05daed829b64f4f9626414af68e0a1c918ec6fa0.tar.gz
packages-05daed829b64f4f9626414af68e0a1c918ec6fa0.tar.bz2
packages-05daed829b64f4f9626414af68e0a1c918ec6fa0.tar.xz
packages-05daed829b64f4f9626414af68e0a1c918ec6fa0.zip
user/man-db: new package
Diffstat (limited to 'user')
-rw-r--r--user/man-db/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/man-db/APKBUILD b/user/man-db/APKBUILD
new file mode 100644
index 000000000..192088aaf
--- /dev/null
+++ b/user/man-db/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=man-db
+pkgver=2.7.6.1
+pkgrel=0
+pkgdesc="The man command and related utilities for examining on-line help files"
+url="http://www.nongnu.org/man-db/"
+arch="all"
+license="GPL-2+"
+depends="groff less"
+makedepends="db-dev gettext-dev libpipeline-dev zlib-dev"
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://download.savannah.nongnu.org/releases/man-db/man-db-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-setuid \
+ --with-sections="1 1p 1x 2 2x 3 3p 3x 4 4x 5 5x 6 6x 7 7x 8 8x 9 0p tcl n l p o" \
+ --enable-nls \
+ --with-db=db
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm "${pkgdir}"/usr/lib/charset.alias
+ rm -r "${pkgdir}"/usr/lib/tmpfiles.d # systemd
+}
+
+sha512sums="623c5e7f8b7c289908b2c926f8777293b8d39aeceef0d2509d701a8b0bfa81408650f655c8608318221786c751a79ee91124b07993de5298cd7fa6d8bb737301 man-db-2.7.6.1.tar.xz"