summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-03-18 18:54:42 +0000
commit32c38901a3117b823697bdcd7adafec4607912d6 (patch)
tree23f9d3ffcaf5505c086cd4f0ca026f58b08fec38 /user
parent40254b068b9389c30608184e33ffce42ee3fc74c (diff)
parent86bc7fce4c621370283feab618a2911c365d5deb (diff)
downloadpackages-32c38901a3117b823697bdcd7adafec4607912d6.tar.gz
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.bz2
packages-32c38901a3117b823697bdcd7adafec4607912d6.tar.xz
packages-32c38901a3117b823697bdcd7adafec4607912d6.zip
Merge branch 'zlg.2019-03' into 'master'
zlg's package bumps for March 2019 This is a routine package upgrade. There is one thing to note, however: * `py3-pyyaml` has a minor issue building due to a missing `ext/_yaml.c` file. It appears that a tool is used to generate the `.c` file it needs to compile the module. It falls back to pure-Python mode and passes all tests, however. I hand-tested `py3-pyyaml` by using vgstash to export a game collection to yaml (everything worked fine) and received a test cert from `certbot` to confirm the bumps didn't break anything affected on my system, since they're the two largest consumers of what was bumped. This should be the last version bump from me until post-1.0-BETA3, barring security bumps. See merge request !202
Diffstat (limited to 'user')
-rw-r--r--user/certbot/APKBUILD4
-rw-r--r--user/py3-certifi/APKBUILD6
-rw-r--r--user/py3-certifi/use-system-certs.patch10
-rw-r--r--user/py3-cryptography/APKBUILD4
-rw-r--r--user/py3-future/APKBUILD8
-rw-r--r--user/py3-pbr/APKBUILD4
-rw-r--r--user/py3-pyyaml/APKBUILD12
-rw-r--r--user/py3-requests-toolbelt/APKBUILD4
8 files changed, 25 insertions, 27 deletions
diff --git a/user/certbot/APKBUILD b/user/certbot/APKBUILD
index cbe6853f5..1ff38841e 100644
--- a/user/certbot/APKBUILD
+++ b/user/certbot/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=certbot
-pkgver=0.30.2
+pkgver=0.32.0
pkgrel=0
pkgdesc="The EFF's reference ACME client"
url="https://certbot.eff.org/"
@@ -41,4 +41,4 @@ acme() {
python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="94c26be7c04de74acf650b4d243675e92c6807eb6bb82fcffd867b22aa5b5527e6f637155fafcb121dfeff77e8a236301c080ad42284b3bf777d2cfc7f4d0de6 certbot-0.30.2.tar.gz"
+sha512sums="fa61e975d2ce09efa3570118f220cd9f9d2fc8d5ab408feb4c4e50bfa795cb28be6c7a78497fb10bc91e577e908126988197ae5d016be4823c5c4ddb68cbf5a4 certbot-0.32.0.tar.gz"
diff --git a/user/py3-certifi/APKBUILD b/user/py3-certifi/APKBUILD
index a67195293..26f6b81f5 100644
--- a/user/py3-certifi/APKBUILD
+++ b/user/py3-certifi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-certifi
_pkgname=${pkgname#py3-}
-pkgver=2018.11.29
+pkgver=2019.3.9
pkgrel=0
pkgdesc="Python package for providing Mozilla's CA Bundle"
url="https://pypi.org/project/certifi"
@@ -26,5 +26,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="6a6bf1ff98caefcdbf78a8c83e11e155368bacdd806f0ae0c6afa8f513667df6598e594b3584de61acdca3d6049f4a776937f2aa8672b602bd6db7b737f6074e certifi-2018.11.29.tar.gz
-1de38c55102b41bc91870b4810de89d8b0cffd61ba14257fe6c8445173b8b44153f2736050772eb63dd0a755890afe0f2d27516bbd39f05bf4016a4e29eebb67 use-system-certs.patch"
+sha512sums="d86559b0d384f8114245b169391c73d5e6df02ba411cf9706c9d4e5958eeef610b6550bcb5eb519856b8fa25f3f5eb1cea02c0df1f6df72e16da8201732b0dd9 certifi-2019.3.9.tar.gz
+afa381a68bbf117fcebb4cd020d8134dcf7c641a3258231249804c4b66d1c2c59fafe2dc1e55f0ddc2e269ad5f49ab10b96fd73d243d7b1df78f15fe70f279e4 use-system-certs.patch"
diff --git a/user/py3-certifi/use-system-certs.patch b/user/py3-certifi/use-system-certs.patch
index bf315aa2f..231e8c94d 100644
--- a/user/py3-certifi/use-system-certs.patch
+++ b/user/py3-certifi/use-system-certs.patch
@@ -1,13 +1,9 @@
---- a/certifi/core.py 2018-01-18 12:27:24.000000000 -0800
-+++ b/certifi/core.py 2018-11-20 18:08:48.230610538 -0800
-@@ -19,9 +19,7 @@
-
+--- a/certifi/core.py
++++ b/certifi/core.py
+@@ -12,5 +12,3 @@
def where():
- f = os.path.dirname(__file__)
-
- return os.path.join(f, 'cacert.pem')
+ return "/etc/ssl/certs/ca-certificates.crt"
-
-
- def old_where():
diff --git a/user/py3-cryptography/APKBUILD b/user/py3-cryptography/APKBUILD
index 587199c0e..7d006ac76 100644
--- a/user/py3-cryptography/APKBUILD
+++ b/user/py3-cryptography/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-cryptography
_pkgname=${pkgname#py3-}
-pkgver=2.5
+pkgver=2.6.1
pkgrel=0
pkgdesc="A package which provides cryptographic recipes and primitives"
url="https://pypi.org/project/cryptography"
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="5e8f8818fcaa8143526006b027107b8afbdc925d40c846701e65b2c7ee02235b7e0918246515520ef2030b1c87bb157d0d403c28ad68c31459d677af7e2d0b3f cryptography-2.5.tar.gz"
+sha512sums="f14319e24d9dca52e74548cada5b78a6235f089ef875dbff4799e862f94da8b087f1b6e03e84dcef9fc7d7693c4a349c5f0cd54b8535806da777420ce8757d39 cryptography-2.6.1.tar.gz"
diff --git a/user/py3-future/APKBUILD b/user/py3-future/APKBUILD
index d98fc65c2..7f433a4fc 100644
--- a/user/py3-future/APKBUILD
+++ b/user/py3-future/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-future
-_pkgname=python-future
-pkgver=0.17.0
+_pkgname=${pkgname##py3-}
+pkgver=0.17.1
pkgrel=0
pkgdesc="Easy, clean, reliable Python 2/3 compatibility"
url="http://python-future.org/"
@@ -12,7 +12,7 @@ license="MIT"
depends="python3"
makedepends="python3-dev"
subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/PythonCharmers/$_pkgname/archive/v$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="0b914ba062dd2b3c6837d8d8d274d27faadc587b264e887266527940fa7b4b98ce1b0076f1e589f943406d24b9e17f3ae8c2060c4ffa2207f620040988c176a3 py3-future-0.17.0.tar.gz"
+sha512sums="50094c44db81afbfd37ee25e1710ed11ecb2c2d64ad076fb62a2688dd36a9696ab26b0d7989bf1ecb10da251961a0ee6bb37c4dbd115f70384cd8c9a675d0b2d future-0.17.1.tar.gz"
diff --git a/user/py3-pbr/APKBUILD b/user/py3-pbr/APKBUILD
index 2bbf0283c..d92c97139 100644
--- a/user/py3-pbr/APKBUILD
+++ b/user/py3-pbr/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-pbr
_pkgname=${pkgname#py3-}
-pkgver=5.1.1
+pkgver=5.1.3
pkgrel=0
pkgdesc="Python Build Reasonableness"
url="https://pypi.org/project/pbr"
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="cd6f8bdc6db80841e948dbb278423556861aa681b970050a40c920dd00e32704a29cfdd28aabd4d14e0e577fff1bc816f0646a62c9450d0d85233ab5802606f1 pbr-5.1.1.tar.gz"
+sha512sums="66927b835058efb24182806e9ba16ee2066798ec7a1bc8dc0e5ec2b9260297515f0cfae192eef665a16e866462a88d379bb56bea21e86083df71b05868219675 pbr-5.1.3.tar.gz"
diff --git a/user/py3-pyyaml/APKBUILD b/user/py3-pyyaml/APKBUILD
index 8af1d75f1..6dece19c3 100644
--- a/user/py3-pyyaml/APKBUILD
+++ b/user/py3-pyyaml/APKBUILD
@@ -1,21 +1,23 @@
# Contributor: zlg <zlg+adelie@zlg.space>
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-pyyaml
-_pkgname=PyYAML
-pkgver=3.13
+_pkgname=pyyaml
+pkgver=5.1
pkgrel=0
pkgdesc="YAML parser and emitter for Python"
url="https://pyyaml.org/wiki/PyYAML"
-arch="all"
+arch="noarch"
license="MIT"
depends="python3 yaml"
makedepends="python3-dev yaml yaml-dev"
subpackages=""
-source="http://pyyaml.org/download/pyyaml/$_pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/yaml/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
+ # Seems like they need Cython to build the C extension now, so it falls back to pure Python.
+ # Once we ship Cython we can probably change this.
python3 setup.py build
}
@@ -29,4 +31,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="93642286d0317e2fe970632c36d38ce6030f7cabcf971f28e3a1054f07390fcee5baaf7f167e7c9690dbd7b2adc61f5b7d75a218ace0abca34ff8815486cfdd7 PyYAML-3.13.tar.gz"
+sha512sums="e49f593b9f60018efa19629b902ad1e56f79537106a4cd019baa324a74a8af7563d294db012280261fc7fa9d686dd5af656e22fb4bf6a6ccfd0084515b9591d5 py3-pyyaml-5.1.tar.gz"
diff --git a/user/py3-requests-toolbelt/APKBUILD b/user/py3-requests-toolbelt/APKBUILD
index 80d5353e6..eeef959c8 100644
--- a/user/py3-requests-toolbelt/APKBUILD
+++ b/user/py3-requests-toolbelt/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: zlg <zlg+adelie@zlg.space>
pkgname=py3-requests-toolbelt
_pkgname=${pkgname##*-}
-pkgver=0.8.0
+pkgver=0.9.1
pkgrel=0
pkgdesc="Useful classes and functions to be used with python-requests"
url="https://github.com/requests/toolbelt"
@@ -26,4 +26,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="55bf93d386442f5deb81eabd85812ffd49e98ff88c0bb96e15271efd84deb7c5d854a2cdc81c989a7d74870e8a218fc968d080052d9ca7cd9733a2378ea9c2f5 py3-requests-toolbelt-0.8.0.tar.gz"
+sha512sums="12667056c225ce0bc88a5959660103feed23810890abd3890ef15581aa64c09c0552c3974473e1742cbe6200bd37d6475ad34ec051e83d4fbf0a33f320dbc0cc py3-requests-toolbelt-0.9.1.tar.gz"