summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-06-01 23:04:18 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-06-01 23:04:18 +0000
commit3b329c19497c9e83bf5173c5621147c1b8eab1da (patch)
tree5dbc157846d74ae588007d7656b6f169a4706cde /user
parent8cbcedad8e10818a217c55770a378215fd1567ae (diff)
parent5befc512a356c813a292168c535e5c365cb69e2d (diff)
downloadpackages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.gz
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.bz2
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.tar.xz
packages-3b329c19497c9e83bf5173c5621147c1b8eab1da.zip
Merge branch 'wine-4' into 'master'
user/wine: bump to 4.0.1, add mpg123 support I can backport the `mpg123` support if you'd like. I think I need to investigate Wine 3 a little more since there appears to be serious problems with it - like not even being able to move Notepad windows around without freezing. This problem is not present in Wine 4, so either something changed upstream or our package is corrupted. I will try a rebuild and see what happens. See merge request !230
Diffstat (limited to 'user')
-rw-r--r--user/wine/APKBUILD11
-rw-r--r--user/wine/no-pie.patch21
2 files changed, 15 insertions, 17 deletions
diff --git a/user/wine/APKBUILD b/user/wine/APKBUILD
index 99cf1f2dd..ea9384603 100644
--- a/user/wine/APKBUILD
+++ b/user/wine/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Martell Malone <martell@marinelayer.io>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=wine
-pkgver=3.0.2
+pkgver=4.0.1
pkgrel=0
pkgdesc="A compatibility layer for running Windows programs"
url="http://www.winehq.com"
@@ -20,7 +20,7 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
libxcomposite-dev libxrender-dev libxinerama-dev zlib-dev
cups-dev alsa-lib-dev libxml2-dev dbus-dev libxi-dev
gnutls-dev tiff-dev v4l-utils-dev udisks2-dev autoconf automake
- openal-soft-dev pulseaudio-dev sane-dev eudev-dev
+ openal-soft-dev pulseaudio-dev sane-dev eudev-dev mpg123-dev
"
source="http://dl.winehq.org/$pkgname/source/${pkgver%.[1-9]}/$pkgname-$pkgver.tar.xz
no-pie.patch
@@ -53,6 +53,7 @@ build() {
--with-fontconfig \
--with-freetype \
--with-jpeg \
+ --with-mpg123 \
--with-openal \
--with-opengl \
--with-png \
@@ -64,7 +65,7 @@ build() {
--with-xcomposite \
--with-xinerama \
--with-xslt \
- $_win64
+ $_win64
make
}
@@ -129,6 +130,6 @@ libs() {
done
}
-sha512sums="dbd0f242c5eace297ad16e314b8ad139e7d430de7eb8ca52b2006d0b80db4809e28a0e785d404a65ea1acdb56e7f06ebfc9a50071db1edaa6180c8835e7c4b13 wine-3.0.2.tar.xz
-d853875f7d659617bdfba364704abd75b760d12977f1f13acc73acb3c8fefec0549677fb79a4f8955e073d64078b3071d63d97262522e22b7832a66d3d820a9c no-pie.patch
+sha512sums="dd240525e389f841123a569fd2f9b8da698b7707bc0de408dfd60ae73c5e24d522abb42b76571c840df52c686fdeae56e0a9c69db2cd31f04cdb345feeacf1dc wine-4.0.1.tar.xz
+a96b1e248447912ba522067b67fc920063f355f326eaf3fec760c79a1c6e46019fbdcfa8b95b9d389959a7e3d3ab794f9aaf78913ad6a73be32b5d34ca8a2267 no-pie.patch
522a94a31fc459e80ea7dd05f7aee64f6ae666ec05236d06614acde118d5c60002e0f253ae75edb5f02164f22937ca89578504b690d1a5611bd60f703c8f0c00 winhlp32-flex.patch"
diff --git a/user/wine/no-pie.patch b/user/wine/no-pie.patch
index 5fb5d87b6..2874e0af8 100644
--- a/user/wine/no-pie.patch
+++ b/user/wine/no-pie.patch
@@ -1,14 +1,11 @@
-diff --git a/loader/Makefile.in b/loader/Makefile.in
-index 8190037..437d4d9 100644
---- a/loader/Makefile.in
-+++ b/loader/Makefile.in
-@@ -26,7 +26,7 @@ wine64_DEPS = $(WINELOADER_DEPENDS)
- wine64_LDFLAGS = $(LDEXECFLAGS) -lwine $(PTHREAD_LIBS)
+--- wine-4.0.1/configure.ac
++++ wine-4.0.1/configure.ac
+@@ -955,7 +955,7 @@
- wine_preloader_OBJS = preloader.o
--wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
+ [WINELOADER_LDFLAGS="-Wl,--export-dynamic"])
+- WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000"
++ WINEPRELOADER_LDFLAGS="-static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie"
- wine64_preloader_OBJS = preloader.o
--wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000
-+wine64_preloader_LDFLAGS = -static -nostartfiles -nodefaultlibs -Wl,-Ttext=0x7c400000 -no-pie
+ WINE_TRY_CFLAGS([-fPIC -Wl,--rpath,\$ORIGIN/../lib],
+ [LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(MAKEDEP) -R \${bindir} \${libdir}\`"