summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-04-17 02:41:35 +0000
commit43b60beb3683582dba2610095c5c0d9fe103ec4c (patch)
treeee2d0852258898f90b9033fc54161c3f90fd8e7d /user
parent8e41995ddbb56175eb00995ab0f7f750e5bde2da (diff)
parent4f4582578d04b74931148cf5a3e4cc6653188bc6 (diff)
downloadpackages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.gz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.bz2
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.tar.xz
packages-43b60beb3683582dba2610095c5c0d9fe103ec4c.zip
Merge branch 'meta/tox' into 'master'
Basic python3 testing packages ``` Includes: * user/py3-tox * user/py3-setuptools * user/py3-pluggy * user/py3-virtualenv * user/py3-pytest ** user/py3-py Most of these packages use tox itself for tests, so !check until we have a copy of tox on the mirrors with which to bootstrap. ``` See merge request !16
Diffstat (limited to 'user')
-rw-r--r--user/py3-pluggy/APKBUILD33
-rw-r--r--user/py3-py/APKBUILD35
-rw-r--r--user/py3-pytest/APKBUILD33
-rw-r--r--user/py3-setuptools/APKBUILD45
-rw-r--r--user/py3-setuptools/pythonpath.patch10
-rw-r--r--user/py3-tox/APKBUILD33
-rw-r--r--user/py3-virtualenv/APKBUILD37
-rw-r--r--user/py3-virtualenv/test-python3.patch74
8 files changed, 300 insertions, 0 deletions
diff --git a/user/py3-pluggy/APKBUILD b/user/py3-pluggy/APKBUILD
new file mode 100644
index 000000000..b71d8de07
--- /dev/null
+++ b/user/py3-pluggy/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pluggy
+_pkgname=pluggy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="Plugin management and hook calling for Python"
+url="https://pypi.python.org/pypi/pluggy"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Cyclic dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36-pytestrelease
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812 py3-pluggy-0.6.0.tar.gz"
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
new file mode 100644
index 000000000..171ac8245
--- /dev/null
+++ b/user/py3-py/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-py
+_pkgname=py
+pkgver=1.4.34
+pkgrel=0
+pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
+url="https://pypi.python.org/py/$pkgver"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ # This test suite seems to be incurring the wrath of
+ # https://bugs.python.org/issue28627 on 1.5.2
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py3-py-1.4.34.tar.gz"
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
new file mode 100644
index 000000000..39b723529
--- /dev/null
+++ b/user/py3-pytest/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-pytest
+_pkgname=pytest
+pkgver=3.2.2
+pkgrel=0
+pkgdesc="A python test library"
+url="https://pypi.python.org/pypi/pytest"
+arch="noarch"
+license="MIT"
+depends="python3 py3-py"
+makedepends="py3-setuptools python3-dev"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db py3-pytest-3.2.2.tar.gz"
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
new file mode 100644
index 000000000..ba5e1aebf
--- /dev/null
+++ b/user/py3-setuptools/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-setuptools
+_pkgname=setuptools
+pkgver=38.4.0
+pkgrel=1
+pkgdesc="A collection of enhancements to the Python distutils"
+url="http://pypi.python.org/pypi/setuptools"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+#checkdepends="py3-tox"
+options="!check" # Circular dependency with py3-tox. Passes on x86_64
+subpackages="py3-easy_install:easy_install"
+# Note: PyPI download is missing tests/requirements.txt
+source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
+ pythonpath.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 bootstrap.py
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ PYTHONPATH="$builddir" TOXENV="py36" tox
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+easy_install() {
+ pkgdesc="Python easy_install tool (deprecated)"
+ depends="$pkgname python3"
+ mkdir -p "$subpkgdir/usr/bin"
+ mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
+}
+
+sha512sums="81903ee7ecb19715bbafe7b4e6878d3af5f801a9ff3334e82a599a81a8e6430443c4b765180c53c3c9cdcea338b3fff0bdf26245bc9d2da7d5d41b745de73a24 py3-setuptools-38.4.0.tar.gz
+0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch"
diff --git a/user/py3-setuptools/pythonpath.patch b/user/py3-setuptools/pythonpath.patch
new file mode 100644
index 000000000..371804f55
--- /dev/null
+++ b/user/py3-setuptools/pythonpath.patch
@@ -0,0 +1,10 @@
+--- setuptools-38.4.0/tox.ini 2018-01-05 13:17:02.000000000 +0000
++++ setuptools-38.4.0/tox.ini 2018-01-11 01:50:05.810000000 +0000
+@@ -6,6 +6,6 @@
+
+ [testenv]
+ deps=-rtests/requirements.txt
+-passenv=APPDATA USERPROFILE HOMEDRIVE HOMEPATH windir APPVEYOR
++passenv=APPDATA USERPROFILE HOMEDRIVE HOMEPATH windir APPVEYOR PYTHONPATH
+ commands=py.test {posargs}
+ usedevelop=True
diff --git a/user/py3-tox/APKBUILD b/user/py3-tox/APKBUILD
new file mode 100644
index 000000000..9ae7e731a
--- /dev/null
+++ b/user/py3-tox/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-tox
+_pkgname=tox
+pkgver=2.9.1
+pkgrel=0
+pkgdesc="virtualenv management and test command line tool"
+url="https://pypi.python.org/pypi/tox"
+arch="noarch"
+license="MIT"
+depends="py3-py py3-pluggy py3-virtualenv py3-six python3"
+makedepends="python3-dev py3-setuptools"
+#checkdepends="py3-pytest py3-tox"
+options="!check" # Circular dependency with itself and py3-pytest. Passes on x86_64
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox -e py36
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066 py3-tox-2.9.1.tar.gz"
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
new file mode 100644
index 000000000..8a4dde3e1
--- /dev/null
+++ b/user/py3-virtualenv/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=py3-virtualenv
+_pkgname=virtualenv
+pkgver=15.1.0
+pkgrel=0
+pkgdesc="Virtual Python Environment builder"
+url="https://pypi.python.org/pypi/virtualenv"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="python3-dev"
+checkdepends="py3-pytest py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ test-python3.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ sed -ie "s/env python$/env python3/" virtualenv.py
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd tests
+ ./test_activate.sh
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d7e95b8c017ec076210f30b6fd4bb44be2f7dc0257492c25bb00fee597d3ade34226d03539180f1edaf2d27b361f8efdabb92d3476e13785b890878ee1295cb2 py3-virtualenv-15.1.0.tar.gz
+8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"
diff --git a/user/py3-virtualenv/test-python3.patch b/user/py3-virtualenv/test-python3.patch
new file mode 100644
index 000000000..8b4a99b51
--- /dev/null
+++ b/user/py3-virtualenv/test-python3.patch
@@ -0,0 +1,74 @@
+--- virtualenv-15.1.0/tests/test_activate_output.expected 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_activate_output.expected 2018-01-10 23:31:17.840000000 +0000
+@@ -1,2 +1,4 @@
+-New python executable in /tmp/test_virtualenv_activate.venv/bin/python
++Using base prefix '/usr'
++New python executable in /tmp/test_virtualenv_activate.venv/bin/python3
++Also creating executable in /tmp/test_virtualenv_activate.venv/bin/python
+ Installing setuptools, pip, wheel...done.
+--- virtualenv-15.1.0/tests/test_virtualenv.py 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_virtualenv.py 2018-01-11 03:40:22.270000000 +0000
+@@ -58,13 +58,13 @@
+ def test_activate_after_future_statements():
+ """Should insert activation line after last future statement"""
+ script = [
+- '#!/usr/bin/env python',
++ '#!/usr/bin/env python3',
+ 'from __future__ import with_statement',
+ 'from __future__ import print_function',
+ 'print("Hello, world!")'
+ ]
+ assert virtualenv.relative_script(script) == [
+- '#!/usr/bin/env python',
++ '#!/usr/bin/env python3',
+ 'from __future__ import with_statement',
+ 'from __future__ import print_function',
+ '',
+@@ -110,7 +110,7 @@
+ if virtualenv.is_win:
+ required_executables = ['python.exe', 'pythonw.exe']
+ else:
+- py_exe_no_version = 'python'
++ py_exe_no_version = 'python3'
+ py_exe_version_major = 'python%s' % sys.version_info[0]
+ py_exe_version_major_minor = 'python%s.%s' % (
+ sys.version_info[0], sys.version_info[1])
+--- virtualenv-15.1.0/tests/test_activate.sh 2016-11-16 02:39:30.000000000 +0000
++++ virtualenv-15.1.0/tests/test_activate.sh 2018-01-11 03:49:05.070000000 +0000
+@@ -19,7 +19,7 @@
+ echo "$0: Created virtualenv ${TESTENV}." 1>&2
+
+ echo "$0: Activating ${TESTENV}..." 1>&2
+-. ${TESTENV}/bin/activate
++PS1="${PS1:-}" . ${TESTENV}/bin/activate
+ echo "$0: Activated ${TESTENV}." 1>&2
+
+ echo "$0: Checking value of \$VIRTUAL_ENV..." 1>&2
+@@ -31,14 +31,14 @@
+
+ echo "$0: \$VIRTUAL_ENV = \"${VIRTUAL_ENV}\" -- OK." 1>&2
+
+-echo "$0: Checking output of \$(which python)..." 1>&2
++echo "$0: Checking output of \$(which python3)..." 1>&2
+
+-if [ "$(which python)" != "${TESTENV}/bin/python" ]; then
+- echo "$0: Expected \$(which python) to return \"${TESTENV}/bin/python\"; actual value: \"$(which python)\"!" 1>&2
++if [ "$(which python3)" != "${TESTENV}/bin/python3" ]; then
++ echo "$0: Expected \$(which python3) to return \"${TESTENV}/bin/python3\"; actual value: \"$(which python3)\"!" 1>&2
+ exit 3
+ fi
+
+-echo "$0: Output of \$(which python) is OK." 1>&2
++echo "$0: Output of \$(which python3) is OK." 1>&2
+
+ echo "$0: Checking output of \$(which pip)..." 1>&2
+
+@@ -60,7 +60,7 @@
+
+ echo "$0: Executing a simple Python program..." 1>&2
+
+-TESTENV=${TESTENV} python <<__END__
++TESTENV=${TESTENV} python3 <<__END__
+ import os, sys
+
+ expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')