summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 12:08:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-04-05 12:08:56 +0000
commit4862439e0ffaeeb0d3dfa844edf236e67df19c70 (patch)
tree841129d39cd878ce17216929cab36f1895464063 /user
parent1994a1a0e90b68c1e53e7827e32eff5b0dbb665c (diff)
downloadpackages-4862439e0ffaeeb0d3dfa844edf236e67df19c70.tar.gz
packages-4862439e0ffaeeb0d3dfa844edf236e67df19c70.tar.bz2
packages-4862439e0ffaeeb0d3dfa844edf236e67df19c70.tar.xz
packages-4862439e0ffaeeb0d3dfa844edf236e67df19c70.zip
user/opengfx: Update to 0.6.0
Diffstat (limited to 'user')
-rw-r--r--user/opengfx/APKBUILD11
-rw-r--r--user/opengfx/Makefile.patch22
2 files changed, 4 insertions, 29 deletions
diff --git a/user/opengfx/APKBUILD b/user/opengfx/APKBUILD
index 6393b9717..0e79f2369 100644
--- a/user/opengfx/APKBUILD
+++ b/user/opengfx/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=opengfx
-pkgver=0.5.5
+pkgver=0.6.0
pkgrel=0
pkgdesc="Graphics files for OpenTTD"
url="https://www.openttd.org/en/"
@@ -9,11 +9,9 @@ arch="noarch"
options="!check" # Requires GIMP
license="GPL-2.0-only"
depends=""
-makedepends="grfcodec nml"
+makedepends="grfcodec nml cmd:unix2dos cmd:which"
subpackages=""
-source="https://binaries.openttd.org/extra/opengfx/$pkgver/$pkgname-$pkgver-source.tar.xz
- Makefile.patch
- "
+source="https://cdn.openttd.org/opengfx-releases/$pkgver/$pkgname-$pkgver-source.tar.xz"
builddir="$srcdir/$pkgname-$pkgver-source"
build() {
@@ -27,5 +25,4 @@ package() {
done
}
-sha512sums="952fb52e19bd790e335a9df0f11fa29b2fc570b49903419904956cc65883adde93d432160b16682366ab8b973b7852d2d30f574f1840f6fbd082e1addbe5bfe8 opengfx-0.5.5-source.tar.xz
-a337ab4ade493a87d2687a7aa2fb05dcd5718725645950486975a6df309dd1e6631d4b04fa6dcbf590e869b45b037caa32468ea6f677ce458d61950f77c5a006 Makefile.patch"
+sha512sums="275b9040e6938bdd5bee2d39361e0b78f447a8e497cc8ff018c7874dc16a357870f8b560999ebb2f2f0b275644c7c9ce85c964875f5a798e2ec45e62a8bc768f opengfx-0.6.0-source.tar.xz"
diff --git a/user/opengfx/Makefile.patch b/user/opengfx/Makefile.patch
deleted file mode 100644
index 1e4585311..000000000
--- a/user/opengfx/Makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- opengfx-0.5.3-source/Makefile
-+++ opengfx-0.5.3-source/Makefile
-@@ -99,8 +99,8 @@
- AWK ?= awk
- GREP ?= grep
- PYTHON ?= python
--UNIX2DOS ?= $(shell which unix2dos)
--UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null && echo "-q" || echo "")
-+UNIX2DOS ?= $(shell which unix2dos 2>/dev/null)
-+UNIX2DOS_FLAGS ?= $(shell [ -n $(UNIX2DOS) ] && $(UNIX2DOS) -q --version 2>/dev/null >&2 && echo "-q" || echo "")
-
- # Graphics processing
- GIMP ?= gimp
-@@ -719,7 +719,7 @@
- $(_E)
- endif
- $(_E) "Release:"
-- $(_E) "bananas: Upload bundle to BaNaNaS
-+ $(_E) "bananas: Upload bundle to BaNaNaS"
- $(_E)
- $(_E) "Valid command line variables are:"
- $(_E) "Helper programmes:"