summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:03:32 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:03:32 +0000
commit4b4b48daeae1f96fb05007102312d38cf9d3ea4a (patch)
tree89a0753d5f2db6bfc3d0254f7df0e4cb0b8f2413 /user
parent380485eb6689ca23a1462e4f0a38006b7a41757e (diff)
downloadpackages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.gz
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.bz2
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.tar.xz
packages-4b4b48daeae1f96fb05007102312d38cf9d3ea4a.zip
user/*: Modernise / fix syntax / metadata / deps / code
Diffstat (limited to 'user')
-rw-r--r--user/mosh/APKBUILD4
-rw-r--r--user/tmux-bash-completion/APKBUILD7
-rw-r--r--user/trigger-rally/APKBUILD10
-rw-r--r--user/trigger-rally/sdl2-compat.patch11
-rw-r--r--user/ttf-sudo/APKBUILD3
-rw-r--r--user/wxwidgets/APKBUILD3
6 files changed, 20 insertions, 18 deletions
diff --git a/user/mosh/APKBUILD b/user/mosh/APKBUILD
index 7ec12f783..d138bd4f3 100644
--- a/user/mosh/APKBUILD
+++ b/user/mosh/APKBUILD
@@ -20,12 +20,10 @@ prepare() {
default_prepare
# Test unicode-later-combining is failing. Ideally we want to fix it.
sed -i '/unicode-later-combining.test/d' "$builddir"/src/tests/Makefile.am
- cd "$builddir"
./autogen.sh
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -38,12 +36,10 @@ build() {
}
check() {
- cd "$builddir"
make check VERBOSE=1 V=1
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
diff --git a/user/tmux-bash-completion/APKBUILD b/user/tmux-bash-completion/APKBUILD
index 8ddbcc875..fe35c7d11 100644
--- a/user/tmux-bash-completion/APKBUILD
+++ b/user/tmux-bash-completion/APKBUILD
@@ -7,17 +7,18 @@ pkgrel=0
pkgdesc="bash-completion files for tmux"
url="https://github.com/imomaliev/tmux-bash-completion"
arch="noarch"
-options="!check" # no tests
+options="!check" # No test suite.
license="GPL-2.0-only"
depends="bash-completion tmux"
makedepends=""
subpackages=""
+install_if="tmux bash-completion"
source="$pkgname-$pkgver.tar.gz::https://github.com/imomaliev/tmux-bash-completion/archive/$_commit.tar.gz"
builddir="$srcdir/$pkgname-$_commit"
package() {
- cd "$builddir"
- install -Dm644 ./completions/tmux "$pkgdir"/usr/share/bash-completion/completions/tmux
+ install -Dm644 "$builddir"/completions/tmux \
+ "$pkgdir"/usr/share/bash-completion/completions/tmux
}
sha512sums="6c4c761aa152d1352a575c91e2c375d3f19ad01263b603b9e0cde4bdd95ce478c93bb55bfcd9fa5332cde12399e1e1e1c062e6be2ed7403b96e808275401effa tmux-bash-completion-1.0.0_git20170805.tar.gz"
diff --git a/user/trigger-rally/APKBUILD b/user/trigger-rally/APKBUILD
index 07e4de092..9e71972d1 100644
--- a/user/trigger-rally/APKBUILD
+++ b/user/trigger-rally/APKBUILD
@@ -14,19 +14,16 @@ makedepends="freealut-dev glew-dev glu-dev openal-soft-dev physfs-dev sdl2-dev
subpackages="$pkgname-doc"
source="https://downloads.sourceforge.net/trigger-rally/trigger-rally-$pkgver.tar.gz
dont-strip.patch
+ sdl2-compat.patch
trigger-rally.desktop
"
build() {
- cd "$builddir"/src
- make OPTIMS="$CXXFLAGS -Wno-deprecated-declarations" DESTDIR="$pkgdir" prefix=/usr build
+ make OPTIMS="$CXXFLAGS -Wno-deprecated-declarations" DESTDIR="$pkgdir" prefix=/usr -C src build
}
package() {
- local _icon=""
-
- cd "$builddir"/src
- make OPTIMS="$CXXFLAGS" DESTDIR="$pkgdir" prefix=/usr install
+ make OPTIMS="$CXXFLAGS" DESTDIR="$pkgdir" prefix=/usr -C src install
install -D -m644 "$srcdir"/trigger-rally.desktop \
"$pkgdir"/usr/share/applications/trigger-rally.desktop
@@ -41,4 +38,5 @@ package() {
sha512sums="feed805858ef63907bb10088761f1219b22fe55ead268511ef73b18aa0f18d79e87d4e2cbfb76361b1dec3949b59464af33efe31e81f06ae7e163430f3336669 trigger-rally-0.6.6.1.tar.gz
a81781058177e012daaad58d72e4bdbdbc2730b1df76941ba03f06367545b213ba82a33bab46deba31570973deb1802a3d459704c3a963c38eec69ef82f228d5 dont-strip.patch
+e16fa74f1554cf8202f1ae5994c8f65eb311bf85ec9e89989911975db54d22c8e7dff559952e730972011b7dfabfd6aedb8c9f1d6292839734bfee54796b743a sdl2-compat.patch
ddaf7d89353280f7952d6cffd06182ea28640473e18eff06809c48477349248f57922eaff9bf816261c32f8fdc167d933f345422f9885638041dd9f5e5ac0524 trigger-rally.desktop"
diff --git a/user/trigger-rally/sdl2-compat.patch b/user/trigger-rally/sdl2-compat.patch
new file mode 100644
index 000000000..ae3f7c609
--- /dev/null
+++ b/user/trigger-rally/sdl2-compat.patch
@@ -0,0 +1,11 @@
+--- trigger-rally-0.6.6.1/src/GNUmakefile.old 2020-01-12 09:46:17.392027213 +0000
++++ trigger-rally-0.6.6.1/src/GNUmakefile 2020-01-12 09:56:43.744640443 +0000
+@@ -26,7 +26,7 @@
+ INCDIRS := -I'./include'
+ CXXFLAGS += -std=c++11 $(WARNINGS) $(OPTIMS)
+ CPPFLAGS += $(DMACROS) $(INCDIRS)
+-EXTRA_LIBS := -lSDL2main -lGL -lGLU -lGLEW -lSDL2 -lSDL2_image -lphysfs -lopenal -lalut -lpthread -ltinyxml2
++EXTRA_LIBS := -lSDL2main -lGL -lGLU -lGLEW -lSDL2-2.0 -lSDL2_image -lphysfs -lopenal -lalut -lpthread -ltinyxml2
+ LDFLAGS += $(EXTRA_LIBS)
+ INSTALL_PROGRAM := install --mode=0755
+ INSTALL_DATA := install --mode=0644
diff --git a/user/ttf-sudo/APKBUILD b/user/ttf-sudo/APKBUILD
index c92b41be5..23d44cdb2 100644
--- a/user/ttf-sudo/APKBUILD
+++ b/user/ttf-sudo/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Monospaced font family for programming and console users"
url="https://www.kutilek.de/sudo-font/"
arch="noarch"
-options="!check" # No tests
+options="!check" # No test suite.
license="OFL-1.1"
depends="fontconfig"
makedepends=""
@@ -14,7 +14,6 @@ source="https://github.com/jenskutilek/sudo-font/releases/download/v$pkgver/sudo
builddir="$srcdir/sudo"
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/usr/share/fonts/X11/TTF/${pkgname#*-}
for i in *.ttf; do
install -Dm644 "$i" "$pkgdir"/usr/share/fonts/X11/TTF/${pkgname#*-}
diff --git a/user/wxwidgets/APKBUILD b/user/wxwidgets/APKBUILD
index 192e67cb2..25f20db92 100644
--- a/user/wxwidgets/APKBUILD
+++ b/user/wxwidgets/APKBUILD
@@ -18,7 +18,6 @@ source="https://github.com/wxWidgets/wxWidgets/releases/download/v$pkgver/wxWidg
builddir="$srcdir/wxWidgets-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -31,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}