summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-10-19 18:57:57 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-10-19 18:57:57 +0000
commit615706519a4d1f25ed49eb9700107520446d66c4 (patch)
tree26958a658ee0e69e778e04a0a53e1186b2b8d6d3 /user
parentcc4a22b8d11e4019eabb255c64ee6c8f733cb76f (diff)
parentfd2ae754a2c7e16e994e2aa15929b2bd1c6b52e1 (diff)
downloadpackages-615706519a4d1f25ed49eb9700107520446d66c4.tar.gz
packages-615706519a4d1f25ed49eb9700107520446d66c4.tar.bz2
packages-615706519a4d1f25ed49eb9700107520446d66c4.tar.xz
packages-615706519a4d1f25ed49eb9700107520446d66c4.zip
Merge branch 'xfce4.plugins' into 'master'
A bunch of XFCE plugins See merge request !82
Diffstat (limited to 'user')
-rw-r--r--user/ido/APKBUILD43
-rw-r--r--user/libindicator/APKBUILD43
-rw-r--r--user/xfce-plugins/APKBUILD26
-rw-r--r--user/xfce-plugins/dummy0
-rw-r--r--user/xfce4-battery-plugin/APKBUILD44
-rw-r--r--user/xfce4-clipman-plugin/APKBUILD38
-rw-r--r--user/xfce4-cpugraph-plugin/APKBUILD44
-rw-r--r--user/xfce4-diskperf-plugin/APKBUILD37
-rw-r--r--user/xfce4-indicator-plugin/APKBUILD37
-rw-r--r--user/xfce4-netload-plugin/APKBUILD39
-rw-r--r--user/xfce4-netload-plugin/no-sysctl.patch11
-rw-r--r--user/xfce4-pulseaudio-plugin/APKBUILD38
-rw-r--r--user/xfce4-sensors-plugin/APKBUILD37
-rw-r--r--user/xfce4-systemload-plugin/APKBUILD37
-rw-r--r--user/xfce4-time-out-plugin/APKBUILD44
-rw-r--r--user/xfce4-timer-plugin/APKBUILD37
-rw-r--r--user/xfce4-verve-plugin/APKBUILD37
-rw-r--r--user/xfce4-whiskermenu-plugin/APKBUILD36
18 files changed, 628 insertions, 0 deletions
diff --git a/user/ido/APKBUILD b/user/ido/APKBUILD
new file mode 100644
index 000000000..a2714b183
--- /dev/null
+++ b/user/ido/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=ido
+pkgver=12.10.2
+pkgrel=0
+pkgdesc="Library for indicator display objects"
+url="https://launchpad.net/libido"
+arch="all"
+options="!check" # broken testsuite
+license="(LGPL-2.1-only OR LGPL-3.0-only) AND GPL-3.0-only AND LGPL-2.0+"
+makedepends="gtk+3.0-dev"
+subpackages="$pkgname-dev"
+source="https://launchpad.net/ido/12.10/$pkgver/+download/ido-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ CFLAGS="-Wno-error" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f745380bbc8b97c739691ae4f0dc27d5903ff078e92aaa2280d2c830c77ea2ad29b3abb4a49ffc7cc928b32e3a60ad64de20087980e02e5d5233eeb22978d2dc ido-12.10.2.tar.gz"
diff --git a/user/libindicator/APKBUILD b/user/libindicator/APKBUILD
new file mode 100644
index 000000000..374a1e0ee
--- /dev/null
+++ b/user/libindicator/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=libindicator
+pkgver=12.10.1
+pkgrel=0
+pkgdesc="Library for builidng indicators for applets"
+url="https://launchpad.net/libindicator"
+arch="all"
+options="!check" # broken tests
+license="GPL-3.0-only"
+makedepends="gtk+3.0-dev"
+subpackages="$pkgname-dev"
+source="https://launchpad.net/libindicator/12.10/$pkgver/+download/libindicator-$pkgver.tar.gz"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ CFLAGS="-Wno-error" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d6d77d0309b15cf6b52539323920ab0c1594cb1c1cef8a8d67cd0f76f8ceeeac28eb6db6227563df1932e6f1fadcffac68d82982182b745257dfaf91f1c945af libindicator-12.10.1.tar.gz"
diff --git a/user/xfce-plugins/APKBUILD b/user/xfce-plugins/APKBUILD
new file mode 100644
index 000000000..8b9396447
--- /dev/null
+++ b/user/xfce-plugins/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce-plugins
+pkgver=0.1
+pkgrel=0
+pkgdesc="XFCE4 panel plugins metapackage"
+url="https://xfce.org"
+arch="noarch"
+options="!check" # no tests
+license="MIT"
+depends="xfce4-battery-plugin xfce4-diskperf-plugin xfce4-netload-plugin
+ xfce4-systemload-plugin xfce4-verve-plugin xfce4-clipman-plugin
+ xfce4-indicator-plugin xfce4-pulseaudio-plugin xfce4-time-out-plugin
+ xfce4-whiskermenu-plugin xfce4-cpugraph-plugin xfce4-sensors-plugin
+ xfce4-timer-plugin"
+source="dummy"
+
+build() {
+ cd "$srcdir"
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+sha512sums="cf83e1357eefb8bdf1542850d66d8007d620e4050b5715dc83f4a921d36ce9ce47d0d13c5d85f2b0ff8318d2877eec2f63b931bd47417a81a538327af927da3e dummy"
diff --git a/user/xfce-plugins/dummy b/user/xfce-plugins/dummy
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/user/xfce-plugins/dummy
diff --git a/user/xfce4-battery-plugin/APKBUILD b/user/xfce4-battery-plugin/APKBUILD
new file mode 100644
index 000000000..21ef88d73
--- /dev/null
+++ b/user/xfce4-battery-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-battery-plugin
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="Battery monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+ AND LGPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-battery-plugin/1.1/xfce4-battery-plugin-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ chmod a+w config.sub
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="d3f5b6d3657abfba2c4c5cb3ab8ddc87f4862f24eb614cb91af48332b3082c3dce7f32eb2e3cb8a9d501ddb01c6259c4fbfbab8ed9c221633e47eb17c623cf09 xfce4-battery-plugin-1.1.0.tar.bz2"
diff --git a/user/xfce4-clipman-plugin/APKBUILD b/user/xfce4-clipman-plugin/APKBUILD
new file mode 100644
index 000000000..0b5323314
--- /dev/null
+++ b/user/xfce4-clipman-plugin/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-clipman-plugin
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Clipboard management plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev libqrencode-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-clipman-plugin/1.4/xfce4-clipman-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-libqrencode
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f12d9e3e37a26f9dade5b76e73ac3998030112b53e7ec7b756128f7f1ee28d19a1d7b8d4a26e0ccb69aaba2f0ab2f6c4cd5a435bd1cc7efd81c05b711480eba6 xfce4-clipman-plugin-1.4.2.tar.bz2"
diff --git a/user/xfce4-cpugraph-plugin/APKBUILD b/user/xfce4-cpugraph-plugin/APKBUILD
new file mode 100644
index 000000000..3aef0d879
--- /dev/null
+++ b/user/xfce4-cpugraph-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-cpugraph-plugin
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Graphical CPU monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-cpugraph-plugin/1.0/xfce4-cpugraph-plugin-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ chmod a+w config.sub
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a xfce4-cpugraph-plugin-1.0.5.tar.bz2"
diff --git a/user/xfce4-diskperf-plugin/APKBUILD b/user/xfce4-diskperf-plugin/APKBUILD
new file mode 100644
index 000000000..a1bac7cb1
--- /dev/null
+++ b/user/xfce4-diskperf-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-diskperf-plugin
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="Disk performance monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="BSD-2-Clause AND GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-diskperf-plugin/2.6/xfce4-diskperf-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ba01ec30e31db0c936b2b18df7c68883f89c6c4d5b82392759c25ef41fa89de37e2e635abd169745a9790d81af5b327768eb62ec3cc369f85e2da0bedc4c7cea xfce4-diskperf-plugin-2.6.1.tar.bz2"
diff --git a/user/xfce4-indicator-plugin/APKBUILD b/user/xfce4-indicator-plugin/APKBUILD
new file mode 100644
index 000000000..db59691a5
--- /dev/null
+++ b/user/xfce4-indicator-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-indicator-plugin
+pkgver=2.3.4
+pkgrel=0
+pkgdesc="Application information plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev libindicator-dev ido-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-indicator-plugin/2.3/xfce4-indicator-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6 xfce4-indicator-plugin-2.3.4.tar.bz2"
diff --git a/user/xfce4-netload-plugin/APKBUILD b/user/xfce4-netload-plugin/APKBUILD
new file mode 100644
index 000000000..139ec29b5
--- /dev/null
+++ b/user/xfce4-netload-plugin/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-netload-plugin
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="Network monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-netload-plugin/1.3/xfce4-netload-plugin-$pkgver.tar.bz2
+ no-sysctl.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="34144bf2d95f71276f8b5f4cf417d97d380233805c6fec1b7c559fee5b11468a421d3691230e01d89b40289d5ab22a472dcbef2a7ee0854abd7213e0ef0a3ef9 xfce4-netload-plugin-1.3.1.tar.bz2
+ca7f5cb8282de4b46a7906570becbab6caa9670d91413945b92d849a5f1127befaf6274031637cde23731f4d78b9145d5973a1406d5c49ba4a0f7fe21ad2a6fd no-sysctl.patch"
diff --git a/user/xfce4-netload-plugin/no-sysctl.patch b/user/xfce4-netload-plugin/no-sysctl.patch
new file mode 100644
index 000000000..5bdab0807
--- /dev/null
+++ b/user/xfce4-netload-plugin/no-sysctl.patch
@@ -0,0 +1,11 @@
+diff -Nurd xfce4-netload-plugin-1.3.1/panel-plugin/os.h xfce4-netload-plugin-1.3.1.new/panel-plugin/os.h
+--- xfce4-netload-plugin-1.3.1/panel-plugin/os.h 2014-10-26 10:26:36.000000000 -0500
++++ xfce4-netload-plugin-1.3.1.new/panel-plugin/os.h 2018-09-08 18:22:36.103957974 -0500
+@@ -170,7 +170,6 @@
+ #elif __linux__ /* L I N U X */
+ # include <stdio.h>
+ # include <sys/param.h>
+-# include <sys/sysctl.h>
+ # include <stdlib.h>
+ # include <stdarg.h>
+ # include <unistd.h>
diff --git a/user/xfce4-pulseaudio-plugin/APKBUILD b/user/xfce4-pulseaudio-plugin/APKBUILD
new file mode 100644
index 000000000..8a1e6cb34
--- /dev/null
+++ b/user/xfce4-pulseaudio-plugin/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-pulseaudio-plugin
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="Pulseaudio plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev pulseaudio-dev
+ keybinder-3.0-dev libnotify-dev dbus-glib-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-pulseaudio-plugin/0.4/xfce4-pulseaudio-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e7b778c78ede9ad62afaa379941ce03636a79dd000e40e748079d3e0f3c71f2e68e32cf85e527be4e1192074652714db4b7c5707b727066198c2ea43184a71cc xfce4-pulseaudio-plugin-0.4.1.tar.bz2"
diff --git a/user/xfce4-sensors-plugin/APKBUILD b/user/xfce4-sensors-plugin/APKBUILD
new file mode 100644
index 000000000..376b6786d
--- /dev/null
+++ b/user/xfce4-sensors-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-sensors-plugin
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="Hardware sensor monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-sensors-plugin/1.3/xfce4-sensors-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="77f6df354c883f9f0b99856738e0976e7bddd5f16c90a8715777c4f4d6debe116cdc21c2e0efbbe9f371d36f9469797d3e631854c33f8561e3ff32291cdef35a xfce4-sensors-plugin-1.3.0.tar.bz2"
diff --git a/user/xfce4-systemload-plugin/APKBUILD b/user/xfce4-systemload-plugin/APKBUILD
new file mode 100644
index 000000000..7cfcf6656
--- /dev/null
+++ b/user/xfce4-systemload-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-systemload-plugin
+pkgver=1.2.1
+pkgrel=0
+pkgdesc="System load monitor plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="BSD-2-Clause"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-systemload-plugin/1.2/xfce4-systemload-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="01e57d799731a5860f043339ff0e90e0967ac1bda91d9f500d657ea14f3a52f31d9dd68ef5293f7941ef93e26e48af72de22aef976d0ccd497c62096e1aaf0b9 xfce4-systemload-plugin-1.2.1.tar.bz2"
diff --git a/user/xfce4-time-out-plugin/APKBUILD b/user/xfce4-time-out-plugin/APKBUILD
new file mode 100644
index 000000000..910bd6425
--- /dev/null
+++ b/user/xfce4-time-out-plugin/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-time-out-plugin
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Forced computer break plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-time-out-plugin/1.0/xfce4-time-out-plugin-$pkgver.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ chmod a+w config.sub
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3f49664fc8fd947627e40de0338e3a115806045c97fa08fd678fdbb831947bcfe14c02e9961d671ce7546d4913fd9319322476df590a70458bdf86fa3bd43464 xfce4-time-out-plugin-1.0.2.tar.bz2"
diff --git a/user/xfce4-timer-plugin/APKBUILD b/user/xfce4-timer-plugin/APKBUILD
new file mode 100644
index 000000000..6e76d0772
--- /dev/null
+++ b/user/xfce4-timer-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-timer-plugin
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Timer plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-timer-plugin/1.7/xfce4-timer-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b4d00396f5be37d009cdb50baea8804c4b06a6f0b821d66751fd07ca21e186c01bafeec5170209b5de69559803e0ac54d9b56266f193b65ac056cdd52bf5228e xfce4-timer-plugin-1.7.0.tar.bz2"
diff --git a/user/xfce4-verve-plugin/APKBUILD b/user/xfce4-verve-plugin/APKBUILD
new file mode 100644
index 000000000..b4b386853
--- /dev/null
+++ b/user/xfce4-verve-plugin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-verve-plugin
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Command-line plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+license="GPL-2.0+"
+makedepends="intltool libxfce4ui-dev xfce4-panel-dev"
+subpackages="$pkgname-lang"
+langdir="/usr/lib/locale"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-verve-plugin/2.0/xfce4-verve-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b6be658f5996857e1c5696dc66f973fa5875ba95682297ad157e107abae821023cdf7101ba5f8e5358740549e392b76bf7d1dae252f43bf1a7e8716d798ed39a xfce4-verve-plugin-2.0.0.tar.bz2"
diff --git a/user/xfce4-whiskermenu-plugin/APKBUILD b/user/xfce4-whiskermenu-plugin/APKBUILD
new file mode 100644
index 000000000..7aa9b05af
--- /dev/null
+++ b/user/xfce4-whiskermenu-plugin/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=xfce4-whiskermenu-plugin
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="Whisker menu plugin for the XFCE panel"
+url="https://xfce.org"
+arch="all"
+options="!check" # no tests
+license="GPL-2.0+"
+makedepends="gtk+3.0-dev exo-dev garcon-dev xfce4-panel-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/xfce4-whiskermenu-plugin/2.2/xfce4-whiskermenu-plugin-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e5b8ab54b66397d0d956d0ddcf7ab9c7531936fa7413094d4cae99aca8f7fca4659012beceec06c9bd6f1ba7695a3e0955d1fd2f10ebf08cf5701224a5dbeb18 xfce4-whiskermenu-plugin-2.2.1.tar.bz2"