summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-27 18:08:02 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-03-27 18:08:02 -0500
commit80e09123a92a2e304ebae2fedf5743214f0e0180 (patch)
treead2ed5b91c2baf3d8f5315277a9f1dcfad176828 /user
parent69dc201454d93cec1dc13d87e7000c19767b34c6 (diff)
downloadpackages-80e09123a92a2e304ebae2fedf5743214f0e0180.tar.gz
packages-80e09123a92a2e304ebae2fedf5743214f0e0180.tar.bz2
packages-80e09123a92a2e304ebae2fedf5743214f0e0180.tar.xz
packages-80e09123a92a2e304ebae2fedf5743214f0e0180.zip
user/pax -> user/heirloom-pax
Diffstat (limited to 'user')
-rw-r--r--user/heirloom-pax/APKBUILD31
-rw-r--r--user/pax/APKBUILD42
-rw-r--r--user/pax/needed-header.patch11
-rw-r--r--user/pax/pax-20160306-glibc-to-linux.patch38
4 files changed, 31 insertions, 91 deletions
diff --git a/user/heirloom-pax/APKBUILD b/user/heirloom-pax/APKBUILD
new file mode 100644
index 000000000..412ed6f8a
--- /dev/null
+++ b/user/heirloom-pax/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=heirloom-pax
+pkgver=1.0
+pkgrel=0
+pkgdesc="Portable Archive eXchange, the POSIX archival tool"
+url="http://heirloom.sourceforge.net/"
+arch="all"
+options="!check" # No test suite.
+license="Zlib"
+replaces="pax"
+makedepends="bsd-compat-headers bzip2-dev zlib-dev"
+subpackages="$pkgname-doc"
+source="https://distfiles.adelielinux.org/source/${pkgname}-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ make LD="gcc"
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/5bin
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ make install ROOT="$pkgdir"
+ rm -r "$pkgdir"/usr/5bin # we don't need 1992 spec pax
+}
+
+sha512sums="7b0ad20cc51b5bcec9c07e84c603e4891f636944f6f6bd13d3decb0e9d6b23d6164b663468ee2293b37721aae20334774f4e56fd8541ffceee934050e819b642 heirloom-pax-1.0.tar.xz"
diff --git a/user/pax/APKBUILD b/user/pax/APKBUILD
deleted file mode 100644
index 5d59e0280..000000000
--- a/user/pax/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: A. Wilcox <awilfox@adelielinux.org>
-# Maintainer: A. Wilcox <awilfox@adelielinux.org>
-pkgname=pax
-pkgver=20161104
-pkgrel=1
-pkgdesc="Portable Archive eXchange, the POSIX archival tool"
-url="https://www.mirbsd.org/pax.htm"
-arch="all"
-options="!check" # No test suite.
-license="BSD"
-depends_dev="libbsd-dev fts-dev"
-makedepends="$depends_dev"
-subpackages="$pkgname-doc"
-source="http://ftp.debian.org/debian/pool/main/p/$pkgname/${pkgname}_$pkgver.orig.tar.xz
- needed-header.patch
- pax-20160306-glibc-to-linux.patch"
-builddir="$srcdir/$pkgname"
-
-build() {
- cd "$builddir"
- ${CC} ${CPPFLAGS} ${CFLAGS} \
- -DHAVE_STRLCPY -DHAVE_STRMODE -DLONG_OFF_T -DHAVE_LINKAT -DHAVE_SYS_SYSMACROS_H -D_BSD_SOURCE \
- -DPAX_SAFE_PATH=\"/bin:/usr/bin:/usr/local/bin\" \
- $(pkgconf --cflags libbsd) \
- -Wall ${LDFLAGS} *.c -o $pkgname $(pkgconf --libs libbsd) $(pkgconf --libs libfts)
-}
-
-package() {
- cd "$builddir"
-
- install -Dm755 pax "$pkgdir"/usr/bin/pax
- ln -s pax "$pkgdir"/usr/bin/paxcpio
- ln -s pax "$pkgdir"/usr/bin/paxtar
-
- install -Dm644 pax.1 "$pkgdir"/usr/share/man/man1/pax.1
- install -m644 cpio.1 "$pkgdir"/usr/share/man/man1/paxcpio.1
- install -m644 tar.1 "$pkgdir"/usr/share/man/man1/paxtar.1
-}
-
-sha512sums="4ca17a412fde5c0de3ff9820a9a5c7e210e015ccddcc791f0c0936f45471dbbe1e96a97515e65d21e5d36a61b14e920eb3a9181ffeabad801663c812ee084c15 pax_20161104.orig.tar.xz
-f494daeebca58bfc0875138e3b01e1d7b74d982b574b0d06d18244046cd0c0b99d8039a629391a578657489346f580c4eaf347ee43ba78eb1058fadebffef497 needed-header.patch
-96d018bd1be2b0d22c9c5e11a92d8cf7ef9bc72d1b13686e572aa15935f2fda9d507baf1e0eb916fec776c2f9d7bab458c203cab64446eed34b70f544109d1d7 pax-20160306-glibc-to-linux.patch"
diff --git a/user/pax/needed-header.patch b/user/pax/needed-header.patch
deleted file mode 100644
index c91d4dafa..000000000
--- a/user/pax/needed-header.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- pax/pax.h.old 2016-10-25 19:05:17.000000000 +0000
-+++ pax/pax.h 2017-07-29 14:52:09.258899166 +0000
-@@ -41,6 +41,8 @@
- #ifndef MIRCPIO_PAX_H
- #define MIRCPIO_PAX_H "$MirOS: src/bin/pax/pax.h,v 1.17 2016/10/25 19:04:26 tg Exp $"
-
-+#include <sys/types.h>
-+
- /*
- * BSD PAX global data structures and constants.
- */
diff --git a/user/pax/pax-20160306-glibc-to-linux.patch b/user/pax/pax-20160306-glibc-to-linux.patch
deleted file mode 100644
index f864729cc..000000000
--- a/user/pax/pax-20160306-glibc-to-linux.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- pax/cache.c.old 2016-03-06 08:12:52.000000000 -0600
-+++ pax/cache.c 2016-04-17 13:01:26.461307830 -0500
-@@ -195,7 +195,7 @@
- * No entry for this uid, we will add it
- */
- if (!pwopn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setpwent();
- #elif !defined(__INTERIX)
- setpassent(1);
-@@ -265,7 +265,7 @@
- * No entry for this gid, we will add it
- */
- if (!gropn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setgrent();
- #elif !defined(__INTERIX) && !defined(__CYGWIN__)
- setgroupent(1);
-@@ -336,7 +336,7 @@
- }
-
- if (!pwopn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setpwent();
- #elif !defined(__INTERIX)
- setpassent(1);
-@@ -403,7 +403,7 @@
- }
-
- if (!gropn) {
--#if defined(__GLIBC__)
-+#if defined(__GLIBC__) || defined(__linux__)
- setgrent();
- #elif !defined(__INTERIX) && !defined(__CYGWIN__)
- setgroupent(1);