summaryrefslogtreecommitdiff
path: root/user
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2020-03-22 10:34:24 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-03-22 10:34:24 +0000
commit8e8bfad331752ef7dc605c9f7c65e8271f96ddeb (patch)
tree4380e2475d4008c4601a8ed66b0d423948c1bfbc /user
parent98667acf075a3383f3e7a5d1192236630f349ab2 (diff)
parent19029ee5ecc515ace99092975081c6e076416d0d (diff)
downloadpackages-8e8bfad331752ef7dc605c9f7c65e8271f96ddeb.tar.gz
packages-8e8bfad331752ef7dc605c9f7c65e8271f96ddeb.tar.bz2
packages-8e8bfad331752ef7dc605c9f7c65e8271f96ddeb.tar.xz
packages-8e8bfad331752ef7dc605c9f7c65e8271f96ddeb.zip
Merge branch 'sr.2020.03.03' into 'master'
Bumps for Maintainer: Max Rees for 2020.03.03 See merge request adelie/packages!410
Diffstat (limited to 'user')
-rw-r--r--user/alsa-lib/APKBUILD9
-rw-r--r--user/alsa-lib/type_compat.patch23
-rw-r--r--user/alsa-plugins/APKBUILD4
-rw-r--r--user/alsa-utils/APKBUILD4
-rw-r--r--user/ethtool/APKBUILD4
-rw-r--r--user/keepassxc/APKBUILD7
-rw-r--r--user/mosquitto/APKBUILD4
-rw-r--r--user/mutt/APKBUILD4
-rw-r--r--user/tlp/APKBUILD5
-rw-r--r--user/tlp/tlp.post-upgrade14
-rw-r--r--user/youtube-dl/APKBUILD9
-rw-r--r--user/youtube-dl/tumblr.patch49
12 files changed, 116 insertions, 20 deletions
diff --git a/user/alsa-lib/APKBUILD b/user/alsa-lib/APKBUILD
index 4f854e443..49f14066e 100644
--- a/user/alsa-lib/APKBUILD
+++ b/user/alsa-lib/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=alsa-lib
-pkgver=1.2.1.2
+pkgver=1.2.2
pkgrel=0
pkgdesc="Linux sound support system"
url="https://www.alsa-project.org/wiki/Main_Page"
@@ -12,6 +12,7 @@ subpackages="$pkgname-dev $pkgname-dbg"
source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
ucm_add_limits_h.patch
remove-test.patch
+ type_compat.patch
"
build() {
@@ -30,6 +31,7 @@ build() {
rm -rf "$builddir"/include/sound
mkdir "$builddir"/include/sound
printf "all:\ncheck:\ninstall:\n" > "$builddir"/include/sound/Makefile
+
make
}
@@ -41,6 +43,7 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="e8286fd55f63ee0d95513279d0885c287533de89b7af6c338413dec5d38ba4f5a15da1a4a4ce36e052614e4b730e3778782dab9979d82958283be17b48604913 alsa-lib-1.2.1.2.tar.bz2
+sha512sums="d21adb3ff998918c7d1820f9ce2aaf4202dd45ccb87cb092d49da8b2402b6ddaad06325be0fd59f17393a5d9958e3743bfccb4b14bdb947a42e7d791d73c7033 alsa-lib-1.2.2.tar.bz2
3b37652d50809443b5f8e80f8d447108195b0cd66fd917805bb393fc091584b6f3dad4414f568742b61745617e7a695862058a0a0f93dcc31e4c97177a520352 ucm_add_limits_h.patch
-0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch"
+0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch
+bdcfa3d5fcc055fb6732922679e21689fc2ac19462fe7b72d16862c98ef8c995c3dd5becc4987ba417068e6b0e561bec7e6284d5f0a414e2966c8e00ac304fa8 type_compat.patch"
diff --git a/user/alsa-lib/type_compat.patch b/user/alsa-lib/type_compat.patch
new file mode 100644
index 000000000..4236d11d4
--- /dev/null
+++ b/user/alsa-lib/type_compat.patch
@@ -0,0 +1,23 @@
+Since we force the use of the uapi headers from linux-headers instead of
+using the vendored copy, type_compat.h never gets put in the place it
+should be for it to be seen in sound/.
+
+However, the only reason it was included here anyway was to replace a
+definition that was never used:
+
+https://github.com/alsa-project/alsa-lib/commit/ae564665ec261cf104de499b1cdda3564070fc65#diff-5e0b4d8ecf374a31036ffc7b224d5e7fL21
+
+ -#define __packed __attribute__((__packed__))
+ -
+ +#include <sound/type_compat.h>
+
+--- alsa-lib-1.2.2/src/topology/tplg_local.h 2020-02-19 03:35:39.000000000 -0600
++++ alsa-lib-1.2.2/src/topology/tplg_local.h 2020-03-17 01:26:25.159548858 -0500
+@@ -18,7 +18,6 @@
+ #include "list.h"
+ #include "topology.h"
+
+-#include <sound/type_compat.h>
+ #include <sound/asound.h>
+ #include <sound/asoc.h>
+ #include <sound/tlv.h>
diff --git a/user/alsa-plugins/APKBUILD b/user/alsa-plugins/APKBUILD
index 2976ee3f3..ebf39a4cb 100644
--- a/user/alsa-plugins/APKBUILD
+++ b/user/alsa-plugins/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Taner Tas <taner76@gmail.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=alsa-plugins
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=0
pkgdesc="Advanced Linux Sound Architecture (ALSA) plugins"
url="https://www.alsa-project.org/main/index.php/Main_Page"
@@ -60,4 +60,4 @@ a52() {
"$subpkgdir"/usr/share/alsa/alsa.conf.d/
}
-sha512sums="a49ef9290b66855112e301a5fd5a0932f13a50254e164f3340f2b342a36469532ee783beabfe5e95870dbf4cd81ca1e8d0415d94c8c7ee963133fb3c343721de alsa-plugins-1.2.1.tar.bz2"
+sha512sums="25a7dfaa64be024447d889b5cde668f1308d197f54880548a82d50beb4ac0dbff33b415da1e26dc5229408c934247a9bd38acfb0f82ca388deac0d77ab3cdadb alsa-plugins-1.2.2.tar.bz2"
diff --git a/user/alsa-utils/APKBUILD b/user/alsa-utils/APKBUILD
index 85811417f..569e8d6a4 100644
--- a/user/alsa-utils/APKBUILD
+++ b/user/alsa-utils/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=alsa-utils
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=0
pkgdesc="Advanced Linux Sound Architecture (ALSA) utilities"
url="https://www.alsa-project.org/wiki/Main_Page"
@@ -36,7 +36,7 @@ package() {
install -Dm644 ../alsa.confd "$pkgdir"/etc/conf.d/alsa
}
-sha512sums="b7729659cd9809197dc30042f522f5103ff41ddc047f13f9c733c93f7e91a26f90cd864c70e654d12ef7a552b1d9ebe2727a24ec9fad03560cb7cdea906662ec alsa-utils-1.2.1.tar.bz2
+sha512sums="30598c658f3f2ad71a5ce7911b09ae13add54b293bcf3bebb053371d84a91528bd64fd376f167456b2e27e2546a2279019678e099247513e5142b283af756fd9 alsa-utils-1.2.2.tar.bz2
817215be6e9f103a8a187df5b1142c4d2e952f547a64579a9b8cfa58bd762d6a55bde75c0f66f018c0597744d07ccdb08216f7b368db464e36667cecedcc00f3 alsaconf.patch
7bf743024d7c5caed2fbf8af5cee73bcc569a7bab0bd6459541d3704cc6a7456d588b600b690e7406e122deaf0316dd1f67219a267bec4dff3f6c0f120edaae4 alsa.initd
6e716e6230fd3d2c33e3cb2dbf572d632c9ac6452c1768388bea7d3ca22f7c72cf6bcd702580f45cb9089983582011c8b04cbdb4420d14fb988167b1391ea547 alsa.confd"
diff --git a/user/ethtool/APKBUILD b/user/ethtool/APKBUILD
index 0f899072c..984066d58 100644
--- a/user/ethtool/APKBUILD
+++ b/user/ethtool/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=ethtool
-pkgver=5.3
+pkgver=5.4
pkgrel=0
pkgdesc="Utility for controlling network drivers and hardware"
url="https://mirrors.edge.kernel.org/pub/software/network/ethtool/"
@@ -40,4 +40,4 @@ bashcomp() {
mv "$pkgdir"/usr/share/bash-completion/ "$subpkgdir"/usr/share/
}
-sha512sums="ad3651f74850e6773489baec27c51d077e3c080eb1d536a585ae05c618304880caf7598df5c9b1416c47ae9c4eac301032f6ea65fe47650dd9ecb7603c1857b0 ethtool-5.3.tar.xz"
+sha512sums="c7bfe7eae2ba207d710716274e9f5ae275c57d0bebc0a9acb95677125e64f1b42ef610032011fb59894aab46973988bad40fddbc5ccc238893e7da66f913255b ethtool-5.4.tar.xz"
diff --git a/user/keepassxc/APKBUILD b/user/keepassxc/APKBUILD
index 739ee75db..4aa4ecff3 100644
--- a/user/keepassxc/APKBUILD
+++ b/user/keepassxc/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=keepassxc
-pkgver=2.4.3
+pkgver=2.5.3
pkgrel=0
pkgdesc="A community revival of the KeePassX password manager"
url="https://keepassxc.org"
@@ -19,6 +19,9 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DWITH_XC_BROWSER=bool:ON \
+ -DWITH_XC_FDOSECRETS=bool:ON \
+ -DWITH_XC_SSHAGENT=bool:ON \
-Bbuild
make -C build
}
@@ -31,4 +34,4 @@ package() {
make DESTDIR="$pkgdir" -C build install
}
-sha512sums="893f1d18ab8051143d29c568ba87adcc42a13d28d0c3a7af04396cd91d6724f8a98d76d2e20ca15138c4642ec060d48b9e957857251f3a0df6066af08cd0765d keepassxc-2.4.3-src.tar.xz"
+sha512sums="8b1e3360b4ae5de170be6936291f7b309de09b2462fcd5a48f239c22f1c8b6ffe721aca8d1e9b6ae3881f7b16374850d7f4b809733244fd16d45eed6ad4f60c6 keepassxc-2.5.3-src.tar.xz"
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 7e19f62f4..67ec942a1 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.8
+pkgver=1.6.9
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
@@ -74,7 +74,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="c15897df4e0979ee29a1e67cc671f56db600a078e9eb0bea376248b3f53b13ceed36616ad3678e2c9e07d6834a6d75e4efca2c40086069c1546e0223be04c071 mosquitto-1.6.8.tar.gz
+sha512sums="f78228a1e8305e4d89b34250981ed2c5fe5317636003636dc90f6fa2b1e3ca3c8fadb705ee7301f5252456cb093a6547bd46a255ca3d9fb5cdced697738d6eb7 mosquitto-1.6.9.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
3886171e36f759a717aa6626d5b8dbd392963c737d5de28b4d52b81359008927b99ff7a0ca82f56a0e5deaed4585571759ba9216336a664fd346845837c2bc18 disable-flaky-test.patch
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
diff --git a/user/mutt/APKBUILD b/user/mutt/APKBUILD
index 505d0c869..09b0f49d3 100644
--- a/user/mutt/APKBUILD
+++ b/user/mutt/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mutt
-pkgver=1.13.2
+pkgver=1.13.4
pkgrel=0
pkgdesc="Small but very powerful text-mode email client"
url="http://www.mutt.org" # No HTTPS
@@ -57,4 +57,4 @@ package() {
"$pkgdir"/etc/Muttrc.gpg.dist
}
-sha512sums="af6eb8d2125dc49391392f350ec44203824a0cea2856ca194e7f8f534e598049185c813a56053491fda221042d1508a48cf46b2167e2ebf44af7b69938dcb829 mutt-1.13.2.tar.gz"
+sha512sums="59ae13d7cef052818f38f6d52e2cb42251f393ecf622eae113bfa29218b541195471de822efbdb072c6f74a4dc385bb94fe27c37b44c62eac7e2a0a4e0c6adc3 mutt-1.13.4.tar.gz"
diff --git a/user/tlp/APKBUILD b/user/tlp/APKBUILD
index 40613efd9..ca7208b5e 100644
--- a/user/tlp/APKBUILD
+++ b/user/tlp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=tlp
_pkgname=TLP
-pkgver=1.2.2
+pkgver=1.3.1
pkgrel=0
pkgdesc="Linux Advanced Power Management"
url="https://linrunner.de/en/tlp/tlp.html"
@@ -13,6 +13,7 @@ depends="/bin/sh perl"
makedepends=""
subpackages="$pkgname-doc $pkgname-rdw $pkgname-bash-completion:bashcomp
$pkgname-openrc"
+install="$pkgname.post-upgrade"
source="$pkgname-$pkgver.tar.gz::https://github.com/linrunner/$_pkgname/archive/$pkgver.tar.gz
$pkgname.initd"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -48,5 +49,5 @@ bashcomp() {
"$subpkgdir"/usr/share/bash-completion/completions
}
-sha512sums="b01fc2063bf8a87f2b93749c08a5cab53a0a4030b74c7fe62964009fb9d54ca5dc10800971f27cfe6dcdf024ba6d3e21a06caed07e8dc12b09d9d359585a480e tlp-1.2.2.tar.gz
+sha512sums="7ebb14ea797ad8aae613c537de51107a3c7430b5c6ee1407e722e2069ed5376f88ab3dac613651fafabd92d219b980452f236bef33e8a655b1abbfed5eded1b1 tlp-1.3.1.tar.gz
e6de216b2540413812711b3304cdc29c8729d527080cfd747ba382db50166dd21c6c27ff467f9f2a967e92007c7a311b00e88262952c34a22f417578c66cf4e7 tlp.initd"
diff --git a/user/tlp/tlp.post-upgrade b/user/tlp/tlp.post-upgrade
new file mode 100644
index 000000000..6adf68850
--- /dev/null
+++ b/user/tlp/tlp.post-upgrade
@@ -0,0 +1,14 @@
+#!/bin/sh
+ver_new="$1"
+ver_old="$2"
+
+if [ "$(apk version -t "$ver_old" "1.3.1")" = "<" ]; then
+ cat >&2 <<-EOF
+ *
+ * tlp has moved its configuration from '/etc/default/tlp'
+ * to '/etc/tlp.conf' and '/etc/tlp.d'. Additionally,
+ * these configuration files are now parsed instead of
+ * executed via the shell, so expansions will no longer work.
+ *
+ EOF
+fi
diff --git a/user/youtube-dl/APKBUILD b/user/youtube-dl/APKBUILD
index 70c5800f9..ed99fcb7b 100644
--- a/user/youtube-dl/APKBUILD
+++ b/user/youtube-dl/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=youtube-dl
-pkgver=2019.11.28
+pkgver=2020.03.08
pkgrel=0
pkgdesc="Command-line program to download videos from YouTube and many other sites"
url="https://youtube-dl.org"
@@ -16,7 +16,9 @@ subpackages="$pkgname-doc
$pkgname-zsh-completion:zshcomp
$pkgname-bash-completion:bashcomp
$pkgname-fish-completion:fishcomp"
-source="https://github.com/rg3/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/rg3/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ tumblr.patch
+ "
builddir="$srcdir/$pkgname"
prepare() {
@@ -64,4 +66,5 @@ fishcomp() {
"$subpkgdir/usr/share/fish/completions/"
}
-sha512sums="fd3fc9658428ecf96d681dd699db49e02f94343e5c49e370cb68a5764e8ecebc14b3ce5bc44db0a829b0d3c4fbffc96a1f8288fb24cbd21add6e9c7852b0915d youtube-dl-2019.11.28.tar.gz"
+sha512sums="09636e3ec526dbcb043cf61ed4dda5c5c00fac2ecd741bf3cb338ca8de72d1395a95a6189bccced140ca1c37eb3f693332e757ff01eb1a25279b100ccdf39b65 youtube-dl-2020.03.08.tar.gz
+5760d06e6bbc1eee2c6be2d1f580f86b3cfa5f4bc44a62fb8145ce1cd41352ecf2f65d65d79a2d7f1ec129a34c28a7ec3d0d328c907e743bfcea54c65c71285d tumblr.patch"
diff --git a/user/youtube-dl/tumblr.patch b/user/youtube-dl/tumblr.patch
new file mode 100644
index 000000000..d34a79da6
--- /dev/null
+++ b/user/youtube-dl/tumblr.patch
@@ -0,0 +1,49 @@
+From a4a199b4dcc3e778621c4268a5dba615cf6f44ba Mon Sep 17 00:00:00 2001
+From: rafinetiz <rafii.netizz@gmail.com>
+Date: Fri, 18 Oct 2019 21:17:00 +0700
+Subject: [PATCH 1/2] Fix tumblr permission denied #22755
+
+---
+ youtube_dl/extractor/tumblr.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/youtube_dl/extractor/tumblr.py b/youtube_dl/extractor/tumblr.py
+index edbb0aa6944b..71ced801859e 100644
+--- a/youtube_dl/extractor/tumblr.py
++++ b/youtube_dl/extractor/tumblr.py
+@@ -165,7 +165,8 @@ def _real_extract(self, url):
+ if iframe_url is None:
+ return self.url_result(redirect_url, 'Generic')
+
+- iframe = self._download_webpage(iframe_url, video_id, 'Downloading iframe page')
++ iframe = self._download_webpage(iframe_url, video_id, 'Downloading iframe page',
++ headers={'Referer': url})
+
+ duration = None
+ sources = []
+
+From 43a19105d78c5c297d91936798d341f89919e9b1 Mon Sep 17 00:00:00 2001
+From: rafinetiz <rafii.netizz@gmail.com>
+Date: Fri, 18 Oct 2019 21:45:12 +0700
+Subject: [PATCH 2/2] Fix coding style
+
+---
+ youtube_dl/extractor/tumblr.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/youtube_dl/extractor/tumblr.py b/youtube_dl/extractor/tumblr.py
+index 71ced801859e..61b0c1db65fe 100644
+--- a/youtube_dl/extractor/tumblr.py
++++ b/youtube_dl/extractor/tumblr.py
+@@ -165,7 +165,10 @@ def _real_extract(self, url):
+ if iframe_url is None:
+ return self.url_result(redirect_url, 'Generic')
+
+- iframe = self._download_webpage(iframe_url, video_id, 'Downloading iframe page',
++ iframe = self._download_webpage(
++ iframe_url,
++ video_id,
++ 'Downloading iframe page',
+ headers={'Referer': url})
+
+ duration = None